Previous 1 2 3 4 Next 57 Replies Latest reply: Nov 16, 2014 10:48 AM by Wyoming Imac
susanfromplainfield Level 1 Level 1 (0 points)

I am using iPhoto '09 and I am running OS X 10.6.8.  I have created a folder on my desktop in which I was to export 312 photos to using the title for the filename.  When I go to File > Export and set the option is starts running and then all of a sudden stop with the message "Unable to create /users/...".  I have tried having it export to the desktop and I still get he message.  I have even created the folder it's to export to. No matter where I export to or how I do it it still only exports 45 of the 312 photos.  If I have it name the file sequentially it did 174. 

 

I think this means that the error is being cause from iPhoto trying to rename the photos.  We wanted to use the title so we can send these photos as they are photos of great grandparents etc.

 

Anyone know how to resolve this issue?

 

Thank you


iPhoto '08, Mac OS X (10.6.8), Really it's iPhoto '09
  • Old Toad Level 10 Level 10 (122,340 points)

    Any unusual/non-standard characters  in the title that you're using?  Have you tried a diffrerent title? Can you successfully export using the original file name?  If so a workaround would be to use a renaming application to post rename them.

     

    OT

  • susanfromplainfield Level 1 Level 1 (0 points)

    I get the same error if ...

     

    I use the original filename

    I use the iPhoto title

    I use the sequential option

  • Old Toad Level 10 Level 10 (122,340 points)

    OK.  Try the following: make a temporary, backup copy (select the library and type Command+D) and  apply the two fixes below in order as needed:

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

     

    Since only one option can be run at a time start with Option #1, followed by #3 and then #4 as needed.

     

    If #1 fails continue with:

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.
      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option
      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

  • malikons Level 1 Level 1 (0 points)

    I had the same problem. I tried all the possble workarounds I could find on Apple forums but to no avail. Then I started narrowing down the issue and found the file causing this 'unable to create' error. It was a .PNG file. I opened iPhoto, clicked the search button at the buttom left side, and typed 'PNG' (without quotes), it gave me all the PNG files in my iPhoto Library. Those were all some random graphic files, and some screenshots I took from my iPhone. cmd+a to select all the displayed PNG files and deleted them. I closed and reopened iPhoto. Emptied my iPhoto trash and tried the export again, it worked like a charm. Not sure if it'd help you, but that is indeed what helped me. Might be a worth a try.

     

    Good Luck!

  • Marina P Level 1 Level 1 (85 points)

    Had the same issue (under Lion). Fix #1 didn't do the trick but Fix #2 did. Many thanks!

  • roy_bilko Level 1 Level 1 (0 points)

    Thanks very much – PNG trick nailed it.

  • tmoney15 Level 1 Level 1 (0 points)

    Another thing that I found causing problems were movie files in format .mp4. You will want to check for all files types not just .png file types in your library, although .png is a good start. Hope this helps.

  • susanfromplainfield Level 1 Level 1 (0 points)

    We found a scanned file that was a jp2 format and it was causing all the problems!

  • tmoney15 Level 1 Level 1 (0 points)

    Actually I just found that it was easier (and much faster) to just copy and paste all the items in iPhoto that I wanted to move to a new location, in my case external hard drive. Then there is no dealing with file types they all get transfered.

     

    Hope that helps. 

  • Terence Devlin Level 10 Level 10 (129,365 points)

    The problem there is that you're only getting your iPhoto Previews, and missing lots of metadata.

  • scandium Level 1 Level 1 (0 points)

    Had the same problem.  What worked for me was to drag the photos I wanted to export out of the iPhoto window and drop them into the target Finder window.  Some files showed up as zero kb files.  Those were probably the cause of the problem.  I tried exporting a set of different photos and had no problem.

  • k1mu Level 1 Level 1 (0 points)

    I've found that this is due to a defect in iPhoto on OSX Lion.

     

    If you select a set of photos to export, and any of them happen to be videos, iPhoto terminates the export with the "Unable to create /users/username/..." error message. There's no indication what file is causing the problem, and rebuilding the iPhoto database doesn't fix it.

     

    I've been doing the same kind of export (to put photos onto a sdcard for my photo frame) for years. To get it to work with the current version of iPhoto, I had to find each movie file and delete it.

     

    Older versions of iPhoto would export the offending file in the original format. I'd be happy if Lion was to simply skip the bad files. Or, at least provided something useful to help identify what file is causing the problem.

  • Old Toad Level 10 Level 10 (122,340 points)

    If you select a set of photos to export, and any of them happen to be videos, iPhoto terminates the export with the "Unable to create /users/username/..." error message.

    Even if you use the File ➙ Export ➙ Export File menu option with Kind = Original selected?

  • k1mu Level 1 Level 1 (0 points)

    If you use the "Kind=Original" setting, then you can't select JPEG quality or file size, so you get everything at full size. That's great if you want huge files, but I want to be able to do a JPEG export while controlling export options so I can control the size of the export. (a 16Gb export is what I get using "Kind=Original", while it consumes around 1 Gb with medium quality - which is quite adequate for my photo frame.)

     

    When I choose "Kind=JPEG", the current behavior of failing without a useful error message is really a bad idea.

     

    Effectively, iPhoto is telling me that "one of the 4,700 files in your library isn't a .jpeg. Good luck with finding it. Oh, and the next time you try the export and I run into another video, I won't tell you about that file either. Deal."  That's a serious regression from earlier versions of iPhoto.

     

    To fix this required me to visually scan almost 5000 files looking for videos (the video length shows up in the lower left corner), then multiple exports until it finally succeded. I found the videos by looking at the last successful pictures, then figuring out what album they were in and using that to find and delete the videos. It took me probably 30 tries to find and delete them all.

Previous 1 2 3 4 Next