Previous 1 2 3 4 5 6 Next 86 Replies Latest reply: Nov 7, 2015 10:26 AM by c_buck88 Go to original post
  • folksong Level 1 (120 points)

    The Gutenprint drivers are grayscale only for laser printers.  If you look back earlier in this thread, you will find that the pxlmono/pxlcolor drivers at

    http://www.linuxfoundation.org/collaborate/workgroups/openprinting/macosx/pxlmon o

    will allow you to print in color.  Be sure to download and install all three packages - pxlmono, Foomatic-RIP, and Ghostscript.

  • tripwalking Level 1 (0 points)

    Hi folks, this has been very helpful information. I'm still having an issue actually connecting to my printer (Ricoh MP5500). I had this all working for maybe a year, and then two weeks ago my Internet went down and I just got it back. Now I can't print to that Ricoh. I've reinstalled the three files, but when I go to add the printer it says "Unable to verify the printer on your network. Unable to connect to xxx.xxx.xxx.xxx due to an error. Would you still like to create the printer?"

    Any suggestions?

     

    Thanks very much

    dw

  • abidiar Level 1 (0 points)

    Hey Everyone,

     

    I just wanted to confirm that this worked for me as well!

  • tripwalking Level 1 (0 points)

    Just found a PS card for my Aficio MP 5500 on ebay for $60. No brainer. I've spent probably two full days working on this.

  • jmillet89 Level 1 (0 points)

    When I run into the issue of a Ricoh printing out like 40 pages of garbage with a postscript driver, I typically set up the printer by IP with HP Jetdirect and the PCL driver like below:

     

    Screen Shot 2014-09-04 at 8.56.13 AM.png

    Works fine for printing after that.

  • oncezaidi Level 1 (0 points)

    I also facing the same problem during printing on Ricoh Aficio MP C5000 from my macbook pro OS X 10.9.5. Any advise from the expertise here?

  • oncezaidi Level 1 (0 points)

    I also facing the same problem during printing on Ricoh Aficio MP C5000 from my macbook pro OS X 10.9.5. Any advise from the expertise here?

  • folksong Level 1 (120 points)

    The Ricoh MP C5000 comes equipped with PCL 5/6 as standard languages.  PostScript is an available option.  To use this printer with a Mac, use the pxlmono drivers mentioned several times in this thread. http://www.linuxfoundation.org/collaborate/workgroups/openprinting/macosx/pxlmon o

  • Christopher R Gillespie Level 1 (5 points)

    FWIW: Foomatic-RIP is being sandboxed now in 10.10 Yosemite Beta. My previously working Rico Aficio MP C2050 no longer can print. Console reports "filter failed."

    foomatic-rip(14574) deny file-read-data /usr/local/etc/foomatic/filter.conf Process:        foomatic-rip [14574] Path:            /usr/libexec/cups/filter/foomatic-rip Load Address:    0x100000000 Identifier:      foomatic-rip Version:        ??? (???) Code Type:      x86_64 (Native) Parent Process:  cupsd [9759] Date/Time:      2014-09-24 07:56:50.372 -0500 OS Version:      Mac OS X 10.10 (14A361p) Report Version:  8 Thread 0: 0  libsystem_kernel.dylib        0x00007fff9302200e __open_nocancel + 10 1  foomatic-rip                  0x0000000100000f70 config_from_file + 37 2  foomatic-rip                  0x00000001000026ca main + 386 3  foomatic-rip                  0x00000001000009f4 start + 52 Binary Images:       0x100000000 -        0x100019fff  foomatic-rip /usr/libexec/cups/filter/foomatic-rip     0x7fff9300c000 -    0x7fff93029fff  libsystem_kernel.dylib (2782.1.96)/usr/lib/system/libsystem_kernel.dylib
  • kiwiandy Level 1 (0 points)

    I found the answer to my problem on the Macrumours forum.. the following solves my problem and am printing in Color now.

    http://forums.macrumors.com/showthread.php?t=879721

    Download the following in this order and install from here:

     

    http://www.linuxfoundation.org/colla...macosx/pxlmono

     

    Ghostscript for Mac OS X 10.3.x (Panther) - Mac OS X 10.6.x (Snow Leopard)

    Foomatic-RIP for Mac OS X 10.3.x (Panther) - Mac OS X 10.6.x (Snow Leopard)

    pxlmono 1.6 for Mac OS X 10.3.x (Panther) - Mac OS X 10.6.x (Snow Leopard)

     

    Once installed add your printer and use the following driver Ricoh Aficio MX C2500 PXL and you should have a fully working colour printer:

     

    Good luck and enjoy.

  • JHahn7837 Level 1 (0 points)

    Any chance of foomatic getting updated to play nice in Yosemite?  I have a Konica Minolta 2300w that won't print now (filter failed).

  • Christopher R Gillespie Level 1 (5 points)

    I was going through System Information and compared a working printer to the Ricoh using foomatic-rip. Here's the screenshots:

     

    Screenshot 2014-10-20 18.12.05.png

    Now compare:

     

    Screenshot 2014-10-20 18.13.56.png

    Someone more capable than I can explain how to correct the CUPS filter permissions.

     

    +crg

  • tifi_tifi Level 1 (0 points)

    Hi there,

    i installed the 3 pxlmono packages. The printer is shown as online. When i tried to print, the job seems to be send to the printer, but nothing is happen. No respons of the printer, no error massage. The job appears short in the printer quere and disappears as if it was sent correctly.

     

    I'm running on Mac OS X 10.10 Yosemite

     

    Any idears?

     

    THX

     

    tifi

  • kiwiandy Level 1 (0 points)

    The pxlmono packages dont appear to work under 10.10

    I upgraded to 10.10 yesterday and among several other things that were broken, I had the exact same issue as you.. it would pint to the printer, but no output

    I have reinstalled 10.9 now, and everything is working again.

  • fgeurts Level 1 (0 points)

    Hi

     

    Same for me. Cannot print to my Ricoh MPC 2500 anymore since 10.10. Sad.

     

    Have a nice day