1 2 3 4 Previous Next 56 Replies Latest reply: Oct 31, 2013 5:44 AM by Mookie Merkk
deperkins Level 1 Level 1 (10 points)

I just installed Windows 8 via boot camp on my mid-2009 MacBook Pro.  Install went fine, installed over Win 7.  Everything was working ok, except for trackpad.  I rebooted into Mountain Lion and downloaded the latest boot camp drivers.  I rebooted again into Windows 8.  Once I got to the login screen, the built-in keyboard would not work.  A wired keyboard would not work either.  My magic mouse was the only thing that did work.  The problem...I have a password set and can't login if the keyboard doesn't work.  Help!


MacBook Pro, OS X Mountain Lion (10.8.1)
  • 1. Re: MacBook Pro Keyboard doesn't work in Windows 8
    The hatter Level 9 Level 9 (58,880 points)

    trackpad work. You need to install trackpad++

    (http://www.techspot.com/downloads/4967-trackpad-control-module.html), it will enable the trackpad driver on boot camp. After you install the trackpad++, trackpad++ will complain something. ingnore it.  You should be able to enable trackpad. And you can now even uninstall the  trackpad++, the trackpad will sill work.

    Also,

    went into Device Manager and on the two "Touchpad" entries with the bang on them, went to "Update Driver" -> "Browse My Computer" -> "Let me pick from a list..." and changed them both to USB Input Device. Reboot.

    Go back to Device Manager, do an "Update Driver" again, let it search automatically, and one comes back as Apple Multitouch and the other as Apple Multitouch Mouse. Rebooted again, trackpad working and shows up in Boot Camp control panel.

  • 2. Re: MacBook Pro Keyboard doesn't work in Windows 8
    deperkins Level 1 Level 1 (10 points)

    Thanks for the response, but unfortunately I currently can't install anything.  When I boot into Windows, I'm stuck at the login screen.  I need to enter my password, however I am unable to because the built-in keyboard does not work. I even tried a wired keyboard and that doesn't work either.  It detects caps lock if I turn that on.  It doesn't make any sense to me.  I went through the install and used the keyboard to type in settings with no problem.  Now, nothing.

  • 3. Re: MacBook Pro Keyboard doesn't work in Windows 8
    deperkins Level 1 Level 1 (10 points)

    Somehow when I boot up now, I can type.  Not sure how that happened.  Anyway, I did install trackpadd++ so my trackpad works now.  I ran a repair on my boot camp drivers so hopefully that'll solve it.

  • 4. Re: MacBook Pro Keyboard doesn't work in Windows 8
    deperkins Level 1 Level 1 (10 points)

    Unfortunately, my problem persists.  I was able to remove the password from my account so I can boot up and get into Windows with no problem.  About 7 times out of 10 the keyboard fails to load, resulting in no use of the keyboard at all.  I went against my better judgement by installing Wndows 8. I guess I should have waited until Apple officially supported it. :-/

  • 5. Re: MacBook Pro Keyboard doesn't work in Windows 8
    The hatter Level 9 Level 9 (58,880 points)

    Installing over an old should work, but it is never ideal or recommended.

     

    You did need to have 30GB free space to perform the upgrade.

     

    And you can rollback and use Windows 7.

     

    Installing 'new' Apple drivers also does not always go well.

    Uninstall and then install. But you're on a new OS so you would have had to install Apple drivers.

     

    I don't think your keyboard is a Wndows 8 issue at all.

     

    If you kept to Windows 8, there is 20GB or so you can delete Disk Cleanup: Options: System Files.

     

    The ideal of course is to boot Windows 8 DVD and format the partition (again) and install - maybe that is what you did. It is also though possible to go different route from within Windows 7.

  • 6. Re: MacBook Pro Keyboard doesn't work in Windows 8
    deperkins Level 1 Level 1 (10 points)

    I decided to check on uptes for third party software that ran on startup.  The only third party app that ran on startup was Dropbox.  There was a minor update to it, so Iupdated.  While I love Dropbox's "quite" updating system, it's just a little too slow my liking. Anyway, since that update all has been working well.  I'll keep you posted if it happens again.  I've had three successful boots in a row since updating.

  • 7. Re: MacBook Pro Keyboard doesn't work in Windows 8
    The hatter Level 9 Level 9 (58,880 points)

    DropBox has unfortunately been in the news of late that tarnished its security image and now has double authentication.

     

    I've run into problems with updates where I had to uninstall the program and just do manual download and install a new version.

     

    Windows 8 Enterprise does not have the issues though that RP and earlier suffered.

  • 8. Re: MacBook Pro Keyboard doesn't work in Windows 8
    Ryblack Level 1 Level 1 (10 points)

    How did u managed to type in the password in the end? I have the same problem now, can't login as I can't type the password..Caplocks can be detected!

  • 9. Re: MacBook Pro Keyboard doesn't work in Windows 8
    deperkins Level 1 Level 1 (10 points)

    About 9 times out of 10, the keyboard wouldn't work.  The 1 time that it did, I logged in and removed the password.  Updating Dropbox seemed to solve my issue and it had been fine for over a month.  However, over this past weekend I decided to install the new Trackpad++ drivers to enable gestures in Win 8.  After installing PowerPlan and then Trackpad++, everything was working ok.  I decided at this point, I would set a password for the account again.  Once I did that, I was back to having keyboard problems again.  When I finially was able to get in, I removed the password.  Upon a reboot, the keyboard didn't work.  I removed PowerPlan and Trackpad++, still didn't work.  I uninstalled Dropbox...still didn't work.  I disabled all 3rd party startup applications, and it still didn't work.  I got fed up, and last night I wiped out Win 8 and reloaded Win 7.  I'll wait until Apple officially supports it, and even after that, I'll give it some time before upgrading again. 

     

    I will note that when I upgraded to Win 8, I did not do a clean install.  I didn't want to go through the hassle of reloading software and setting up the OS again.  Maybe a clean install would have been better.  I was at the point of frustration where I didn't even care to find out and I was just going to go back to Win 7.

     

    Sorry that I'm no help. If you figure anything out, let me know.

  • 10. Re: MacBook Pro Keyboard doesn't work in Windows 8
    Chiantii Level 1 Level 1 (0 points)

    Just to add to the discussion,

     

    I tried an upgrade from Windows 7 to Windows 8 and had the same issue with the keyboard not working. Not only that, but NO keyboard would work. I tried plugging in several USB keyboards and nothing worked. Only a clean install of Windows 8 fixed the issue.

  • 11. Re: MacBook Pro Keyboard doesn't work in Windows 8
    Ryblack Level 1 Level 1 (10 points)

    tried restarting and shut down more than 10 times and still not managed to type. i removed the partition

  • 12. Re: MacBook Pro Keyboard doesn't work in Windows 8
    deperkins Level 1 Level 1 (10 points)

    Are you going to do a clean install of Win 8?  If so, let me know how it goes. 

  • 13. Re: MacBook Pro Keyboard doesn't work in Windows 8
    Ryblack Level 1 Level 1 (10 points)

    Nope, i'll only install windows 8 until bootcamp is compatible with it

  • 14. Re: MacBook Pro Keyboard doesn't work in Windows 8
    hminaya Level 1 Level 1 (0 points)

    I did a clean install and have the same problem, I guess I will be going back to win 7

1 2 3 4 Previous Next