Previous 1 2 Next 17 Replies Latest reply: Jul 1, 2014 3:09 AM by jgoldschmidt
jshuldawg Level 1 Level 1 (0 points)

I recently downloaded Apple Configurator and upon setup, I entered an apple ID.  Now I was told that was the incorrect Apple ID for the VPP.  How do I change the apple ID In Configurator?

  • nsdjoey Level 3 Level 3 (880 points)

    Unfortunately, the menu option that was available in earlier versions of Apple Configurator is no longer available But here's how I've been doing it using the latest Apple Configurator 1.1.2.

     

    First, go into iTunes and authorize with an Apple ID (iTunes -> Store -> Authroize this computer). It doesn't have to be a VPP Apple ID…just an ordinary Apple ID used to associate with the app. Then download the app(s). They will go to ~/Music/iTunes/Mobile Applications. These apps will be linked to the Apple ID you authorized in iTunes. Next go into Apple Configurator and add the apps on the Prepare -> Apps screen. When you try to add the app in AC (clicking on the "+" at the bottom of the screen), you should be prompted to enter an Apple ID and password (see screenshot below).

     

    Screen Shot 2012-08-31 at 2.12.34 PM.png

     

    It will say that "This Apple ID will be used to redeem VPP codes…" It is NOT the Apple ID used to purchase the VPP codes… The VPP codes can be redeemed by any Apple ID.

     

    You must enter the same Apple ID and password that you used to download the app in iTunes, and you should be good to go.

     

    Hope this helps!!

    ~Joe

  • SeeCoolGuy2 Level 1 Level 1 (0 points)

    how do you handle the error when you try to upload the vpp xls sheet to Apple Configurator and you get the error:

     

    Apple Configurator The spreadsheet provided has redemption codes for "(null)."

     

    if I open the xls sheet, I have my orderid, my vpp id, my group of codes... but same error? is there a way to manually add the redemption codes?

  • cking2729 Level 1 Level 1 (0 points)

    I have the same error. Uploaded a .xls full of 70 redemption codes for iMovie without any problems. Did the same thing for 70 Keynote redemption codes and I get "the spreadsheet provided has redemption codes for "(null)."

    There's no way I am going to redeem the codes individually or email them to 70 different people.

  • SeeCoolGuy2 Level 1 Level 1 (0 points)

    So at the moment I have a support ticket with applecare for enterprise open, i'm waiting to hear back from them on how to fix this issue.  My boss would be super upset if we couldn't redeem 70 codes... wow.

     

    why doesn't the system at least allow you to key in the codes though?  I could apple script them in

  • naholmes Level 1 Level 1 (0 points)

    I'm having this exact same problem with 150 codes. Could it be a mountain lion issue? Has anybody found a fix?

  • LesliSkarphol Level 1 Level 1 (0 points)

    I just tried importing redemption codes and received the message "the spreadsheet provided has redemption codes for "(null)." Please provide a spreadsheet with codes for "Math Bingo."

     

    The only thing I did that may be different was I used the first code to redeem in the iTunes account on the same computer I use Configurator.  I did go back in to the VPP store and re-downloaded the spreadsheet to import but unfortunately came up with the same error you are receiving.  I just submitted a ticket to Apple.  When I receive a reply, I'll repost.

  • naholmes Level 1 Level 1 (0 points)

    I just got off the phone with Apple Support. They said the problem stems from the most recest updates to Lion and Mountain Lion that rolled out last week. (10.8.2 and 10.7.6) They pretty much said there was nothing I could do until an update to Configurator comes out. I even asked if reverting to Lion would help but since I would revert to 10.7.6 by default, I would have the same problem. So basiclly, by installing the most recent and recommended version of OSX, iOS and Configurator, I unknowingly shot myself in the foot. Great.

  • SeeCoolGuy2 Level 1 Level 1 (0 points)

    Maybe that's why I haven't received my call yet! >:(

  • gyrhead Level 3 Level 3 (785 points)

    Received from our Apple Engineer on Monday:

     

    Please see the important note from our System Engineerre: Apple Configurator and Mountain Lion:

    If you are running Apple Configurator, please be sure NOT to upgrade to 10.8.2. If you are running Lion (10.7) or earlier versions of Mountain Lion, you are fine. There is am emerging issue only with 10.8.2 we are currently tracking.

    If you have already upgraded, and are seeing an issue importing VPP codes, please call the iOS/iPad and MacOS Phone Support - Education Customers can call for Toll-free- AppleCare - 866-752-7753 . Please be sure to keep your case number anytime you call; we can follow-up and escalate any issues if we have that case number as a reference.

    Lastly, for everyone using Apple Configurator, it is VERY important that you back up the local Apple Configurator (AC) database regularly, and put that back in a secure location/drive/server share

    http://support.apple.com/kb/HT5194

    Please take the time to be sure all of your instances of Apple Configurator are being backed up periodically.

    We will soon have some updates on the capabilities of Apple Configurator, and its associated "Supervised Mode" with iOS 6, in the next few weeks. More to follow!

  • SeeCoolGuy2 Level 1 Level 1 (0 points)

    Thanks for the post, I got off the phone right now with AppleCare and that is the problem, 10.8.2 is the cause of this issue. 

     

    based on the money that organizations are spending on this, I would hope that some verbiage could be posted on the VPP website stating that you can't redeem codes with the current combination of OSX 10.8.2 and Apple Configurator 1.1.2

  • PCS3711 Level 1 Level 1 (0 points)

    Thanks for all the info... I've been troubleshooting this for two hours now! Hopefully there will be a fix SOON! I have 110 iPads I gotta get deployed and this has been a nightmare.

  • ktharper Level 1 Level 1 (0 points)

    Help.. I've got the same issue with good reader

  • SeeCoolGuy2 Level 1 Level 1 (0 points)

    AppleCare for enterprise confirmed that it is a 10.8.2 problem in combination with Apple Configurator 1.1.2,  All they could tell me was that Apple is aware of the issue and are actively working on a fix,  they could not provide me with an ETA or other technical workaround this issue, so for now, you are stuck with 150 codes you can't use...

  • GRoyar Level 1 Level 1 (0 points)

    I just got off the phone with them and they said there basically is no work around and all we can do is wait until the update is released.

Previous 1 2 Next