Skip navigation

Turn off resume

16119 Views 17 Replies Latest reply: Oct 6, 2013 3:03 PM by mistersquid RSS
1 2 Previous Next
Scott Nash Level 2 Level 2 (160 points)
Currently Being Moderated
Aug 30, 2012 8:37 PM

Ok.  I've tried, but this is just not a feature I want.  I can't get used to it and don't like it.  I use reboot to get a clean slate, impossible when it reloads everything I rebooted to get rid of.  In Snow Leapord I (after a lot of trying) got it licked, but the fix no longer seems to work in Mountain Lion.

 

How do I turn off this stupid "Feature?"

Powerbook G4
  • ~Bee Level 7 Level 7 (30,580 points)
    Currently Being Moderated
    Aug 30, 2012 8:45 PM (in response to Scott Nash)

    This is from MaWorld:

     

    Turn off the Resume defaults

    It’s easy to turn off the application auto-resume option: when you shut down or log out, deselect Reopen Windows When Logging Back In in the confirmation dialog box. The only hitch is that the button resets to the selected state, so you must uncheck it every time.

    You can also keep your previous session’s documents from coming back to haunt you every time you start an application. Open System Preferences and click on General. In the Number Of Recent Items section, uncheck Restore Windows When Quitting And Re-Opening Apps.

  • ~Bee Level 7 Level 7 (30,580 points)
    Currently Being Moderated
    Aug 30, 2012 10:09 PM (in response to Scott Nash)

    I'll come back tomorrow.

    In the meanwhile, anyone with good advice, pleae don't hesitate to join us here.

  • ~Bee Level 7 Level 7 (30,580 points)
    Currently Being Moderated
    Aug 31, 2012 3:38 PM (in response to ~Bee)

    Make sure the box

    Close windows when quitting an application

    is checked:

     

    Screen Shot 2012-08-31 at 6.33.09 PM.png

  • baltwo Level 9 Level 9 (59,150 points)
    Currently Being Moderated
    Aug 31, 2012 4:13 PM (in response to Scott Nash)

    See this for more steps to resolve: http://osxdaily.com/2011/08/01/turn-off-resume-per-app-in-mac-os-x-lion/


    Should work in ML.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.1), G4 450 MP w/Leopard, 9.2.2
  • baltwo Level 9 Level 9 (59,150 points)
    Currently Being Moderated
    Aug 31, 2012 11:38 PM (in response to Scott Nash)

    Resume is a Lion+ process, never saw the light of day in Snow Leopard. If you don't like it, file a bug report with Apple.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.1), G4 450 MP w/Leopard, 9.2.2
  • Király Level 6 Level 6 (9,460 points)
    Currently Being Moderated
    Sep 1, 2012 10:17 AM (in response to Scott Nash)

    This Terminal command will kill Resume entirely:

     

    defaults write -g ApplePersistence -bool no

     

    Log out and log back in after entering that command.

     

    You might find it overkill, though, because it will also disable Auto Save and Versions, for all apps. This is an unsupported feature, and it might cause some strangeness. Proceed with caution.

  • baltwo Level 9 Level 9 (59,150 points)
    Currently Being Moderated
    Sep 1, 2012 1:56 PM (in response to Scott Nash)

    >

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.1), G4 450 MP w/Leopard, 9.2.2
  • djxk Calculating status...
    Currently Being Moderated
    Jan 20, 2013 12:43 PM (in response to ~Bee)

    This seems to have worked for me: when logging out or restarting, option-click when unchecking the "Reopen windows when logging back in" box.  I think this saves the default state of that option as unchecked.

  • WylyQuimby Calculating status...
    Currently Being Moderated
    Jan 30, 2013 1:40 PM (in response to djxk)

    Option-check does the trick. Thanks. I often run a dozen applications and have dozens of PDFs open in preview. Restarts are painful. Even with an SSD it takes a long time to load everything to its previous state.

  • Cerniuk Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 14, 2013 5:59 PM (in response to Scott Nash)

    Really great feature!  In Mountain Lion I have a server that crashed because of VMWare running other servers. Now the server crashes, comes back, I log in, VMWare launches, server crashes, comes back, VMWare launches, server crashes, comes back and....

     

    Best yet, the Xserve runs headless and is in Orlando, I am in DC.

     

    Now if I could write a check that would bounce to Apple and not cost me anyting. Then we could write check, Apple cashes, it bounces, Apple tries to cash again, it bounces, Apple tries to cash again, it bounces... and so on.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.