Previous 1 2 Next 26 Replies Latest reply: Nov 29, 2013 7:04 PM by Peter Roussak Go to original post
  • Old Toad Level 10 (135,329 points)

    Did you wife use the Photos ➙ Batch Change ➙ Date menu option of the Photos ➙ Adjust Date and Time... menu option?  If it were the latter have her try the Batch Change.

  • RadMac Level 1 (0 points)

    Hi,

     

    She used the Adjust date and time as each picture had a different date.  Did not think to try batch change for the single pictures.

     

    I just find it interesting that the automatic date and time preference solved the problem, pointing to some sort of code issue.

     

    Thanks for the pointer on the batch change.

  • Alaz Level 1 (0 points)

    Thanks RadMac I am assuming you meant in the system preferences and not in iphoto - I turned off the automatic but... no nothing still wild dates!! Yes I,m sure its a bug - maybe i should contact apple genius??

    i did sent a report to apple but do they actually follow up

    alaz

  • Alaz Level 1 (0 points)

    hey the batch change system worked!! thanks everyone

    alan

  • GordieT Level 1 (0 points)

    Six months along and I discovered the same issue with photos imported from a camera with a bad date set up. Changing the "set date and time automatically" in System Preferences worked. Thanks for the advice and work around. Hoping that the iPhoto bug fix will come soon. I am current on iPhoto 11 (version 9.4.3) and the issue was still there.

  • gameroony Level 1 (0 points)

    I found it nice and easy to solve this problem. If you use the "Batch Change" option instead of the "Adjust Date and Time" option it worked for me.

  • fishymac624 Level 1 (0 points)

    thanks, gameroony- this worked for me.  i too have had this problem for years.

  • Peter Roussak Level 1 (5 points)

    Silly question but how do you specify AM/PM when changing the time stamp on a photo?  When I go into Adjust Date and Time, I can change the time easily enough but iPhoto seems always to assume that's it's AM and doesn't offer me any way to set the time as PM. 

  • Old Toad Level 10 (135,329 points)

    Use the up or down arrow to move the hour to the am or pm version.  It's like resetting a digital clock by running the hour around till it is in the other 12 hour period:

     

    From this

    Screen Shot 2013-11-29 at 6.29.32 PM.jpg

     

    to this by advancing the hour with the up button by one hour:

     

    Screen Shot 2013-11-29 at 6.29.38 PM.jpg

  • Peter Roussak Level 1 (5 points)

    Thanks but the problem is that there is no "AM" or "PM" in that window for me, hence the question - this screenshot is from Adjust Date and Time but it's the same in Batch Change.Screen Shot 2013-11-29 at 3.39.jpg

  • Old Toad Level 10 (135,329 points)

    Check the Sustem/Language & Regior/Advanced/Times preference pane to make sure you have AM/PM appended to the time.

     

    Screen Shot 2013-11-29 at 6.58.49 PM.jpg

  • Peter Roussak Level 1 (5 points)

    Solved - thanks!

Previous 1 2 Next