Skip navigation

Broken Wireless - iOS 6 on iPhone 4S

65470 Views 160 Replies Latest reply: Apr 1, 2013 5:49 AM by escottr RSS
  • Walleth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 1, 2012 3:19 AM (in response to yerodtr)

    I have just spoken to Apple on the phone for the second time.


    They want nothing to do with the issue and are saying the company who make the router are responsible for resolving the issue.


    My iphone wifi works on other routers but not on my Addon Magic R9500, the new IOS6 crashes the router and prevents all other wired and wireless devices accessing the network and internet.


    Apple offered no steps to try and fix the problem and zero information I could pass on to Addon who make the router.

  • XtremeArtists Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 1, 2012 6:25 AM (in response to yerodtr)

    I have a similar problem: IPhone 4S (upgraded to IOS 6 OTA) connects to cellular data while sleeping/locked. I have an Airport base station the phone connects to when awake, but at night it's using cellular data.


    My second iPhone 4S upgraded to IOS 6 using iTunes shows no problem.

  • marty.li0707 Calculating status...
    Currently Being Moderated
    Oct 1, 2012 6:33 AM (in response to Walleth)

    god **** it apple! It is getting clear that apple wants to sell out their airport express's.. Lame apple, lame! It is a glitch! Every computer programmer knows that. It works just fine with the iOs 5.1.1. Ios6 is the WORST update from apple.... It is more like a downgrade! Poor maps, now, poor wifi compatibility.... Bad after jobs effect.... If jobs is alive today, he will firing the people responsible for such update or should i say, downgrade?!


    Hope they will make a solution soon... :-(

    I am unhappy with iOS 6... :-(

  • XtremeArtists Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 1, 2012 6:49 AM (in response to marty.li0707)

    I have an AirPort Extreme 802.11n and it does not fix the problem. Apple support have been instructed to lie about the problem. This is an IOS 6 problem.

  • mobg888 Calculating status...
    Currently Being Moderated
    Oct 1, 2012 7:01 AM (in response to yerodtr)

    removed. solution didn't work

  • marty.li0707 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 1, 2012 6:53 AM (in response to XtremeArtists)

    Yes, it is a glitch on their so called iOS 6. I  am actually tempted to buy their airport express, anyway, thanks for your post here, i am definitely not going to buy 1 for myself now.... Thanks.


    What router should i use then? Any ideas?

  • marty.li0707 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 1, 2012 6:53 AM (in response to mobg888)

    Tried all of those, works for a whole then, the same no connection after few minutes...

  • marty.li0707 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 1, 2012 6:57 AM (in response to mobg888)

    Try rebooting your device, see if the connection tomthe internet still works... Me, everytime i do it, internet connection fails. Also, other devices cant connect to the same routers!

  • dinogt Calculating status...
    Currently Being Moderated
    Oct 1, 2012 8:52 AM (in response to marty.li0707)

    For those who are not near a store - sorry this won't help.

    I went to the store Saturday and they exchanged my 4 month old 4S and now I have a replacement. Even better, it came with iOS5.

    Too bad the fruit company won't talk about this.

    Cute how Jim Cook apologizes for maps when there are many work-arounds for that gingerbread but serious problems aren't admitted.

  • Joshua D David Calculating status...
    Currently Being Moderated
    Oct 8, 2012 2:20 PM (in response to yerodtr)

    Hi chaps,


    I did two things to resolve this issue


    1. Downgrade the router to a lower version.If your router is Netgear WGT624 v3 use this link to downgrade your router



    (this help to avoid getting a errro message "Unable to join network")


    2. Reconfigure you Wifi network by going to setting ---->under choose a network---> others-----> Enter your SSID name (seen at the back of your router) ----->under the security tab selet the same encyrption standard as that of your router which you can see when you log in to the router (usually router IP ---->setup ------>wireless setting----> security option. This one helps you to join your home wifi as soon as you enter your home.



    I hope this one works as it worked for me

  • bees_knees Calculating status...
    Currently Being Moderated
    Oct 9, 2012 12:11 PM (in response to yerodtr)

    I read this entire thread and I see you are all having issues connecting to WiFi, but what about making calls while connected to WiFi?  I have a 4S that I updated with IO6.  After about a week, my WiFi stopped working, but my husband was able to get it to work again by resetting our router (apple airport extreme).  Another week goes by with no problems. 


    All of a sudden I can make no outgoing calls or receive them unless my WiFi is turned off. I don't even get Voice Mail alerts for missed calls.  I've contacted my wireless carrier and they're claiming that since WiFi is on a different network, it's normal for the phone to not work unless using only 4G.  I say ********, but wanted to know if others are having this problem as well.  I can't imagine having to toggle back and forth between WiFi On and Off with a complete reboot each time depending on whether I'm browsing/using email or needing to make a call. 

  • Mac Rotz Calculating status...
    Currently Being Moderated
    Oct 10, 2012 2:45 AM (in response to yerodtr)

    I upgraded my new Ipad to IOS6, wireless is my biggest issue here, because I used my ipad as part of BYOD program in my office. Now I can only connect for several minutes to Access Point in my office (Cisco Product), before it get lost and after that I have to manually reconnect again. It's really annoying! I've tried to reset network setting several times, and no hope. But at home I used private wireless (from telco provider) and it works fine. AP security in my home is WEP and in my office is  WPA2 Enterprise. I don't have any problem when using ios 5. I hope apple would fix this issue! I agree this is the worst update in ios or MacOS and that's why Tim Cook should apologize to us.

  • Beatsbyair Calculating status...
    Currently Being Moderated
    Oct 10, 2012 6:56 AM (in response to yerodtr)

    yeah, same problems here...3G seems to work fine, but wireless hardly works unless I'm connected to a specific employer has hundreds of WAP's in various office locations on our campus and some of them work, I suspect they are of the security type that actually functions with iOS 6...99% of them don't work.  Really annoying that I can't use iTunes to PURCHASE music and apps right now.  Apple is doing the music industry and the app industry a disservice by not fixing this.  It is not a hardware issue, it's aon iOS 6 issue.  My 4s was perfect until I updated it.


    Also, the podcast app is basically worthless.  The worst app I've ever used, I should say try to use.


    I hope an update comes out soon.  When they released 5.1.1 it was about a month after 5.0 came out.  We're almost there.

  • Smartpatrol Calculating status...
    Currently Being Moderated
    Oct 12, 2012 8:34 AM (in response to yerodtr)

    Just wanted to add to the list and confirm that for me it is the ios6 upgrade that causes this issue. My ipod touch connects to my work network just fine when i take it home it connects to my wireless network(gets an IP from DHCP etc..) but it does not have connectivity. I have a netgear WAP using WPA2 which upon power cycling the wap my 4th gen ipod touch will connect up fine. This is not a problem with my WAP this is obviously a problem with the networking on ios6 let hope they correct the problem soon.

  • JustTyson Calculating status...
    Currently Being Moderated
    Oct 14, 2012 5:24 PM (in response to yerodtr)

    I have a Iphone 4S running iOS 6 using a Netgear N600 and I can connect but every once in a while it toggles back and fourth between celluar data and wireless data every second or so. There are times where it won't be connected at all but eventually comes back. I haven't played with my settings at all. I have althoug ried rebooting my phone and it worked for a bit then toggled back and fourth for a while. It only seems to do that when I use the wireless data, like using Facebook or Safari/Mail.


More Like This

  • Retrieving data ...

Bookmarked By (8)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.