Previous 1 2 3 Next 37 Replies Latest reply: Oct 1, 2012 6:38 AM by Trio music Go to original post
  • Edicius Level 1 Level 1

    Same problem here. iPhone 4S with zero issues before iOS 6 upgrade.

  • larrycooke1207 Level 1 Level 1

    Same for me.  IOS 6 upgrade on iPhone 4

    Router NETGEAR DG834G with simple Open Wireless

    Worked fine in ios 5.1, so I may have to downgrade.

  • mgdrw2 Level 1 Level 1

    I can't connect to wifi either!  I've done the reset and still nothing.  Is there anyway to roll back to the previous version until Apple gets a fix out there?

  • kjchipmunk Level 1 Level 1

    Same problem on iPhone 4s, but the upgrade worked on the ipad 3.  Not sure whats up.  The suggestions above didn't work for me either.  I have all apple hardware on the wifi network as well.

  • douglaswardacn Level 1 Level 1

    The issue is this...

     

    (from http://forums.macrumors.com/showthread.php?t=1446596&page=3)

     

    The following page on apple.com is down:


    http://www.apple.com/library/test/success.html


    This is what iOS uses to detect if you're behind a "captive network." I guess it thinks everyone is behind a non-internet-reachable network right now, so it disconnects.

     

    So, until apple gets that page to stop crashing, you're SOL. Unless you do the incredibly geeky thing I did to fix it NOW...

     

    I run a local DNS server, so I A) created a new virtual host on my webserver for apple.com with a page htttp://www.apple.com/library/test/success.html page. I then B) told my local DNS server to be the authority for apple.com, and that IP was the IP of my local web server. I then connected to my WiFi with my iOS 6 iPh4s and iPad2, and it worked. I then took the apple.com OUT of my local DNS, and everything was fine.

     

    Most people don't run a local webserver or local DNS server, so the point is moot.

     

    Apple will get that page fixed sooner or later, and it will work fine.

  • nerdoloco Level 1 Level 1

    I have the same issue. tried using other wifi in my area and the same apple.com "hmmmm" page comes up. auto http does not help. HELP!!!

  • asahin Level 1 Level 1

    I don't believe the problem is with Wi-Fi or connection settings or proxy settings at all. The thing connects to the net and lets you browse thru apple.com pages. Just not the initial page it requests. Because it is NOT THERE! (Apple the caps are for you). I've hooked up a proxy to see what page was not being found. Apparanetly right after the a "successfull" wi-fi connection, it tries to load "http://www.apple.com/library/test/success.html" I don't know what would it do if it had found that page there, maybe a simple Agree/confirmation of some sort and the check a thing within iOS and then it wouldn't come up again everytime a wi-fi connection has been established. But since the page is not found and that we cannot click on that agree button (or whatever was on that page), it simply drops the already established successfull connection (and even turns of Auto-connection). Verrry verry annoying. I too, actually didn't need/wanted the iOS 6 update. I want to go back to 5.1.1. Apple Maps really ***** and I was just way too happy with my 5.1.1 on my iPad 2.

  • dvdhoo Level 1 Level 1

    I'm getting the same issue as well. It connects, and then just drops because some stupid page is gone with the wind.

    That is really upsetting because it just came out a few hours age, and then this is happening. I really miss Jobs for letting these product running smoothly and flawlessly. Apple is not perfect any more!

  • YeahBuddyDC Level 1 Level 1

    I changed the HTTP proxy to auto, the "page not found" appeared again; however this time the "cancel" was "Done".  I clicked it and it works.

  • lenionet Level 1 Level 1

    iPhone4 w iOS6 upgrade today, lost Airport express access.

    Turned off phone and restarted. No problems since.

  • AguileraLoya Level 1 Level 1

    This worked for me on iPhone 4S and iPad 2:

    Settings -> General -> Restore -> Restore network settings

    After the device restart, I logged in my wifi network without any problem.

  • Gamercq Level 1 Level 1

    Awesome thanks

    Wifi is now working

  • Kenneth Lowry Level 1 Level 1
    expertise.iphone
    iPhone

    This is an odd issue.  If I turn my HTC into a hotspot, my iPad and iPhone have no issues connecting to it.  The only difference seems to be that the HTC requires WPA2 and my router had WPA/WPA2 as the authentication mechanism.  I switched the router to use on WPA2 and now the iPad and iPhone connect.

     

    However,  I have a third router that I've been playing with (a new Airport Express).  Both devices now also connect fine to this access point, but I didn't change anything on that.  The previously got the same "page not found issue".

     

    Would be interested if changing to WPA2 helps anyone else.

  • asahin Level 1 Level 1

    Working now because Apple fixed the success.html page.

  • douglaswardacn Level 1 Level 1

    I posted a public reply to others with this issue here...

     

    https://discussions.apple.com/message/19626818#19626818