Previous 1 2 3 Next 207 Replies Latest reply: Jan 10, 2015 3:39 PM by kavanagh.adam
cazmn01 Level 1 (0 points)



I just updated my Macbook Pro Retina to OSX 10.8.2.  I often use my hdtv as an external display, that is, until after updating.  Now whenever I connect my mbp to the tv via hdmi, the screen goes black and nothing but a cursor appears.  The cable is fine, tried multiple cables, multple comps, none of the system preferences have been changed.  Literally happened just after restarting with the update.  Help?

MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.2)
  • sanjampet Level 5 (7,760 points)

    With everything booted up and connected, try a NVPRAM reset, this has helped some people.


    Power down mac, leave TV on, power up the mac holding the following keys before the start up chime:


    option, command,P,R,(no commas) continue to hold till you hear the start chime 2 times, then release.


    If no joy, try a reboot.


    Hope this helps

  • cazmn01 Level 1 (0 points)

    no dice, but thanks.  the screen is fine in disk repair mode. wierd.

  • KenV54 Level 1 (5 points)

    Exactly the same thing has happened to me--MacBook Pro Retinan screen, 10.8.2., just installed today.


    Neither a plain reboot nor one with a NVPRAM reset solved the problem.


    No video problems with my iMac early 2009 with 10.8.2. Must be Retina specific.


    One possible variable in addition to the one being a retina screen and the other an iMac--along with the 10.8.2 OS upgrade today came a Retina firmware upgrade. I tried cleaing the startup drive cache using TinkerToolSystem--a great, non-free, program, btw--but no luck, even after another reboot.


    Guess I'll call Apple on this one and let them start working on it.

  • KenV54 Level 1 (5 points)

    (I tried editing the original but it didn't take, so I'll reply to myself.)


    I then rebooted into Safe Mode by holding the shift key down, and the video-HDMI worked fine.


    Then I rebooted into standard mode and the problems was not resolved.


    I am on Applecare hold right now--they are escalating the problem. I'll repost if and when I get a resolution, which I doubt I'll get tonight.

  • KenV54 Level 1 (5 points)

    Applecare went through all the usual stuff including kext file removal, launch daemos, etc., and couldn't solve it. They then had me do a Data Capture with the HDMI plugged in and generated all sorts of data which they will send to their engineering department--said it may take a few days. Sounds as though it's a firmware issue but who knows?


    Anyway, I would respectfully suggest that anyone else with this problem not spend a lot of time on their own trying to fix it until Apple figures it out, because there is no easy answer, apparently.

  • rss from Illinois Level 1 (0 points)

    I have the same issue using the 24" LED Cinema Display with the MBPr.  Worked fine through the Thunderbolt port until upgrading to 10.8.2 with the firmware upgrade.  Now just get black screens with a large cursor when display is connected.  Arrrgh!    

  • mjeick Level 1 (0 points)

    I have the same problem with a 15" rMBP after the OS X 10.8.2 upgrade.  Connecting a HDMI cable, which worked fine prior to the OS X upgrade, now causes the rMBP display to go black with an enlarged pointer visible.  I'm relieved I'm not alone.  Thank you for initiating the support call and providing the diagnostics.



  • KenV54 Level 1 (5 points)

    Progress report:


    Apple called me today, had me remove my third party SwitchResX multiple monitor program and preference pane, and also an plist in th system preferences, followed by a reboot with a NVPRAM reset.


    Neither of these solved the problem or changed it in any way.


    They then had me redo the capture pocess while the HDMI cable was plugged in, send another 10 megs worth of data to them, and they have sent the new data back to engineering.


    By the way, mjeick, besides the 10.8.2 upgrade did you also do the firmware upgrade? My suspicion is that the firmware is the source of the problem, and that Apple will have to do a new firmware update. If you didn't do the firmware update and still have the problem, I should let Apple know that.


    Apple seems very interested and concerned about this. My rep, who is a high level guy, said he hadn't seen the engineering people get back to him this fast (less than one day) in a while.

  • mjeick Level 1 (0 points)

    Howdy KenVS4,


    Sorry - can't say for sure.  I instaalled the OS X 10.8.2 update, the XCode 4.5 update and the iPhoto 9.4 update.  If there was an EFI update in there, it was hidden from my view. SInce OS X 10.8 changed the update process, I still haven't found a good way to list installed updates.  I can say, I downloaded the rMBP EFI 1.0 update published Sep 19 and tried to install it, but it refused - could not be installed on my system - I'm guessing I already have it.   My hardware Boot ROM Version is: MBP101.00EE.B02 and SCM Version is 2.3f32. 



  • mr da Level 3 (510 points)

    Your boot rom  and smc versions are the same as my mbpr's, and the EFI did install on it.

  • mjeick Level 1 (0 points)

    Thanks for that information Mr Da.  My thought is that KenV54's suspicion is correct.  I think he's engaged the right folks and I shall reap the rewards of his and their work by being patient.

  • Ba55Man Level 1 (0 points)

    It's infuriating.  After updating my mid-2010 MBP to 10.8.2 my external monitor stopped working.  I got it to work once, by installing gfxCardStatus, which seemed to wake it up--and then I started and the monitor shut off as soon as it came up.  It looks like this is related to graphics card switching--I hope they fix this soon because I really miss my monitor.

  • KenV54 Level 1 (5 points)



    I've passed this comment along to my Apple support rep.


    Was there a firmware update to your mid-2010 MBP as well?


    If not, it would seem that 10.8.2 itself is the culprit rather than the Retina MBP or its firmware update.


    My early-2009 iMac now has 10.8.2 but the external monitor is working perfectly. There was no firmware update to the iMac. Maybe only MBPs are affected.

  • Ba55Man Level 1 (0 points)

    There was no firmware update, although the app store icon is badged as though there were 1 thing available, but nothing shows up in the Updates section.

Previous 1 2 3 Next