Previous 1 9 10 11 12 13 14 Next 207 Replies Latest reply: Jan 10, 2015 3:39 PM by kavanagh.adam Go to original post
  • KenV54 Level 1 (5 points)



    We actually agree. This is what I said: "But since the HDMI on the non-Retina machines was working (wasn't it?) before 10.8.2, there has to be a software solution or workaround."


    No, "my fix," which, of course, wasn't my fix, at all, but rather was Apple's fix only for the Retina MBP, doesn't seem to work for non-Retina, that is, older MBPs.


    But clearly there is something in 10.8.2 which has caused the problem in the older MBPs, since the HDMI was working before 10.8.2. And since software doesn't change or damage hardware (although it can change firmware), there is still something that can be done in terms of either the firmware or the OS with the older MBPs. The problem is that no one seems to know what to do at this point.


    I'm not pleased, either, with Apple, but they are the only people we have to work with. That's why I've strongly suggested that you and others contact AppleCare and try to force them to find and fix the problem. They will have to gather data and logs from your computer, as they did with mine, and send this information to their engineers. Until they see what's happening on /your/ MBP with HDMI, they can't come up with a fix.


    To use AppleCare after you are out of warranty may cost you $50 or so per incident, although that might be waived once they figure out the problem is their fault. If you use your MacBook Pro for business, as many of us do, it's worth it to pay the $50 to AppleCare, and much cheaper (and easier) than switching to Windows.




  • ampdeck Level 1 (0 points)

    hi guys, im using non retina MBP mid-2012 13"



    tried all solution found on this thread but it just that doesnt work.



    I reformat my OS using full 10.8.2 installer and already applied all patch but no luck.

  • Diawhey_47 Level 1 (0 points)

    Hi KenV54,


    Your ideas were great! It worked for me at first try.

    Actually I also have the same problem connecting my Sony TV to my MBPR.

    I followed the steps removing the .plist on my mbp and it worked, but after the latest update from apple, the same problem occured with blue screen and then turned to black then the big arrow shown up.


    I tried the same procedure but this time it's not working.. Any suggestions?


    Appreciate your help! Thanks a lot!

  • KenV54 Level 1 (5 points)



    Thanks, but sorry to hear the problem has returned, although I don't know exactly which Apple update you are referring to (not that that would help me to solve the problem for you).


    As I've been suggesting here to the people who have had repeat or persistent failures with video on the rMBPro, I think you have to contact AppleCare. These machines are still under warranty, whether you bought additional AppleCare coverage or not.


    I really don't know what else to suggest, other than to make sure you've removed /all/ the widowserverxxx.plist files from every directory and the rebooted the machine with the viseo plugged in, and doing the PRAM reset while it boots. And even that doesn't seem to work in many cases.


    This is Apple's problem, and they have to be pressured to come up with a fix for everyone.



  • cksachdev Level 1 (0 points)

    Hi @KenV54,

    The solution you provided worked for me. But after using it for around 14 hrs plugged in, it again comes up with a black screen. Tried to switch off the TV and switched on again, it flickers for 3 times and showing my Desktop, and later it goes back to black again. I am using it with a Panasonic TVTH L24C20*. It used to work earlier with OSX 10.6.8, after my later upgrade with 10.8 (currently 10.8.2) it had stopped working.


    @Apple, aren't you guys able to reproduce and fix this ??

  • greenone83 Level 1 (0 points)

    have any of you tried the 10.8.3 beta? apperently they've also worked on the graphic drivers. don't forget to make a backup before though

  • shz1372 Level 1 (0 points)

    Hey KenV54


    My problem is not solved yet. I could find and delete the second .plist that you said but not the first one.

    What do you mean by root directory? If you mean what I named my Macbook, when I go to Finder and click on that, i dont have "Library" to click on.


    Thanks for your help in advance

  • KenV54 Level 1 (5 points)



    Go to Finder, click on your computer name under Devices (usually the first device listed), open up the MacintoshHD directory (that's the root directory), click on Library, click on Preferences, and  you should find a file, which you can then delete.



  • nivre13 Level 1 (0 points)

    I have the same problem whith my MacBookPro7,1 (13" 2010=). The problem was found when I installed 10.8.2. I tried the guides described above. but  the problem continues. I also replaced hdd with 10.7.4 installed and the problem still. Now i installed 10.8.3 beta and is the same problem. I think that is a problem of efi. If we look the apple issued efi update for all new mac but not for mac before 2010. And I was just about to buy another adapter dvi to hdmi. I hope not to waste money......

  • mrkevan Level 1 (0 points)

    I noticed this problem last night when I attempted to mirror onto my HP screen via thunderbolt to HDMI with my MacBookPro retina. Worked a month ago when I last mirrored and worked last night OK via hdmi to hdmi, but was a bit peeved as it cost £40 for the thunderbolt to HDMI cable, and looks a lot neater and more discrete. Disapointment turned to anguish at the thought of having to return the laptop for repair and the void it would leave. Good old Google soon lead me to your thread (oops! Forgot Apple spurns Google like a rabid dog).


    Thanks to your published solution (which worked for me) I'm up a running again!

  • KenV54 Level 1 (5 points)



    I'm happy to see that the solution worked for you with the Thunderbolt to HDMI cable, but am curious about the difference you note between the quality of straight HDMI vs TB to HDMI.


    I've just tried switching between one and the other on a 32" HD flatscreen, Panasonic TV, and can't see any obvious difference in video quality. I wonder if on your rMBP the settings changed going from TB to straight HDMI?

  • losmanman507 Level 1 (0 points)

    OK, i had the same problem as the rest of you, imac 27" with the dynex mini display adaptor with a sharp 42" tv. 1. unplug adaptor

    2. unplug power from tv and wait 30sec then plug it back in.

    3. trurn on tv

    4. plug adaptor in mac while computer is on and hdmi cable.


    thats what i did for it to work again. lol computers

  • mrkevan Level 1 (0 points)

    No difference in video quality (1920x1200-60hz) and settings remain constant switching between either HDMI or TB. My reference to 'looks neater' meant the TB cable itself which is thinner and of course a smaller connector.

  • JoshSN Level 1 (0 points)

    Mac Book Pro Retina, mid-2012, OS X 10.8.2 (12C2034) No system updates available

    via HDMI Cable

    Samsung TV MODUE: T-RBYAUSC-1012.2, DATE:2008-10-10, MICOM:T-RBYAUSS-1002 SDAL3.4.15-US-080728-103, RFS


    The TV says "No Signal" and remains black, i.e. no large cursor.

    The top menubar does now have a icon with "Turn Off/On Display Mirroring" as a menu item. The resolution on the MBPr changes when I do that, but there is no obvious difference on the television.


    I tried to remove the plist files, using commands like:

    # updatedb

    # locate windowserver


    # rm /Library/Preferences/


    and then rebooting while holding down Option + Command + P + R for a PRAM reset.


    The HDMI port on the television definitely works, as it works with a different device.


    I tried updating the Samsung's software, but it says USB not connected... but I don't know what I would even connect the USB to, if that's even the problem.


    I never tried the HDMI connection before 10.8.2.

  • KenV54 Level 1 (5 points)



    Other than making sure that you've removed all the windowserver plist files, including one in the [youruser]/library/preferences/byHost directory, I wouldn't know what else to suggest.


    Some people have had better luck using the Thunderbolt output with an HDMI cable attached to that, but of course, it costs $30-40.


    Even after a few months there's been no clarification from Apple on this problem, and no OS or firmware updates in a while.