Previous 1 4 5 6 7 8 Next 207 Replies Latest reply: Jan 10, 2015 3:39 PM by kavanagh.adam Go to original post
  • bakajunk Level 1 Level 1

    Same blue screen on both rMBP and external HDMI display (HP LP2475w) after 10.8.2 upadte.  Sometimes jumble pixels on rMBP screen if external is on and plugged in on start up.  But same HDMI works fine on Sony Playstation 3D Display as external monitor for some reason.

  • KenV54 Level 1 Level 1

    Unfortunately, these posts are not numbered, but the "fix" is my post of September 24, 5:05 pm.


    I'll restate it here with some clarifications. But this is not the fix for everyone with MBP-HDMI problems, and as I've suggested previously, you may have to get Apple support.


    Go to Finder.


    In the root directory (MacBookPro or whatever your HD is called), go to Library, go to Preferences, find and put it into Trash


    In your own user directory, go to Library (to see the user Library folder in Finder, click the Go menu in finder and at the same time hold the Option key down, and then you'll see Library). Go to Preferences folder within the Library folder, go to the ByHost directory within the Preferences folder, find[random numbers and letters].plist, and put that plist file into Trash.


    There may be more than one file in both of these directories, including one that ends in plist.lck--just remove any plist file with "windowserver" in it. You won't cause any harm by removing a plist file.


    You do not have to empty the Trash folder, but you can if you want to.


    Reboot computer.


    I don't know how to state it any more clearly than that. If it doesn't work, and it may not, especially with non-Retina MBPs, then you have to call Apple support.

  • Galor Level 1 Level 1

    Hey KenV54,


    Thanks very much for the fix. I too was having the same issue on a new MacBook Pro Retina thinking that it was the firmware update (Apple and nVidia created it for the gamers, WoW in particular). After reading your post and knowing that I too use a 50 inch Samsung for work and the only connect IT gave me was a HDMI connection. It worked fine prior to the update and my co-workers at work uses the HP Elite and even though its another computer maker theirs worked fine along with mine prior to the 10.8.2 update.


    After deleting the windowservers plist files (I found 3) I quickly hooked up my HDMI cable and wa la it worked!

    Thanks again and buy your Apple Rep a beer.


    Quick note:

    I did notice that my 50 in display had a setting of 1920 x 1880 @ 30 Hz. Is that the same for you?



  • KenV54 Level 1 Level 1

    "I did notice that my 50 in display had a setting of 1920 x 1880 @ 30 Hz. Is that the same for you?"


    I don't have a Samsung. I use a projector TV, and it gives me a 1400x900 60Hz display.

  • douglas.c.thomas Level 1 Level 1

    Adding my voice to the choir:  This worked....Thanks so much.  This was very frustrating.  Cheers!

  • derek_ Level 1 Level 1

    Worked for me.  Frustrating problem -- thanks for following up on how to solve it and sharing the solution!

  • Maui Todd Level 1 Level 1

    Updated rMBP to 10.8.2 and lost a thunderbolt display and the other one is now wonky.....takes forever to make it work.  Both worked flawlessly before update....

  • KenV54 Level 1 Level 1

    Maui Todd,


    Did you read through this thread? It looks as though you only responded to the first post.


    The answer is here, twice, and restated six posts above yours on page 6 of the thread.

  • pinzzon Level 1 Level 1

    tried everything even the NVRAM and PRAM  reset.... nothing works i hope apple fix this firmware bug soon enough

    I'M kinda angry right now


    brand new macbook air.. and just after the 10.8.2 update the minidisplay port ISN'T working.

  • Maui Todd Level 1 Level 1

    You're so right...was so frustrated I just linked to first entry.  Just followed your directions and will attempt to hook up to external display/VGA projector in morning and will update comment.


    Thanks for checking up on me and giving me kind direction!

  • kckaos Level 1 Level 1

    Worked for me aswell!! thanks KenV54!!

  • DanteTso Level 1 Level 1

    thanks, it does work cheers

  • Maui Todd Level 1 Level 1

    Hi there....gave your instructions a try and this morning was my first to test the system, but unfortunately the problem persists for me. A have a house full of Macs and have been traveling with MBP's for years....and this rMBP has several issues si I think it's time for a trip to the Apple Store for some help. Thanks again for your suggestion....glad it's worked for many!

  • KenV54 Level 1 Level 1

    Maui, I'm sorry to hear the fix didn't work. It was Apple's solution, of course, based on the data they collected from my rMBP, and apparently applied to many but not all rMBPs and/or projectors. I assume you found and trashed all the files in both the root Library and in your user Library and subdirectories.


    My guess is that the Apple Store Geniuses won't have the answer, either, since they depend upon the Appple knowledge base for problems like this. Since you most likely still have AppleCare on your rMBP, i would suggest you give them a call, have them bump the problem up to a higher level, let them collect data from your computer while it is plugged into your own projector, and see if it's some other issue.


    Good luck. If you come up with an answer, please post it here.

  • MS485 Level 1 Level 1

    It did work for me, but I had to delete the .lockinfo files as well for it to work. When I deleted the two .plist files first it didn't work.

Previous 1 4 5 6 7 8 Next