Skip navigation

HDMI display issues after 10.8.2

65181 Views 206 Replies Latest reply: Oct 25, 2013 12:03 AM by Juhaz RSS
  • MS485 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 4, 2012 9:24 AM (in response to Juhaz)

    Yes, delete the lock files as well. So in total it would be four files.

  • himshu Calculating status...
    Currently Being Moderated
    Oct 6, 2012 1:48 PM (in response to MS485)

    I'm having similar issue(https://discussions.apple.com/message/19919451#19919451) with MacBookPro and tried above steps but didn't worked for me - Deleted pst files including lock files from library and byhost directory.

  • KenV54 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 6, 2012 2:47 PM (in response to himshu)

    Himshu,

     

    I looked (with textedit) at my existing com.apple.windowserver.plist file on my iMac (early 2009) with 10.8.2, which doesn't have this problem, so I hadn't removed the plist files.

     

    This plist refers to a file called "windowserver" which is buried in a sub-sub-subdirectory in the root Library. "Windowserver" itself no longer exists on my rMBP from which I removed all the relevant plist files, which may meanthat it isn't a critical file.

     

    I don't have the slightest idea if this solution will work or even if it's safe--I can't test it myself--but try removing (but saving it on your desktop or some place in case you have to replace it) the file "windowserver" on your MBP, if it's still there. You can look for it here:

     

    /System/Library/Frameworks/ApplicationServices.framework/Frameworks/

    CoreGraphics.framework/Resources/WindowServer

     

    Also, search carefully for any windowserver plist files you may have missed.

     

    Then reboot and see if the problem still exists.

     

    If for some reason, after removing the windowserver file, you can't boot your MBP, you will probably be able to boot it into safe mode by holding the shift key down while booting, and then you can reinstall the saved file. Worst case would be that you would have to reinstall the OS, but I highly doubt that either of these would happen.

  • KenV54 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 6, 2012 3:45 PM (in response to KenV54)

    See my post immediately above.

     

    I just checked my rMBP and despite the fact that I can't find the "windowserver" file on it, WindowServer appears to be running in the Activity Monitor.

     

    I think it may not be safe to remove this file unless you have a cloned backup of your entire disk on an external HD using CCC or some other cloner, or unless you can re-install 10.8 booting from a USB drive or from the recovery partition that should exist on your computer HD.

     

    Given that WindowServer is running on my rMBP that was fixed by removing the plist files, removing may not end up being a fix at all for the external projector.

  • KenV54 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 6, 2012 7:49 PM (in response to KenV54)

    The more I look the more I'm sure that removing the WindowServer file itself is a bad idea. It appears to be critical to the operation of the OS.

     

    From: http://www.macworld.com/article/1163410/bugs_and_fixes_when_os_x_lion_slows_to_a _crawl.html

     

    What is WindowServer? In brief, it handles windows. It is the core process responsible for drawing the windows and boxes that make up the graphical user interface. As Apple notes: “The window server does more than just manage windows. Even an application with no user interface (like a background-only application) depends on the window server.”

     

    I hope I didn't cause anyone any problems. There's no obvious way to remove or even edit the first post. 

  • KenV54 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 6, 2012 9:23 PM (in response to KenV54)

    A couple more thoughts.

     

    1. After removing all the com.apple.windowserver.xxxx files in the By Host directory and in the root Library Preferences directory, remember to do a PRAM reset on reboot.

     

    2. See this article on video problems from 2011, before Mountain Lion. the Windowserver plist files are referenced here, as well, for solving video problems. At the end of the article there is a method to remove all such plist files using Termnal, after which you would still have to reboot and do the PRAM reset. The Terminal method is more thorough, but has some small risk of deleting data if not done correctly, so you want to have a full data backup first.

     

    http://news.softpedia.com/news/What-to-Do-if-Your-Mac-Has-Video-Problems-158878. shtml

     

    3. I just checked my rMBP which has been working perfectly with the HDMI ever since I went through the plist removal process. It now has new windowserver.plist files in the two directories--it must have recreated them. And I repeat, the rMBP is working perfectly even with the new windowserver.plist files in place.

     

    Somehow I think the plist files are the culprits in almost every case, and when removing them doesn't work it may mean that they weren't all removed, or were replaced on reboot with backup plist files, something that the PRAM reset is supposed to prevent.

  • himshu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 7, 2012 3:21 AM (in response to KenV54)

    Thanks KenV54 for looking at this

     

    This time i tried removing the windoserver pst files and then PRAM reset on reboot but didn't fixed the problem. Do you this this is a generic issue with 10.8.2 and Apple might release patch for HDMI at later stage or else my only option to go the apple service desk.

  • KenV54 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 7, 2012 8:16 AM (in response to himshu)

    himshu,

     

    I, too, hope Apple releases a patch or 10.8.3 or something that fixes this, since it does seem to be related to 10.8.2.

     

    Did you try the removal of the windowserver files using the slightly risky Terminal method described at the bottom of the page in the link I provided two posts above this one?

     

    If so, and if that didn't work, I have no further ideas. One of the solutions AppleCare offered me as a last resort (in case removing the files didn't work) was to do a clean install of the OS, which would mean that you have to back up everything with Time Machine on an external drive first, then erase the HD, reinstall 10.8.2, and restore everything from Time Machine.

     

    You still may have to have Apple look into it for you. 

  • 123bart Calculating status...
    Currently Being Moderated
    Oct 7, 2012 9:51 AM (in response to cazmn01)

    KenV54, I commend you for continuing to help people with this issue. I have followed the thread out of curiosity, even though the deletion of the plist files completely solved my problem. I do not understand why apple does not have a better system in place to help solve a widespread problem like this. Just wanted you to know that someone has noticed that you have been going above and beyond.

  • KenV54 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 7, 2012 10:19 AM (in response to 123bart)

    123bart, thanks much for your kind words. I like to troubleshoot computer issues, so it's no bother to me.

     

    I do agree that Apple has dropped the ball here. Part of it may be that the HDMI and video problems are multifactorial, even if they are all related in some way to 10.8.2.

     

    Also, without capturing data from an affected machine it is difficult for Apple to isolate the problem in any particular case. Users whose AppleCare has expired naturally don't want to pay for a support incident which costs $49. I think Apple should wave this charge in cases in which it is an Apple issue, not a user issue. 

  • koppah Calculating status...
    Currently Being Moderated
    Oct 9, 2012 10:34 AM (in response to KenV54)

    This fixed my issue, but caused my Filevault login to then be running in low resolution. While on the phone to AppleCare, I was playing around, and simply booting up the computer with the external display plugged it seems to have forced it to recreate the settings file and fix the issue.

     

    Thanks for keeping this thread updated, KenV54

  • fah219 Calculating status...
    Currently Being Moderated
    Oct 15, 2012 2:59 PM (in response to cazmn01)

    After the retina firmware update and 10.8.2 update was installed, when I power on the Mac and I have the external monitor connected to the Thunderbolt Port on the MacBook Pro Retina using DisplayPort to DVI adapter, the computer locks up and never get the login screen.

     

    I also have a Thunderbolt display connected to the other Port too. I boots ok which this monitor connected. This has happened to two MacBook Pro Retina with same configuration.

     

    How can I uninstall the firmware and 10.8.2 update?

  • Wal - E Calculating status...
    Currently Being Moderated
    Oct 17, 2012 10:23 AM (in response to cazmn01)

    Yes, updates can cause strange behaviors.

    -try setting energy saver to default and reboot.  This worked for one case with a MBP RetinaDisplay with external Display

     

    Sometimes just playing with the energy saver / screen saver settings will 'reset' the updates and allow performance to the way it was.

  • Raisi87 Calculating status...
    Currently Being Moderated
    Oct 21, 2012 12:06 PM (in response to cazmn01)

    Thank you @ KenV54!

    I had the same problem with my 2012 MB Retina with the black screen and the crusor.

    To delete the plist file solved the problem as well.

    Thank you so much, it was a better kind of solving than the apple care hotline.

  • KenV54 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 21, 2012 5:36 PM (in response to Raisi87)

    Raisi87,

     

    Thanks for the feedback. Glad it's still helping people.

     

    I haven't figured out if the windowserver plist files are the cause of the video issue in every case.

     

    I'm surprised that Apple still hasn't come out with an OS update fix for this problem.

     

    By the way, this thread is easier than dealing with AppleCare, as you say, but it took an escalated AppleCare session and data gathering to come up with the fix. It may be that AppleCare now has it in their database and can help people immediately when they call with the problem.

1 ... 5 6 7 8 9 ... 14 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.