Previous 1 2 3 4 Next 79 Replies Latest reply: Apr 23, 2013 3:50 PM by Zohak H Go to original post
  • juby019 Level 1 Level 1

    wont work for me the wifi is greyed out

  • Keiichi_K Level 2 Level 2

    What fix... greyed out in settings means hardware is dead. Usually liquid damage or dropped it.

  • paulcb Level 6 Level 6

    Keiichi_K wrote:


    What fix... greyed out in settings means hardware is dead. Usually liquid damage or dropped it.

    Not necessarily.


    Doubtful that wifi hardware died at the exact same time as an iOS6 update for so many people.

  • Airborne_MP Level 1 Level 1

    Wi-FI issues persist. I have tried everything, including all the suggestions in the various posts. Turn this off, turn this on, cross your fingers, but not smiles or joy!!  Apple Support - PLEASE HELP. This is a problem.

  • cuzl8r Level 1 Level 1

    There seems to be 3 separate wifi issues.


    1. wifi disabled

    2. can't access WiFi, not able to connect to local networks.

    3. when trying to connect a network, others were prompted with a log-in screen with just Apple's website, and nowhere to fill in a password. When dismissed that redirected to Apple's site.


    I have issues 1. on iPhone 4s - wifi disabled (greyed out).

    I have tried all known attempts at solutions and none have worked.

    restart phone

    reset network only

    soft reset

    hard reset (full restore)


    toggle this and toggle that, which annoys me becuase wifi is disabled i.e. option is greyed out...usually means you can't toggle it on/off in my book.

    i haven't downgraded as yet. but may have to if its not resovled soon.



    As a side note I am curious to know if others with this specifice issue (disabled) was caused by updating over the wifi as opposed to cable/itunes...

  • mastman26 Level 1 Level 1

    This has been my problem too - no data.

    Suggestion above did nothing for me.

  • hpumac Level 1 Level 1

    Same problem but I think I found a solution:


    Turn off Cellular Data: Settings - General - Cellular


    Go back to connect to your WiFi. Then turn on your Cellular Data again.


    Worked for me!

  • cuzl8r Level 1 Level 1

    This usually means the software is buggy.

    wifi was fine prior to update. have to disagree on this if it was a H/W fault it would have been doing it prior to update when "liquid or dropping" took place.

  • mastman26 Level 1 Level 1

    No joy.  Saw that in another post.  I turned off data, wifi, bluetooth; rebooted; then turned on wifi, BT, and data.  NO change.

  • Cindy023 Level 1 Level 1

    Try calling or go to the Apple store.  I did today and they had to give me a new phone.  They said there's no way to fix the issue where the wifi button is gray and won't toggle to on or off.

  • Phil Ossifer Level 1 Level 1

    I've generally found that IOS WIFI setting are very sticky and you have to tell it to forget then it will let you add something back in. The ultimate is a DFU rebuild to completely start over (after first doing a back up for all the settings) which is not for the faint of heart. Apple is very good about replacing stuff but I've had problems where I replaced the phone, (and still had the same software problem), and thus had to find other solutions based on step by step basic troubleshooting.

  • GonzaloAA Level 1 Level 1

    Didnt work for me :(

  • mastman26 Level 1 Level 1

    Thanks Phil. I appreciate the comments. With my 4S, I have had problems that carried over from my prior 3GS that I am sure are software related. I have resisted a fully clean revert to factory conditions, mainly because i don't want to lose four years of texts with my kids. But continuing to restore from backup only seems to perpetuate the prior problems. And i wonder if in the current case, it has created new ones in that I have no data (wifi is fine) with iOS6.  What a PITA.

  • Rtaxerxes Level 1 Level 1



    If the wifi is greyed out, as the the OP of the original thread this is a reply to said, you can do anything you want, the toggle switch doesn't move. It is unavailable. It is disabled. So telling people to "Switch on wifi" when it is impossible, is not a fix.

  • Phil Ossifer Level 1 Level 1

    If the WIFI is working, and the cellular data is not working I would probably approach my carrier and get them to do an account refresh, and put in a new sim card. It would make sense if you can use the phone, the data would work also.


    I'm not saying this is a fix, but it's one of a series of things that can be done for free, that are not in the replace or fix hardware realm and are simple.


    I've also gone the replace hardware route under Apple Care when it turned out that the problem was truly some error on their part that couldn't be resolved.


    The last time however, they replaced the hardware because they could not figure out the problem, and when I got it home and restored it the problem was still there!


    It took quite a while til I could isolate the issue and come up with my own fix. The Google searches turned up just a couple of people with the same problem and no one had figured it out.


    The point is simply to get it back to a known good point.


    Software can be prone to x in a million bugs that they generally catch, but we also live in a world where various strings of data can also lock up software and cause it to fail that they don't catch simply because it is so unexpected.


    If that fills up past the wrong spot, it can affect other parts by overwriting what is supposed to be there.


    I have no idea about the 4 years of text's and  I can't imagine why that would be a problem  but then again that might exceed what was expected by a developer, so that might be worth exploring.


    The device firmware update did not nuke my texts.  I do back stuff up to iCloud and my computer and before I updated to 6 I had completely rebuilt the phone software from backup first to get rid of any cruft just to be safe.


    I have gone through carrier provisioning problems when upgrading to new hardware, and they assigned things wrong, requiring going back and re-setting them so I would check with them to see if they are registering your device correctly.

Previous 1 2 3 4 Next