Previous 1 2 3 4 5 6 Next 79 Replies Latest reply: Apr 23, 2013 3:50 PM by Zohak H Go to original post
  • ZiziChan Level 1 (0 points)

    Good! But what about those who have the WIFI option greyed... We CANNOT by any means turn it ON nor OFF!!! So what should we do??

  • barbara264 Level 1 (0 points)

    My wi fi button was greyed and useless too. Here is what worked to fix it this afternoon. Having been gone all morning I had turned of my network (cable modem and airport) and taken laptop with me for the day. So nothing was plugged in at the start.


    #1 I totally turned off the phone something I have possibly never done before- that means I held down that sleep button on top for enough seconds to bring up some kind of window confirming to turn it off. The phone is now off.


    Everything else was turned off, too, my having been gone all day w/laptop.


    Now, first I turned on the cable modem and airport, like normal, nothing special. Then turned on laptop, nothing special. THEN turned on phone (I had not corded it into the laptop either) , saw the word "searching" on the top bar where it was looking for its connections. I went to the Setting-> Wi Fi and the button was either working or able to be activated and "My Network Name" was visible, I tapped on it, added the password and it is working fine. (I used it to update my gen. file on the phone which was the goal all along.)


    Time will tell if this holds. But so far so good.

  • Phil Ossifer Level 1 (10 points)

    Cool, another one working!


    Not a bad idea to reset your network connection. Another one of the "free" debugging  solutions worth trying.


    When you reset your cable modem router, and turn off the phone, you are breaking any previous network connections which otherwise would stay the same.


    If you reset the phone, you are only resetting the phone network ip address from your router's DHCP pool. You should get the same address when you reboot, but maybe not.


    The cable modem re-connects to the cable plant, and if left off long enough will provision a different IP address from the pool provided by cable provider. If it just goes on and off, it will probably get the same one so you want to make sure you leave it off for a while.


    Then reboot the  router, which then  also gets this new address from the modem and finally the phone, which attempts to get a new address from your local DHCP pool.


    If anything had gotten stuck in this process, (while connecting and re-connecting while updating) it could have interfered with getting a new IP address.  Again, this is not a "fix' but something you would normally try in resetting everything.

  • moiemoie Level 1 (0 points)

    Wifi is greyed out and I haven't even done the upgrade to ios6. How do I fix this? No water damage, no physical damage. 4s is 4 days shy of being 3 months old.

  • TwitMediaCritic Level 1 (0 points)

    Possible Solution:


    Tried everything seen in the Apple Forums and elsewhere, and nothing.


    This would be in reference to the my iPhone 4, upgrading from IOS 5, a WIFI connecting to the router, authenticating with WPA2, but never getting a DHCP address, manually putting in a static IP, and finding nothing worked.


    I have just resorted to wiping the phone and trying a restore. Even after the total erase of the phone when I went to connect in the inital setup it no longer worked. Since WIFI wasn't working it gave me the option to setup with iTunes. I chose that option.


    It is currently working, the sync is progressing. Hopefully I do not lose the WIFI in the process. If I do I will let you all know.

  • Nero85 Level 1 (0 points)

    If your wifi toggle is greyed out and unresponsive. You can do one crazy thing I found online. Turn your phone off completely and place it in the fridge for an hour. You will then be able to turn your wifi and Bluetooth on. I swear this works. Althought it will not work if you reboot your phone.

  • Raelyn50 Level 1 (0 points)

    Wifi Grayed out, went to Best Buy Geek Squad, no answers. Tried all the suggestions listed here, still no access. I guess I'm headed to Apple Store. All BB could say was probably board dead.

  • TwitMediaCritic Level 1 (0 points)

    What I discussed in my previous post was tedious, but it did work for me.

  • green3418 Level 1 (0 points)

    I had same issue. Had to take phone to Apple store they did diagnosis and determined hardware problem and replaced phone. Since then no issue. They said it might be coincident that wifi broke when i tried ios6 upgrade. but I think it is ios6 damaging wifi. Apple would not admit it yet till more people report issue. 

    My issue happened right after I upgraded to ios6

    Had to go through all reconfiguration and lost my screen protector needless to say spent whole Saturday morning with this phone 

    Not happy with Apple:(

  • moiemoie Level 1 (0 points)

    Took the phone to Apple store and they couldn't do a diagnosis today. Told me to schedule an appointment for Thursday morning! Absolutely ridiculous, the store wasn't even that busy with customers today, but the hipster working there claimed all appointments were booked.

    I am Extremely unhappy with Apple and rethinking about purchasing a Macbook next month...


    Apple just isn't the same as it used to be and not for the better by ANY stretch of the imagination.

  • TheOfficialYu Level 1 (0 points)

    I cannot get the wifi toggle switch to become "ungrey".  Does anyone have the answer to this?  Ive resetteding my phone, Ive hard-start the phone, Turn-off and turn-on the phone, reset the network, ive done everything everyone has said and still the switch is greyed out. This started happening after I upgraded my 4s to iOS 6, and I only have had this phone for 2 months... Very upset

  • Nero85 Level 1 (0 points)

    For some reason Apple has not come out with a definitive reason as to why a select (but large) number of people are having WiFi issues. If your phone is under warranty they will swap it out for you. If not under warranty or the moisture sensor is even slightly pinkish, you are on your own. I'm sure this will develop into another "antenna-gate" scandal. The only thing that will ungrey the wifi toggle is to turn off your phone and place it in the fridge for 10 minutes. You will be able to turn on your wifi, but it will not connect. I spoke with Verizon technical support and she said "sounds like the update fried your wifi chip". This was a direct quote.

  • cuzl8r Level 1 (0 points)

    Siri, was no help either ...

  • reneeaustralia Level 1 (0 points)

    I have an iPhone 4S.  Also having this problem with no longer being able to connect to wifi after I upgraded to iOS6.  Also very disappointed like everyone else.  I do not have the option of going to an apple store as I have moved from Australia to The Netherlands.  Have tried restore, turning on and off and everything else here (but not going to try the fridge suggestion!).  Sometimes wifi is greyed out, other times after I turn it off and back on, it shows my wifi network, but will not connect.  Also started having problems lately where my screen will freeze or go black.  My phone is not yet 2 years old and I rely on it daily so hope there is a fix sorted soon.

  • f-50 Level 1 (0 points)

    Getting error 3194 when trying to restore and downgrade


    Delete the file C: \ Windows \ System32 \ drivers \ etc \ hosts (Windows) / etc / hosts (Mac OS X) line
    , And put the firmware by downloading it from an external source via Shift + Restore.