14 Replies Latest reply: Jul 1, 2013 9:15 PM by simon asdf
Jerad Hofmeister Level 1 (0 points)

It's baaaaaaaaaack.

I'm having drag and drop problems, AGAIN!


Solution from the topic Drag and drop issues 10.8.1 no longer works. from here: https://discussions.apple.com/message/19359042#19359042

I do dragging and dropping all the time so I NEED this to work!


Anyone else know how to fix this?


I'm on a 15-inch MacBook Pro Late 2008

  • macjack Level 9 (51,639 points)

    Go to your Finder "Go" menu hold the option key and choose Library. Then go to Preferences folder and trash this file:



    Then, restart, or log out and in again.

    (You will have to reset a few finder prefs the way you like them.)

  • Jerad Hofmeister Level 1 (0 points)

    Tried what you suggested, no luck. Issue still persists.

  • macjack Level 9 (51,639 points)

    Try starting up in Safe Mode  (It will take more time to startup because it runs a directory check.)


    If your apps function correctly that way, go to System Preferences >> Users & Groups >> Login Items and remove them. Boot normally and test.


    If the issue is systemwide, then you may be able to repair by booting cmd-r to your r

    Recovery Volume and re-installing Lion. This will be an "install in place" and shouldn't effect your data and settings.

  • thinkblue77 Level 1 (10 points)

    Having the same issue, can no longer drag and drop anywhere in the OS, even within iTunes while trying to move app icons to different screens.


    Tried starting in Safe Boot, which did allow for normal behavior for dragging and dropping. However, performing the second step of removing login items, then booting normally, did nothing.


    Anyone have any other thoughts on this? It's quite maddening to say the least... 

  • macjack Level 9 (51,639 points)

    thinkblue77 wrote:


    Having the same issue, can no longer drag and drop anywhere in the OS

    Some areas of the OS you do not have permissions but within your HOme folder (except hidden Library folder) you should be able to drag & drop.


    Might try repairing permissios on your Home folder, which isn't touched with a normal Repair Permissions.




    Startup holding command-r keys.

    1. You will boot into the Repair Utilities screen. On top, in the Menu Bar click the Utilities item then select Terminal.
    2. In the Terminal window, type resetpassword and hit Return.
    3. The Password reset utility launches, but you’re not going to reset the password. Instead, click on the icon for your Mac’s hard drive at the top. From the drop-down below it, select the user account where you are having issues.
    4. At the bottom of the window, you’ll see an area labeled ‘Reset Home Directory Permissions and ACLs’. Click the Reset button there.

    The reset process takes a couple of minutes. When it’s done, quit the programs you’ve opened and restart your Mac. Notice that ‘Spotlight’ starts re-indexing immediately.

  • thinkblue77 Level 1 (10 points)

    Found the fix, at least for the issue I was having...


    For whatever reason, the problem had to do with enabling audio in AirParrot (I have an older MBP incapable of native AirPlay).


    To fix this:


    - Go to [HD]\System\Library\Extensions

    - Delete AirParrotDriver.kext & APExtFramebuffer.kext

    - reboot


    Hope this helps anyone else who was pulling their hair out over this.


    The original Lion solution for this was found here:


  • thinkblue77 Level 1 (10 points)

    Further information on this from AirParrot's site:


    • Q I'm having issues with my screensaver activating or drag and drop issues.
    • A Unfortunately these issues are related to a bug with Apple's Nvidia drivers on earlier MacBooks. The only way to remedy this is to remove the AirParrot driveror to disable your screensaver. The following Macs will have this issue when using the External Display driver in AirParrot: MacBookPro5,5 MacBook Pro (13-inch, Mid 2009), NVIDIA GeForce 9400M, MacBookPro5,4 MacBook Pro (15-inch, 2,53 GHz, Mid 2009), NVIDIA GeForce 9400M, MacBookPro5,3 MacBook Pro (15-inch, Mid 2009) NVIDIA GeForce 9600M GT and GeForce 9400M. We've provided this tool to remove the graphics driver.
  • macjack Level 9 (51,639 points)

    Thanks for the feedback!

  • Jerad Hofmeister Level 1 (0 points)

    Well, I deleted everything associated to AirParrot and drag and drop is back! I never thought a simple program would cause so much trouble.


    Thanks for the help everyone!

  • scottuf Level 1 (0 points)

    i've also seen that the problem only occurs after booting, but before the computer goes to sleep.  i have the issue, but don't have air parrot.  everytime i reboot i have this issue, then just close the lid, let it sleep for a few seconds, and wake up, now it works correctly.

  • sonnycheeba Level 1 (0 points)

    I also don't have air parrot. but this fixed my issue until a software update! thanks for posting!

  • richyb Level 1 (45 points)

    Thank you so much! Was driving me crazy!

  • Rick Koconis Level 1 (0 points)

    Not sure if anyone else has bothered to try this, but it worked perfectly for me. I am on a MacPro tower (late 07) so I am restricted to Lion OS. I thought a drive was goiong bad so I have spent way too many hours reloading OS, swapping drives and endless back-ups. The final solution was addressing an issue with the Logitech wireless mouse I was using. For some reason the necessary firmware was either not updated or just didn't come across in any of my multiple migration attempts.


    I tried my original wired mac mouse and voila! everything is back to normal. Now if you have a wireless mouse that you love, don't ditch it just yet. Try to see if there are any software updates for your particular mouse (which I did through Logitech's support on their site) and now I can still use the mouse that I love so much and everything works great. Hope this helps whoever is having this problem.

  • simon asdf Level 1 (0 points)

    I also have a MacBook Pro 15" bought mid 2009 running OSX 10.7.5 and have recently unable to drag and drop.


    I tried Safe Boot and deleting com.apple.finder.plist and it did not work.


    Have read in another post that Air Display can cause this.


    Have just uninstalled Air Display and can drag and drop again.