Previous 1 2 3 Next 267 Replies Latest reply: Jan 10, 2014 11:39 AM by sungyle
canecaster Level 1 Level 1

After doing all the upgrades noted above, I was unable to sync my photos to either my iPhone or iPad.  The sync would stop with an unknown error 1140 message.  I tried all kinds of things, including deleting the iPod Photo Cache folder, restoring the iPad software and setting it up as a new device, and rebuilding the iPhoto library.  If I unchecked the sync photos option in iTunes the sync would run to completion (but of course not sync any photos!).  There were two other oddities in all this.  First, when I would check the iTunes box to sync photos, the option to select specific events was greyed out.  Also, even though there appeared to be no photos on the iPhone or iPad, the little disk usage bar in iTunes would show a couple GB of space allotted to photos.  Clearly something was hosed.


The only way I could finally get things working was to pull a pre-iPhoto 9.4 photo library off of Time Capsule.  I also deleted the iPhoto 9.4 application from the Applications folder and pulled the previous version of iPhoto off of Time Capsule.  Now both the iPad and iPhone will sync properly in iTunes again, the disk usage seems right and the option to choose what photos to sync is no longer greyed out.


But now I don't really want to upgrade to iPhoto 9.4 again.  Anyone have similar issues or thoughts about what the problem might be?



OS X Mountain Lion (10.8.2)
Solved by Joseph Delaney on Sep 21, 2012 2:19 PM Solved
iPhoto 9.4 isn't creating the "&", what it is doing is incorrectly using a plain "&" instead of a special "&" code (the "&" has a special purpose in XML, using "&" tells iPhoto and iTunes that it's just a regular ampersand character - not the "special purpose" XML).  The same thing can happen if one of your songs uses a quotation, apostrophe, greater-than, or less-than symbol - you can see the "XML Entities" on this wikipedia page  (only the shorter list at the top of the page, not the long one). "&" is just the most likely one, and it's the easiest to find.  If you don't have many photo albums, you could also just try going through each photo album in iPhoto, and setting a song to use for the slideshow, one-by-one. 
  • xordinary Level 1 Level 1

    Exact same thing here. So at least you're not alone with this … :-)


    And I might add that in iTunes there is another strange behaviour that seems to be new. As you did, I tried to sync only specific events or albums. In that context I discovered events in the iTunes Photos section that don't exist in iPhoto, like Movie 123, Movie 456 etc. I guess those are movie clips I shot with the iPad, imported to iPhoto but sorted them into events.


    So the fact that those Movie items appear in iTunes indicate that there might be something wrong with the iPhoto library. But – as you wrote – all the rebuilding and repairing does not lead to anything. So I will ry and restore the pre-update versions of the library and iPhoto Application and report back here.

  • canecaster Level 1 Level 1

    Thanks.  I have a case with Apple - it got bumped to a second-level guy and then he's referred it to "engineering", which I guess means that Scotty's working on it.  ;-)


    If they report back to me with anything useful I'll post again.

  • theob Level 1 Level 1

    I have done everything canecaster did too, with the exception that I'm still on iPhoto 9.4 without any pics on my iPhone. It clearly seems is not an iTunes problem but it relies on iPhone solely. I've managed to sync another iPhoto library successfully, and there was no problem with selecting specific events and albums. However when I turned back to my original iphoto library after that, it stil doesn't work and the "selection option was still greyed out.


    I hope they will come up with a quick fix soon!

  • rjans Level 1 Level 1

    I also hope they come with a fix soon. Same problem after upgrading to iPhoto 9.4. Did not have problem with iPhoto 9.3.2 with iOS6 and 10.8.2. A seriuos bug in 9.4.

  • samplane123 Level 1 Level 1

    Same problem here since upgrading to 9.4. Not happy at all, Apple really need to get a fix out asap.

  • ubic Level 1 Level 1

    Same problem for me. No problem with the Aperture Library, but doesn't work with iPhoto Library and albums. Same error 1140. Help!!!

  • George Mcgee Level 1 Level 1

    Same problem here. Error 1140 when trying to sync multiple devices on both iOS 5.1.1 and iOS 6.0 using iTunes 10.7, iPhoto 9.4 and Mac OS 10.8.2. The option to select individual albums, events or faces is disabled. I have to turn off photo syncing entirely (while leaving my pictures on my devices) in order to successfully sync. This certainly seems to be an issue with iPhoto 9.4 and I seem to remember something similar happening a few versions back. This is not an obscure issue so I am not sure why their testing wouldn't have caught this.

  • Mark 24 Level 1 Level 1

    Also have the same issue error 1140 all was fine after I ipdated to ios6 synced no problem but after I installed the 9.4 iphoto update iphote said that i needed to repair the iphoto disc permissions which I have done but started geting the 1140 message straight away.  I have also updated thumbnails, cleared ipod cache restored my iPhone 4 from back up and from new but still getting the same 1140 message, this I am sure has been caused by 9.4 and as mentioned previously I also remenber a senario similar to this happening before.  Fingers crossed for a quick fix from apple as I now have no photos on any of my devices.

  • soul2soul Level 1 Level 1

    My issue is similar. My events for iPhoto in iTunes is creating multiple blank folders. Please help before I update to the iPhone 5 tomorrow!!!

  • Level 1 Level 1

    Exact same problem here. When looking into Photo Sync Settings in iTunes, I saw that it automatically switched to sync "All photos..." and the previously used option "Selected albums..." is now disabled and can no longer be selected. To be able to sync my iPhone without error 1140 I turned off Photo Syncing for now and hope for a fix.

  • numerozerosix Level 1 Level 1

    Same problem... I have also to turn off photo synchro to sync my iPhone. This problem appeared just after iPhoto 9.4 upgrade.

    Help !!!

  • DrMael Level 1 Level 1

    I have exactly the same problem after updating! :-( Hope they will find a fix soon.

  • jameshgale Level 1 Level 1

    I performed all the same software upgrades and had the same result.  Now, when I try to sync either my iPhone or my IPad, I get the 1140 error message.  (If I choose not to include photos, I can sync without a problem.)  The syncing problem appeared only after I downloaded iPhoto 9.4.  I had been able to sync after downloading ios 6 and OSX 10.8.2.


    I stopped by an Apple store and discussed this with one of the geniuses.  At least in part in reliance on this thread, he said that Apple is aware of the problem.  He advised that I wait for a software fix, which he predicted would come soon.  The only alternative, it seems, would be to restore the previous version of iPhoto, as canecaster did.  (I probably won't do that at this time and will hope for a quick fix.)

  • John Dorsey Level 2 Level 2

    Though I'm not encouraged to see so many others suffering this problem, it's really helpful to know that others are experiencing it, there's probably nothing I can do in the short term to fix it (short of a downgrade) - that's a major time saver!; and that it's been reported to Apple.  On the theory that *lots* of squeaky wheels may get grease sooner, I'm going to file a bug report myself and recommend that everyone else do so as well.


    (BTW - this afflicts both my iPhone and iPad, which both remain on iOS 5; that would seem to eliminate iOS 6 as the immediate source of the problem.)


Previous 1 2 3 Next