Previous 1 2 3 4 5 6 Next 267 Replies Latest reply: Jan 10, 2014 11:39 AM by sungyle Go to original post
  • jameshgale Level 1 Level 1 (0 points)

    I followed Canecaster's lead and restored iPhoto 9.3.2 from Time Machine.  I also restored my iPhoto library from a couple of days ago.  (I don't know whether iPhoto 9.4 corrupted the photos or the library.)  And predictably, I can now sync again.  I will be ready to set up my new iPhone, which purportedly left the factory in China today and should get to me next week.

     

    I'll be interesting to see how long it takes Apple to fix the iPhoto 9.4 problems.  In the meantime, the little red circle with a "1" in it will taunt me from the OSX App Store icon in the dock, daring me to once again download iPhoto 9.4.

  • BrianInCalifornia Level 1 Level 1 (10 points)

    Thanks for the quick response Andrew!

    Andrew Patterson wrote:

     

     

     

    the iphone photo sync was a big loss, the slideshow music I can live without

    Me too. For me, the new features of 9.4 are no big deal but the loss of photo sync is huge. As I mentioned previously, I'm just going to wait for 9.4.1.

  • Rexpo Level 1 Level 1 (0 points)

    BrianInCalifornia wrote:

     

    Rexpo wrote:

     

    I have the same problem here - OS X 10.7.5, then upgraded iPhoto to 9.4 yesterday. Thank god for Time Machine, I'm rolling back to iPhoto 9.3.

    Right -- thank God for Time Machine! I just rolled back to iPhoto 9.3.2 and restored my iPhoto library. Everything is back to normal. No 1140 error, the options to sync selected events and other items are back, and my photos synced to my iPod with no issues.

     

     

    Yep - works here too - no more greyed out sync options, and I'm now successfully syncing my 6000 pictures back to my iPhone.

  • aponcio Level 1 Level 1 (0 points)

    Same problem here!... I tried everything aside of the downgrade. I'll wait for the fix.

    Thanks

  • alejandrofrombloomington Level 1 Level 1 (0 points)

    Thank you! Your solution worked for me. But I had to change the "&" for "&" in two xml files and one folder:

     

    Pictures/IPhoto Library/Albumdata.xml

    Pictures/IPhoto Library/ILife Shared/Albumdata2.xml

    Music/ITunes/ITunes Music/John Lennon & Yoko Ono

     

    Using TextEdit I chaged the following in both xml files: "John Lennon & Yoko Ono" for "John Lennon & Yoko Ono." The folder called "John Lennon & Yoko Ono" I renamed "John Lennon and Yoko Ono"

  • alejandrofrombloomington Level 1 Level 1 (0 points)

    Never mind. I spoke too soon. XML files reverted to original names and got the error back.

  • mani.de Level 1 Level 1 (25 points)

    Thanks for the hint! I was able to solve it for me based on that information.

    Editing the XML directly is not the solution, of course, because it gets overwritten soon.

    But I just searched the XML for the song names that contained the "&" character and looked what album they belong to. Then I launched iPhoto and just set a different Diashow song for that album (or just deleted the album).

    It works! I can successfully sync my iPhoto photos on my iPhone again.

  • Patrick Lombard Level 1 Level 1 (10 points)

    Time Machine back, problem when away!

  • ubic Level 1 Level 1 (0 points)

    Many many files in iTunes with "&" character. Impossible to change all of them... :-(

  • aburger Level 1 Level 1 (15 points)

    Thanks!

    It works...

    One diashow used a song by "xyz & zyx", I changed it with iTunes to "xyz and zyx"...

     

    Now iTunes syncs again! Yeah!

    All the stress because of ONE song

  • macblue4u Level 1 Level 1 (0 points)

    I had the same error 1140.

    The sync with the iphone 4 worked fine again after i deselectet the  "iPhoto sync2 in iTunes for the iPhone.

    It's a temporary workaround...

    Apple has to FIX this bug asap!

  • W M R Level 1 Level 1 (145 points)

    Exactly! I won't waste time on that either. That's a bug and has to be solved by Apple. I used an older Time Machine backup to downgrade iPhoto and go back to an earlier (not by iPhoto destroyed) version of my library.

     

    Why don't they test their software before releasing it?

  • Joseph Delaney Level 3 Level 3 (590 points)

    Wow. My thanks to Andrew for figuring out the problem with the ampersands in the XML files. That's brilliant.

     

    Here's how to fix it without editing the XML, in a way that should stick.It takes a bit longer, but it's safer than editing the files directly. You'll still have to look at the XML files to figure out what album to change.

    1. Right click on your iPhoto Library (in your "Pictures" folder) and choose "Show Package Contents"
    2. Find the "AlbumData.xml" file and open it in TextEdit or any other text editor
    3. Search (command-F) for "& " - don't include the quotation marks, but do include a single space after the ampersand. It should take you right to the name of the song that's the problem.
    4. Do not change anything! Just look in the lines immediately above the song name, for the name of the Photo Album that's using that song in it's slide show. It will look something like this, if the name of the album was "Vacation Pictures":
        <key>AlbumName</key>
        <string>Vacation Pictures</string>
    5. Close the "AlbumData.xml" file, and close the "iPhoto Library" folder.
    6. Now open up iPhoto.
    7. Look for the album with the same name as the one you found in the file, and click on it.
    8. Click the "Play" icon
    9. You should see some options for the slide show (if the slide show starts playing, just move your mouse and click the "music" icon to get there)
    10. On the music tab, cilck the "custom playlist" checkbox, and drag any song (make sure it doesn't have an "&" in the song name, album name, or artist name) into the custom playlist box.
    11. Click "Play"

     

    That will safely and permanently remove the ampersand from the slideshow, so when you go back to iTunes you should be able to sync selected albums.

  • canecaster Level 1 Level 1 (0 points)

    I didn't seem to have any & characters followed by a space in my AlbumData.xml file.  But I rolled back my iPhoto library to the pre iPhoto 9.4 version.  So I presume the issue is that these single ampersand characters are being created when the library gets updated by iPhoto 9.4?

  • blangen Level 1 Level 1 (0 points)

    Success! Thank you Mr. Delaney.  It worked just as you said.

     

    One FYI for those attempting this fix... Make sure you're working on the Album, not the slideshow.  The offending album im my AlbumData.xml was "ABCD Slideshow" so I worked on that slideshow with no success. I realized that the "ABCD" album that built the slideshow was buried in a folder of old travel photos.  I found it, followed your procedure and viola! All is right with the world once more.  Thanks again.

     

    Oh, and Apple... you're making it difficult to remain an unrepentant Fanboy.  This is "insanely bush league"

Previous 1 2 3 4 5 6 Next