Previous 1 2 3 Next 37 Replies Latest reply: Feb 22, 2015 4:12 PM by vebaev Go to original post
  • azsharom Level 1 Level 1 (0 points)

    @ventmore unfortunately on my iPhone 4S, in Mail I only get the option to 'Mark as Unread' when I tap the flag icon. Worked fine with iOS 5.1.1. I didn't get any error messages when I updated from 5.1.1. to 6 over-the-air.

  • ventmore Level 1 Level 1 (0 points)

    That's weird.  I had a feeling I was only detailing the steps you'd probably already tried, so I apologise for that, but I have the flag option right there.  This is with an iPhone 5.

     

    Just done some Googling for you.  Are you by any chance using a GMail Exchange account.  Apparently, there is a bug with iOS6 and GMail Exchange, but there is also a workaround here:

     

    http://forums.macrumors.com/showpost.php?p=15815971&postcount=4

     

    HTH

    ventmore

  • azsharom Level 1 Level 1 (0 points)

    And this is why Forums are so helpful!

     

    Thanks @ventmore - that did the trick!!! :-)

  • ventmore Level 1 Level 1 (0 points)

    No problem at all mate......I'm glad it's working for you now!

  • Changren Yong Level 1 Level 1 (100 points)

    I did your suggestion and managed to get the "Not Trusted" Comodo-issued certificate to become Trusted. Right now i can send an signed and encrypted email and the recipient (testing it using my own email) will see that the message is both signed and encrypted. However, if i choose to just signed the email, the recipient will receive an email that is not signed but one that comes with the attachment smime.p7s.

     

    Anyone else having this problem? My personal Comodo certificate was exported from KeyChain in the p12 format (which requires a password be set), emailed to myself, and then installed on my iPhone.

  • Changren Yong Level 1 Level 1 (100 points)

    I also tried a Verign digital signature with the same outcome: Sending just a signed email would show up as an email with the smime.p7s attachment while sending a signed and encrypted email worked.

  • an.ke Level 1 Level 1 (0 points)

    In preferences I let sign and encrypt (booth) "on" and send a email to a mailaddress who not have a cert. The mail app send a uncrypted but signed email out. I send this from iOS6 to myself and received it on iOS6 too. No attachement but a checked-signed-star on the from-address, meaning the signature is working well.

     

    Then i turned "off" the encryption in preferences, signation was still "on". And send a email to the same address, and additionally to a email-address who have a cert to see if there are any differences. But all emails came without a p7s-attachements but well-signed.

     

    I can not reproduce your problem, sorry.

     

    The signature really IS a p7s-attachement of the email. If your mail-client dont know how to use this attachement it will show it as a attachement. In a webmailer like roundcube you will see a attachement called "smime.p7s" for example.

  • Changren Yong Level 1 Level 1 (100 points)

    Hi an.ke,

     

    Questions:

     

    - Is your digital certificate the free one from Comodo?

    - Did you export it out of KeyChain Access as a .p12 format file?

    - Did you email that file to yourself and install it on your iPhone?

     

    Thanks,

    Changren

  • an.ke Level 1 Level 1 (0 points)

    hi Changren,

     

    - yes, I use the free email cert from comodo.

    - yes, I got this cert from comodo-website on my mac and exported it as a .p12 -file.

    - yes I send the .p12-file from mac as a attachement per email to my iPhone. By using the email-account who have got the comodo-cert I switched OFF the cert-signature (the email was not signed and it was unencrypted) so that this email dont have a p7s-attachement too.

     

    I did it for more than one email-account, it was working all time the same way .. with success.

     

    hope this helps

    an.ke

  • Changren Yong Level 1 Level 1 (100 points)

    I have just narrowed down the issue to my gmail account (set up as Microsoft Exchange). I created a digital cert for my mac.com email account and the digital signature for that account works perfectly. I then configured another Gmail account using IMAP (instead of MS Exchange). For that account, the digital signature works.

     

    So looks like the issue is with email account configured using MS Exchange.

  • NOeu_Sunrise Level 1 Level 1 (0 points)

    Same Problem here:

    Google Apps Account

     

    Configured as GMail or Exchange Account the digital signature is not working without encryption.

     

    Configured as Imap its working well.

  • dmiyamoto Level 1 Level 1 (0 points)

    That definitely worked for me. Thank you very much. This was driving me crazy.

     

    I wonder if this has to do with the security breach Comodo had back in March 2012. Maybe Apple decided not to include Comodo in the default keychain so people would have to explicitly trust Comodo as a Certification Authority.

  • rhej Level 1 Level 1 (0 points)

    We use Comodo certs and after spending about an hour playing around this morning I believe I've figured out the issues:

     

    1.  Make sure you export the Comodo intermediate cert from your keychain (it's called "COMODO Client Authentication and Secure Email CA" in my keychain).

    2.  Make sure you export both the public AND private keys for your email certificate!  This is the certificate whose name is the email to which it applies.  This was also the tricky step for me.  I was blindly assuming that if I selected that certificate and clicked export that all was well.  However, doing that only exports the public key as a CER file.  To get both the public and private keys as a p12, you have to click the arrow next to the cert to expand it and then select both the public cert (the parent cert whose arrow you clicked) AND the private cert (the cert that appears below the public cert when the arrow is clicked).  When you export those you will be prompted to enter a password and then they will happily export as a pk12.

    3.  E-mail all of those to your iOS device, and then click on them (intermediate cert first) to install the profiles.  After that, toggle S/MIME on should work fine.

     

    Hopefully that will help some.  Most probably already new this, but I've always used CLI for my certificates and haven't played with the Keychain much.

  • jrc* Level 1 Level 1 (0 points)

    I think I found a fix, and the "Comodo Client Authentication and Secure Email CA" intermediate cert isn't necessary. The problem is that sender's public certificate isn't getting automatically installed.

     

    In iOS 6 Mail, go to a signed email and tap the sender's name (which has the little blue "signed" checkmark seal). It should say "Signed - The sender signed this message with a trusted certificate". Tap the [View Certificate] button immediately under that. The certificate should say "Trusted". Tap the [Install] button. Nothing happens; the button simply toggles between Install and Remove. But that's the key. Now you should be able to decrypt encrypted messages and also send encrypted messages to that same contact.

     

    This is all assuming that S/MIME is configured normally. It works both with and without the Comodo intermediate cert.

  • jrc* Level 1 Level 1 (0 points)

    Upon further thought, this manual step of installing the sender's certificate is probably only necessary due to that missing intermediate cert.