Previous 1 2 3 4 Next 135 Replies Latest reply: May 21, 2015 5:31 PM by FriedFesh Go to original post
  • rrafila Level 1 (10 points)

    Finally got it fixed. Make sure you guys call Apple Support. The first tier tech support is not able to help you because they have not been trained for that You will have to speak to a senior advisor. There will be a lot of deleting of caches involved while in safe mode. After did all that my trackpad and keyboard is working again. Hope you'll get yours working too!

  • Chris Stephens1 Level 1 (55 points)

    Why dont you share with everyone 'how' you fixed it?

  • rockerium Level 1 (5 points)

    Yes, please, share with us the solution to this problem. You said to boot in safe mode, and then???

     

     

    I already erased my disc, installed everything again now I have 10.8.0, and the problem persist even in Bootcamp and in the mac restoration screen, so I think it is an EFI problem.

  • rrafila Level 1 (10 points)

    Umm I thought I just told you guys. There are a lot of folders and caches that need to be deleted, while in safe mode. There is no way I can remember all of them and their location, as I was not able to write down the step-by-step while I was on the phone with Apple Support. As I said, a senior advisor helped me. The first tier support was not able to.

  • YeahChristopher Level 1 (0 points)

    I followed your directions and called Apple Support. WARNING! You must still have AppleCare for them to help you. As I am an early adopter, this no longer applied to me.

     

    Best bet seems to make an appointment with the genius bar. Unless someone can come up with a step by step.

  • rrafila Level 1 (10 points)

    So for those who do not have Apple Care, then the Genius bar is your best bet.

  • rockerium Level 1 (5 points)

    Last night I made a Factory Reset with CMD+R, It downgraded to Lion as I bought. The problem persist.

  • rockerium Level 1 (5 points)

    Last night I made a Factory Reset with CMD+R, It downgraded it to Lion as I bought. The problem persist.

  • mac15back Level 1 (0 points)

    I was able to solve this problem by moving all files under /Library/LaunchAgents/* and /Library/LaunchDemons/* /Library/StartupItems/* to the Desktop and then rebooting.

     

    The problem went away. So obviously one of those files together with 10.8.2 is causing this problem.

     

    Now I just need to add those files back one at a time (rebooting in between everytime) to see which file actually causes the problem.

     

    I hope this info is of any use to you.

     

    /K

  • rrafila Level 1 (10 points)

    Actually some of those files/folders are the one that needed to be deleted.

  • seppanen Level 1 (0 points)

    I'm having the same probem right after I upgraded to OS X 10.8.2

     

    Macbook Pro - 17" early 2008

    2.6 GHz Core 2 Duo

    OS X 10.8.2 (12C54)

  • rockerium Level 1 (5 points)

    And finally, it appears to be solved. The only way that I found was restore to factory settings, install Mountain Lion and Upgrade again to 10.8.2. Now my trackpad is running well. Now I have to install everything again because It was a clean installation.

  • Chris Stephens1 Level 1 (55 points)

    Thanks, This worked for me

     

    I removed the contents of these folders. Nothing there I couldnt live without.

     

    /Library/LaunchAgents/*

    /Library/LaunchDemons/*

    /Library/StartupItems/*

  • rockerium Level 1 (5 points)

    just forget my previous response, it doesn't work...

  • Gozem Level 1 (5 points)

    Hi,

     

    I have the same issue as you do. Keyboard and trackpad seems to go into sleep after some inactivity and takes a few seconds to "wake up" again.

     

    I am using a Logitech wireless mouse using a nano-receiver. This mouse doesn't have the problem.

     

    The problem seems to go away when I cleaned out the content of:

     

    /Library/LaunchAgents/*

    /Library/LaunchDemons/*

    /Library/StartupItems/*

     

    Actually I copied them and cleaned them afterwards. I havn't taken the time yet to put things back one by one, but here is my content for anyone to try to cross reference to see what might be offending agent/daemon:

     

    bash-3.2# ls -lR /Library/Launch*.old /Library/StartupItems.old

    /Library/LaunchAgents.old:

    total 24

    -rw-r--r--  1 root  wheel  697 May 25 02:31 com.Logitech.Control Center.Daemon.plist

    -rw-r--r--  1 root  wheel  788 Jul 27 12:51 com.google.keystone.agent.plist

    -rwxr-xr-x  1 root  wheel  395 Oct 14  2010 com.hp.devicemonitor.plist

     

     

    /Library/LaunchDaemons.old:

    total 32

    -rw-------  1 root  wheel  605 Aug 31  2011 com.dymo.pnpd.plist

    -rw-r--r--  1 root  wheel  814 Jul 27 12:51 com.google.keystone.daemon.plist

    -rw-r--r--  1 root  wheel  568 Mar 10  2011 com.microsoft.office.licensing.helper.plist

    -rw-r--r--  1 root  admin  374 Feb  3  2012 com.telldus.service.plist

     

     

    /Library/StartupItems.old:

    total 0

    drwxr-xr-x  5 root  wheel  170 Jan 10  2012 ChmodBPF

     

     

    /Library/StartupItems.old/ChmodBPF:

    total 24

    -rwxr-xr-x  1 root  wheel   959 Jan 10  2012 ChmodBPF

    -rwxr-xr-x  1 root  wheel  2551 Jan 10  2012 README.macosx

    -rwxr-xr-x  1 root  wheel    84 Jan 10  2012 StartupParameters.plist

     

    I my self suspect the Logitech driver as it has todo with USB.

Previous 1 2 3 4 Next