Skip navigation

Spotlight not working correctly

57599 Views 148 Replies Latest reply: Feb 21, 2014 10:18 AM by Todd Jacobs RSS
  • Christopher Murphy Level 2 Level 2 (470 points)
    Currently Being Moderated
    Oct 1, 2012 9:54 PM (in response to stcinder)

    It looks like it's just for caching, so it would seem disposable. But anything actively using it probably won't like its cache files vanishing. I'm seeing references that iTunes uses it for downloading apps, not your downloads folder. Once the download is complete, it moves the apps into position (it may be an installer package that's being downloaded). I have previously downloaded one App Store app, months ago, and even though I deleted all /var/folders folders, that app still works.

     

    However, what I notice is that this app is not up to date, and the App Store application is saying no updates are available. If I go to Purchases, it sees the apps I've purchased and there it indicates an update for one of the apps is available. I have no idea if the discrepancy between Purchases and Updates in the App Store app has anything to do with removing /var/folders or if it's a bug, or what.

     

    So if I try to update this app I get a cryptic message saying "To update this application, sign in to the account you used to purchase it." But I've already done this. I only have one App Store account. If I sign out and back in, same message. Not sure if it's related.

  • Christopher Murphy Level 2 Level 2 (470 points)
    Currently Being Moderated
    Oct 1, 2012 10:15 PM (in response to Christopher Murphy)

    Looks like other people have had this App Store problem who did not delete /var/folders. I deleted the app, and was allowed to reinstall it with the same account, and it still has the original purchase date intact. *shrug* Another bug.

  • Dausto Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 1, 2012 10:38 PM (in response to Dausto)

    Hi guys,

    my iMac has completed indexing!!!

    It token about 3 full days.

    For my Mac Book, I think that if I leave it stay turned on for further days, would be possible that it also finish, but unfortunately I use it at work and I turn it on/off every day, so it begin indexing at every switch.

     

    About midimporter, in folder I've only default and no other, so I don't think that is the problem.

  • baltwo Level 9 Level 9 (59,180 points)
    Currently Being Moderated
    Oct 1, 2012 11:38 PM (in response to somewhitechick1)

    I know I'll sound like a complete moron, nevertheless -- what is Sandbox?

    Google;s your friend: search for os x sandbox.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • boldfysh Calculating status...
    Currently Being Moderated
    Oct 2, 2012 2:55 AM (in response to Christopher Murphy)

    Anyway, blowing away the folders in /var/folders, then rebooting, and then either 'mdutil -E /' or adding your Mac OS volume in privacy to prevent searches, then promptly removing it, appears to fix the problem. For me.

     

    And, it appears for me too!  (Mac Pro 1.1) I have multiple Apple ID's but have noticed (so far) nothing detrimental and Spotlight indexing is back to its normal speed.

     

    Will turn Time Machine on shortly and see how that behaves.

  • Dausto Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 2, 2012 3:25 AM (in response to boldfysh)

    Hi, did you toke a look to the content before deleting /var/folder ?

    This is mine:

     

    MacBookDasty:~ dcobianc$ ls /var/folders/*

    /var/folders/b5:

    c2mktw9j7zn0ql1z8l13s33c0000gn

     

    /var/folders/zz:

    zyxvpxvq6csfxvn_n0000000000000          zyxvpxvq6csfxvn_n00000s0000068

    zyxvpxvq6csfxvn_n0000004000001          zyxvpxvq6csfxvn_n00000s800006_

    zyxvpxvq6csfxvn_n000003800000t          zyxvpxvq6csfxvn_n00000sm00006d

    zyxvpxvq6csfxvn_n0000084000021          zyxvpxvq6csfxvn_n00000t800006k

    zyxvpxvq6csfxvn_n00000b000002r          zyxvpxvq6csfxvn_n00000th00006m

    zyxvpxvq6csfxvn_n00000b400002s          zyxvpxvq6csfxvn_n00000tm00006n

    zyxvpxvq6csfxvn_n00000bh00002w          zyxvpxvq6csfxvn_n00000vr00006y

    zyxvpxvq6csfxvn_n00000c4000031          zyxvpxvq6csfxvn_ngzzzzzvzzzzzy

     

    I didn't delete it at moment on my mac book: I'm waiting for any other user confirmations about it is a definitive solution.

    Thanks.

  • CarloCarlo Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 2, 2012 3:55 AM (in response to Jean-Luc)

    Seems that Christopher's solution (removing /var/folder) worked here!

    No idea what else might be affected by emptying that folder though...

    Thank you!

    Carlo

  • stcinder Calculating status...
    Currently Being Moderated
    Oct 2, 2012 4:04 AM (in response to CarloCarlo)

    Worked for me too. And Time Machine worked afterwards, even with Spotlight on.

    Just testing backup over a network now. It looks as if it was slower than with Spotlight off, but I will have to investigate further. It could be just that Spotlight has started indexing one of my backup drives...

     

    Edit. yet it was Spotlight indexing the backup. I put the drive on the private list, and Time Machine is working perfectly.

  • boldfysh Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 2, 2012 4:05 AM (in response to Dausto)

    I deleted mine, rebooted and the /var/folders/ have been recreated but Spotlight and Time Machine now work...

     

    Mac-Pro:zz boldfish$ ls /var/folders/*

    /var/folders/3v:

    5720z9ws6x3249s8msqkmv8w0000gn

     

     

    /var/folders/5t:

    _8979vd94154c3_1rrx_z09h0000gq

     

     

    /var/folders/yk:

    748237l10_d7fhf36vy14_v40000gp

     

     

    /var/folders/zz:

    zyxvpxvq6csfxvn_n0000000000000          zyxvpxvq6csfxvn_n00000b400002s          zyxvpxvq6csfxvn_n00000s800006_          zyxvpxvq6csfxvn_n00000tm00006n

    zyxvpxvq6csfxvn_n000003800000t          zyxvpxvq6csfxvn_n00000bh00002w          zyxvpxvq6csfxvn_n00000sm00006d          zyxvpxvq6csfxvn_n00000vr00006y

    zyxvpxvq6csfxvn_n0000084000021          zyxvpxvq6csfxvn_n00000c4000031          zyxvpxvq6csfxvn_n00000th00006m

  • Dausto Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 2, 2012 7:02 AM (in response to Christopher Murphy)

    Thank you Chris,

    worked very fine for my Mac Book Pro: in half hour spotlight is full indexed!!

    This night I'll try also form mi iMac that was indexed in 3 full days.

  • lauhub Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2012 7:54 AM (in response to Dausto)

    All of this did the trick:

    Disabling Spotlight

    Deleting existing index

    Deleting /var/folders/*

    Re-enabling Spotlight

     

    Thanks a lot. This was blocking my TM backup. It now works... until when ?

  • baltwo Level 9 Level 9 (59,180 points)
    Currently Being Moderated
    Oct 2, 2012 8:57 AM (in response to lauhub)

    To all:

     

    File a bug report with Apple and include what you did. Hopefully, that'll get into 10.8.3 or an 10.8.2 v1.1 update.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • Network 23 Level 6 Level 6 (11,510 points)
    Currently Being Moderated
    Oct 2, 2012 9:42 AM (in response to baltwo)

    baltwo wrote:

    File a bug report with Apple and include what you did. Hopefully, that'll get into 10.8.3 or an 10.8.2 v1.1 update.

    Well, we're all hoping it will actually be in 10.7.6 since this is a Lion issue.

  • baltwo Level 9 Level 9 (59,180 points)
    Currently Being Moderated
    Oct 2, 2012 9:48 AM (in response to Network 23)

    Thanks for catching the brain ****.

    27" i7 iMac SL, Lion, OS X Mountain Lion (10.8.2), G4 450 MP w/Leopard, 9.2.2
  • Network 23 Level 6 Level 6 (11,510 points)
    Currently Being Moderated
    Oct 2, 2012 9:55 AM (in response to baltwo)

    So far, Christopher Murphy's /var/ folder deletion is working for me, and I hope it keeps working, otherwise you will be correct baltwo in that I would have to bail to Mountain Lion to get this fixed sooner.

1 ... 4 5 6 7 8 ... 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (12)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.