Previous 1 4 5 6 7 8 Next 181 Replies Latest reply: May 6, 2014 12:15 PM by Rivanor Go to original post Branched to a new discussion.
  • McKid Level 1 Level 1

    Just a quick note:


    I noticed somehow that my keyboard had changed to English(uk) when it was supposed to be English(Canada). After I installed the right keyboard and removed the UK keyboard, all of my shortcuts began working again.

  • wendy_is Level 1 Level 1

    Unfortunatly deleting & re installing the Emoji Keyboard is not a permanent fix. I found the shortcuts to be garbled again after a while, so deleted the Emoji & did not re install, all was well till this afternoon when the shortcuts just stopped working.


    A re-boot fixed it ~ apparently. Have also reset the Keyboard Dictionary which has been given as a solution earlier in this thread by LucyO912   Settings > General > Reset > Reset Keyboard Dictionary. Time will tell if that has fixed it!

  • lucyo912 Level 1 Level 1

    my keyboard dictionary fix only worked for a couple of days.  my shortcuts aren't working anymore.  :-(

  • irishelysia923 Level 1 Level 1

    I think I've tried all these suggestions. And as everyone else says they only work for a couple days. I guess we will just have to wait for a bug fix on this one!!!!

  • mcclure1 Level 1 Level 1

    Nope not working anymore only worked for a short while....

  • wendy_is Level 1 Level 1

    I think the problem has been caused by iOS 6 bringing in iCloud synchronisation of Keyboard Shortcuts.


    I have tried various fixes mentioned here and some seem to work for a while, then everything goes haywire again. I think I've found the reason, it appears to happen for me when Internet connection is lost. Without WiFi the Keyboard shortcuts are garbled. The reset of the keyboard fixes this so everything works just fine. Re-connect to the Internet with WiFi and nothing. Shortcuts don't work. Re-set the keyboard and they work again! WHAT A PERFORMANCE!


    Come on Apple please fix this and add the ability to turn Keyboard Shortcut synchronisation with iCloud on or off.

  • bawstinredsox Level 1 Level 1

    Iphone 4 with IOS6

    Having the same issues, along with my Imessage not working unless someone sends me an Imessage first.


    I called Apple and had to do a reset of my phone (mind you the IOS6 update erased my phone completely!) and the reset fixed the issue for about 18 hours before the shortcuts stopped working again along with my Imessages.


    Very very frustrating. They better fix this soon. Even my old flip phone had shortcuts!

  • Fletch9871 Level 1 Level 1

    Try this fix:

    1. Set Documents & Data to Off in iCloud Options
    2. Go to Keyboard Shortcuts & delete existing shortcuts
    4. Hold down the power button to shutdown phone
    5. Power phone back up
    6. Create a new Shortcut (In my case the old ones were gone but the ones I was attempting to test with came back)
    7. Test the new Shortcut
    8. Rebuild remainder of Shortcuts
    9. Set Documents & Data to On in iCloud Options
    10. Enjoy


    I tried all the other solutions I could find and non worked. So I started playing and this worked for myself and a coworker.


    Initially my Shortcuts were just in a list form. After performing the procedure above and recreating them they're now listed in alphabetical order with an alphabet selector list just like Contacts on the right. Been working for quite a few days now.


    Hope this helps...!!!


  • jsml Level 1 Level 1

    This worked for me just now. Hopefully, it will stick! (The other solution many are suggesting [to delete a shortcut, hard restart, and add it back] did not work, but I only tried it with one shortcut, not all of them. I have too many to even want to try it.)

  • jsml Level 1 Level 1

    Interesting. Thanks for posting this note.

  • LongCall Level 1 Level 1

    Shortcuts don't work the way they used to before iOS 6 came out.  It's taken me awhile to figure out but in Safari I used to enter my shortcut and then touch the screen near it to get the desired word to come up.  What works for me now is a double touch on the opposite side of the screen.  The word I want pops up just like it used to.  I hope this makes sense and works for you to.

  • Neuey Level 1 Level 1

    I have had the same problem over and over where they will just randomly stop working. What fixes it for me is i turn off/on my phone then go into my settings and click on one of my previous shortcuts I have and just type random stuff to act like I'm editing it but put it back to normal and save it and poof it's fixed. I've done this 8 or 9 times and it works for me every time so hopefully this helps everyone out.

  • Fletch9871 Level 1 Level 1

    Update: Both original phones still working correctly. I've done the same procedure on 4 other phones and they're still working as well. It's a pain to have to recreate the shortcuts but you'll only have to do it once...TheDude

  • rithwik Level 1 Level 1

    This is what i tried and it worked for me,
    1. Kill all the apps

    2. Reboot your device
    3. Go to Settings>iCloud>Documents&Data>toggle the switch off and back on again
    4. Give it a few seconds to sync
    try out your shortcut in the messages app or anyother app of your choice, it should work.


    Hope it helps,

    Cheers !

  • rodrigui Level 1 Level 1

    I just got my shortcuts to work. 


    1. Settings

    2. General

    3. Keyboard

    4. Turned OFF "Auto-Correction"


    Shortcuts are working.  Now to see how long this works for.  Hope this helps.

Previous 1 4 5 6 7 8 Next