Skip navigation

iOS 6 update - cannot connect to wifi with proxy

10143 Views 21 Replies Latest reply: Jan 31, 2013 7:25 AM by Todd7912 RSS
1 2 Previous Next
SJ_School Calculating status...
Currently Being Moderated
Sep 26, 2012 6:14 AM

We have 300 IPad 2's to configure and they cant connect to our wifi.  Since the upgrade we can no longer connect our proxy network as we did before.  We use an explicit proxy where we manually enter the proxy address.  WPA2 Security.  We contacted Apple support and after an hour they said they didn’t know how to resolve the issue and needed to research.  This was 5 days ago so im reaching out to the Apple community.  We contacted our proxy support BlueCoat and they have escalated the issue to their top level support.  After the iOS 6 update we are basically dead in the water.  

 

We select DHCP under our network settings and select Manual under the http Proxy settings.  After filling in the Server, port, authentication info and try to connect, it immediately brings up a safari page that states "Error Opening Page - Hotspot login cannot open the page because it could not connect to the server".

 

The other issue we have even with iOS 5 is we could not connect to https sites.

iPad 2, iOS 6
  • jms703 Calculating status...
    Currently Being Moderated
    Sep 26, 2012 9:22 PM (in response to SJ_School)

    How many of your iPad's are having this issue and running iOS6?

  • Fattious Calculating status...
    Currently Being Moderated
    Sep 26, 2012 10:55 PM (in response to SJ_School)

    Check your if your wireless infrastructure is compatible. In our case we are needing to upgrade firmware on our HP / H3C Wireless as the current version is not compatible IOS6.

     

    We also use Blue Coat Proxy SG and have not yet discovered any specific IOS6 issues when appropriate wireless firmware is being used - as yet (early days).

  • rrichmond Calculating status...
    Currently Being Moderated
    Oct 1, 2012 12:20 AM (in response to SJ_School)

    Hi,

     

    I work at a College in Australia and saw this post. We haven't had the same problems.. iOS 6 seems to be working without issue. However I note you mention:

     

    SJ_School wrote:

     

    The other issue we have even with iOS 5 is we could not connect to https sites.

     

    This measns that your proxy is not working appropriately. You see we found out, (by accidently typing our proxy address incorrectly) that we could still visit all http sites, but could not see our https sites.

     

    Have you tried entering in your Proxies address into safari, and seeing if you can see the text file? It would seem to me at least, that for some reason your iPads are not able to read the file. This may be due to permissions on the file. Check this out if it is being run on a Linux based OS.

  • Gi5_Ghosthunter Calculating status...
    Currently Being Moderated
    Oct 1, 2012 6:51 AM (in response to SJ_School)

    HI

     

    I'm an engineer at a Hospital looking after BYOD.

    We've just had the same as above, users bring in ipdas and phone upgraded to IOS6.

    We're using a Cisco wireless nework and bluecoat SG in trnasparent mode.

    If I put a static bypas in the ipad connects to the web page "sucsesfull", soon as I take the by pass out, this no longer works.

    Had no problems with IOS 5.

    Do have the same kind of problem with Android, but in a call with supplier regarding this.

     

    Will be interested to see the out come as we've tried all these hard resets.

     

    Luckly non of coporate devices have been upgraded yet.

     

    cheers

  • Todd7912 Calculating status...
    Currently Being Moderated
    Oct 1, 2012 8:47 AM (in response to SJ_School)

    Our school is having a similar problem with the iPads that were updated to iOS6. We don't use a proxy but we have a Sonicwall and the user has to login to the Sonicwall before the device can have Internet access.

     

    Here is what I have found and maybe it will help you. The problem (for us) is that immediately after the iPad is connected to our Wifi it tries to contact the Apple servers in California. This connection is blocked by the firewall because the user has not had the opportunity to login to the firewall. The iPad opens a screen that is not part of Safari to allow the user to log into the firewall but they can't because a pop-up window is needed and this application has no settings to allow pop-ups. Under normal circumstances the user would open Safari and login but if we try to switch to Safari it cancels the connection attempt and disconnects from the Wifi. Obviously, this means we no longer have a connection to our Sonicwall. 

     

    The trick I am using to make it work is this. (Keep in mind, we don't normally use proxy settings). I set the http proxy setting for the particular network to AUTO. This causes enough confusion in the iPad that, if I am quick enough, I can open Safari and log into the firewall real quick. Once that is done it will work fine....until the user goes to a different access point.

  • MrUs Calculating status...
    Currently Being Moderated
    Oct 2, 2012 3:52 AM (in response to SJ_School)

    Try adding the following addresses to the proxy whitelist:

    http://gsp1.apple.com/pep/gcc

    http://www.apple.com/library/test/success.html

     

    After getting an IP-address, seems iOS6 wants to "phone home".

  • mshultz78 Calculating status...
    Currently Being Moderated
    Oct 11, 2012 10:51 AM (in response to MrUs)

    Can you tell me exactly what the 2 address are?

  • MrUs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 5:46 AM (in response to mshultz78)

    mshultz78 - I'm assuming you're asking me that question.

     

    we whitelisted the following addresses in our Squid proxy:

    gsp1.apple.com

    www.apple.com

     

    Hope this helps.

  • mshultz78 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 12, 2012 6:39 AM (in response to MrUs)

    Actually what I was wondering is if you could tell me what gsp1.apple.com is actually used for.  Since upgrading our iPads to iOS 6 we cannot get an IP until our iPads connect to that address.  We use an appliance called Websence which requires authentication before accessing the internet, as soon as you connect to an SSID you get a Websence prompt, after authentication you get a blank page with only the word success on it.  After tracking the location we found that it is going to gsp1.apple.com and just wondered if there was a way areound this, and why this stops our iPads from getting an IP if they done connect to it.

  • MrUs Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 8:53 AM (in response to mshultz78)

    Sorry, don't know the answer.

    Once both web sites were whitelisted, we were able to authenticate within our own system.

    Oh, also Safari opens for some reason.

    Luck.

  • Gi5_Ghosthunter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2012 2:41 PM (in response to SJ_School)

    Hi

     

    I tried the 2 urls in blue coat, put them to not authenticate, so should be no problem. Didn't work, then just put a wild card in for apple.com, this still doesn't work.

    Think may have to do with session cookies, every time a new browser page is opened you need to reauthnticate or or will loose the wifi settings.

     

    if I put the iPad in a static bypass there is no problem.  So seems to be the way it handles cookies.

    Somehow I did get it to access a website but then it failed again.

     

    We're are just using wpa2psk for the WLAN for iPad, but the blue coat require windows authentication via Iwa.

     

    Hope this helps

  • blokerip Calculating status...
    Currently Being Moderated
    Jan 9, 2013 6:47 AM (in response to SJ_School)

    Hello,

     

    Just found following On the Blue Coat support site

     

    Problem Description

    ITunes application on the Apple phones uses different headers than the standard HTTP headers to represent the expired objects time.
    These headers are not recognized by the proxy since they are not standard HTTP, and hence the proxy may server expired objects that can lead to terminating the application.
    Please see both the request and respond below ( the application is using x-apple-lok-expire-date header

     

    Resolution


     

    Apply the policy below to your local policy file to bypass cache for the traffic coming from itunes.apple.com and any request using it as referer

    <Proxy>

    request.header.Referer="itunes.apple.com" bypass_cache(yes)

    url.domain="itunes.apple.com" bypass_cache(yes)

     

     

     

    Hope this helps

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.