Previous 1 2 Next 26 Replies Latest reply: Jun 29, 2006 12:44 AM by itlaw
RichB UK Level 1 Level 1 (0 points)
I've just inserted a blank CD into my Macbook Pro and it is completely stuck and will not come out. Has anyone any suggestions. I can't write any data to it and it is constantly trying to eject but with no success. I've tried dislodging the CD with the end of a paperclip but still no success...PLEASE HELP!!

Macbook Pro, Mac OS X (10.4.5)
  • Mark Hunt Level 4 Level 4 (1,070 points)
    Shutdown, restart and right before you press the powerbutton to restart hold down the mouse button until the CD ejects. If that doesn't work I'm not sure if this will, but you can try...(it is for a PBG4 but it might work anyway)

    http://docs.info.apple.com/article.html?artnum=88068
  • RichB UK Level 1 Level 1 (0 points)
    Still no luck getting this CD out, I've tried everything, including turning the MBP upside down whilst booting up!! It is only attempting to eject when I hold down the mouse button whilst booting up, once it is up and running it won't attempt to eject at all......

    Any other suggestions would be most welcome.......HELPPPPP!
  • terencejai Level 1 Level 1 (0 points)
    I had the same problem.
    I took the MPB to a repair centre. The guy told me it had to be disassambled to take the CDR out.

    I don't know why.... I had tried to use a CDR of the same brand but it was ok, and this one looks like a normal CDR. What's going on?

    Is the super drive normal??
  • ibid Level 1 Level 1 (0 points)
    Rich, have you checked to see if the drive is seen by the system? Check under About This Mac -> More Info -> Hardware -> Disc Burning. Is there a device listed?
  • RichB UK Level 1 Level 1 (0 points)
    I've checked under the About this mac>Hardware>disc burning settings and the device is listed:

    MATSHITA DVD-R UJ-857

    However it still doesn't seem to want to do anything, I cant read the disc or eject at all. Think I may have to take it in...
  • Christiaan Level 3 Level 3 (525 points)
    Same problem here. What is up with Apple's quality control these days? I'm coming across so many problems with these new Intel machines.
  • Christiaan Level 3 Level 3 (525 points)
    I can use the media stuck in my machine (a DVD), I just can't eject it. I also remember when I first started it up the DVD drive made a lot of mechanical noise (eject/insert noise) seemingly going back and forth. Makes the same noise if I try to eject this DVD.

    I've reset PRAM and it didn't make any difference. Mine is also a MATSHITA DVD-R UJ-857
  • Christiaan Level 3 Level 3 (525 points)
    Hey I managed to eject it! Problem is I'm not sure if resetting the PRAM or another thing I tried.

    I initially thought the PRAM reset didn't work because I held the mouse button down to force eject immediately after resetting PRAM and it didn't eject. I didn't try a normal eject once the machine had completely restarted. If I did maybe it would have ejected.

    What I tried instead, thanks to a comment on this forum: http://forums.macnn.com/showthread.php?t=288629 , was to go to System/Library/Core Services/Menu Extras and double-click on eject.menu (which put an eject button in the menu bar) and then click on the eject button now in the menu bar. Bang, out comes the DVD.

    Hope it works for you too.
  • Christiaan Level 3 Level 3 (525 points)
    I have the problem every time I insert a disk now and I confirm that the menu bar eject button is the (temporary) solution.
  • Christiaan Level 3 Level 3 (525 points)
    A couple more observations:

    I had a DVD eject without any problem last night using the normal process. It appears that the problem occurs either randomly or that certain disks are more problematic than others (I suspect the later). The disks I'm currently having a problem with are from lovefilm.com and their labels do seem to be a bit thicker than usual (they're actually kind of bubbly too, there's something wrong with them).

    I've written a letter to Lovefilm.com to see what their response is.
  • RichB UK Level 1 Level 1 (0 points)
    Well after a lot of hassle, I ended up taking mine to the apple store and they concluded that my optical drive motor had burned out. Fortunately (or unfortunately) I had only bought it 14 days previous so they gave me a brand new one and copied all my data over.

    Happy now, but slightly concerned that this happened so easily, through no mistake of my own. My previous G4 powermac lasted me 3 and a half years without a glitch.....

    Thanks eveyone for advice and help!
  • Christiaan Level 3 Level 3 (525 points)
    Well I finally got a DVD stuck that I couldn't eject with the menu bar button eject method. Phoned Apple and after some testing over the phone I'm sending it to Apple to get repaired.

    Hopefully they'll replace the drive with a different brand.
  • Randall Schulz Level 3 Level 3 (800 points)
    I was under the impression that there's only one source for drives with a sufficiently small vertical form factor to fit the MacBook Pro’s smaller vertical size.

    Randall Schulz
  • cal6n Level 2 Level 2 (265 points)
    I believe that this, like the thermal grease issue, is a serious case of poor assembly. When I first received my MBP it refused to eject a particular DVD. I initially managed to solve the issue by holding the machine upside-down and pressing the eject key but decided to investigate further.

    I powered down, inserted a disc half way and then viewed the laqptop from the side. The portion of the disc that protruded from the machine had a slight downward slope and, when viewed from the front, one side was higher than the other. It seemed obvious that the slot in the drive was slightly out of alignment with the slot in the case. I then removed the top panel, took the drive out and slightly loosened the screws holding the mounting bracket on the side that appeared high. This allowed the bracket to be moved up and down by about 0.5 mm. I then held the bracket in its highest position and gently re-tightened the screws.

    Upon reassembly, I tested with a half-inserted disc again and now it was level when viewed from both front and side. I reckon that some discs are slightly thicker than others and so can hit a portion of the case upon ejection.

    As an experienced engineer, I have no qualms about tweaking the assembly of my computers but I shouldn't have to and most owners certainly won't want to!

    IMHO, this, like the thermal paste situation, is another issue that Apple needs to address on their assembly line, maybe with a jig to locate brackets more accurately on the drive. It definitely shouldn't be left to individual owners risking their warranties in order to get their machines running acceptably.

    G5LC, G4 1.4 GHz cube, 2.0 GHz MBP, 15 1.67 GHz & 1 GHz PBs, 800 MHz PB   Mac OS X (10.4)  
Previous 1 2 Next