Previous 1 2 3 4 5 Next 60 Replies Latest reply: Jul 7, 2015 10:21 AM by mbpeebles Go to original post
  • ChrisP1974 Level 1 (0 points)

    I still have issues but learned a work around. Contrary to what someone told me, my settings were not wrong. But I learned that by turning General -> Messages -> Send as SMS when iMessage is not available off, then on again, and in the same place turn MMS off then on again,  then doing hard reset it starts working again. Until it happens again and I have to repeat these steps. Better than if was, still not perfect.

  • pepetooo Level 1 (0 points)

    hey, I only send a text to 10 people and it doesn't send it .. the text is onlt wording and doesn't have any pics ..

    I think it's only an iphone issue !!

  • mledwards Level 1 (0 points)

    This IS an iTunes issue!! I spent a long time in the Verizon store with the only solution to get another phone. I had done EVERYTHING in the threads trying to find a solution.  The only thing that solved the issue is to ERASE ALL DATA AND SETTINGS, then set up as a NEW iPhone.  I backed everything up to iclould bc it only saves data not necessarily the software issues.   I can now send mms!!! yay!

  • sherizzlep Level 1 (0 points)

    I had the exact same issue and have iPhone 5 through Verizon. I called them and they didn't know how to fix it but came to this thread and someone said to turn on carrier settings and it worked for me! I called Verizon so now they are aware. The rep told me that photos cannot be sent using only wifi and that carrier settings must be on to send photos to non-iPhone users.

  • Back door Level 1 (0 points)

    This may help some folk. I've just bought a 5s and after installing the new nano sim, neither the cellular data or MMS would work. Turns out that my carrier detected it was an iPhone, so when sending over the carrier settings,  assumed I had a dedicated iPhone data plan which I haven't. All I had to do was change the cellular data and MMS APN details and it worked. Anyone with this issue should contact their carrier for the correct APN details. In my case I had to swap from to

  • Egret94 Level 1 (0 points)

    Check w/ ATT. If you have Pay Per Use for your messaging service, MMS won't work. MMS is required to send group messages and images.


    If you have ever received a notice to go to see someones picture at some url, that may be because of the PPU account.

  • Ratchet1848 Level 1 (0 points)

    I just purchased a new iPhone 5c and had this same problem.  I had called Verizon and checked all of the websites that had anything on this issue.  I was able to find some good information but nothing that resolved the issue.  I decided it had to be something with my iCloud backup.  I reset the phone and set it up as a new phone and then I was able to send MMS which confirmed my backup theory.


    Back story is, I had an AT&T iPhone 4 that, when I left AT&T, I had carrier unlocked so I could use it on Straight Talk.  When I took it to Straight Talk, MMS didn't work (seeing a pattern).  I had to mess with the APN settings to even get data to work properly.  I was finally able to get MMS and data to work on Straight Talk.  Fast forward to getting new phone.  The APN profile was still in my AT&T phone with the Straight Talk SIM.  I removed the APN profile and put the old AT&T SIM card back in it, ran the iCloud backup THEN I set up the new phone using that backup.  Once it was done restoring, MMS was working like it should be.


    If you run into this issue and are restoring from a back up, make sure that the phone you are getting the backup from did not have an APN profile on it and is using the original SIM card that came with the phone.  It's best to make one last backup once you've made sure of all of those things and use that one to set up the new phone. 


    Hope that helps someone with this problem!

  • whynotzoidberg03 Level 1 (0 points)

    outtapocket's right. i was only connected to my wifi to try and save data. But i turned my data back on and now i can send messages again! I have an iphone 5 on at&t

  • sbits Level 1 (0 points)

    I had the same problem and when I turn off MMS in settings it sends if some in the group are not Iphone users. If all have iphones it sends with mms on. SIMPLE fix.

  • jkvideo Level 1 (0 points)

    I also had the same the problem. After talking with a Verizon representative I found out that because the iPhone 5, 5s, & 5c all use 4G/LTE network when cellular data is turned on, that is the only way to send a photo message. However, if you are near wi-fi, you should be able to turn off cellular data and turn on iMessage to send photos. Now, as far as MMS and SMS is concerned, I was trying to send Group Messages with MMS turned on and Cellular off-it didn't work. I just now turned off MMS, iMessage, and Data, and it worked. I believe, if you're not concerned with data usage, you can just keep iMessage on and data on and everything should work no problem. But for someone like me that is data usage conscious, I turn off my data, iMessage, and just keep it on SMS, and only send photo messages when I have to. It's kind of a scam from the carriers which make you use data or wi-fi to send photo messages. That's just the world we live in. If I am wrong with that, then I would love to learn how to send photos without using LTE, but that's what I was told and has worked for me. In fact, Non iPhone users (older phones) use 3G network, therefore, they can send photos easier than 4G users (that is, if their data is turned off). Just to reiterate, you cannot receive photo messages without data or wi-fi/iMessage being turned on. And, you CAN send group messages if MMS is off and iMessage is off, or if data is on and iMessage is on. Hope that helps.

  • Quziesue Level 1 (5 points)

    not sure what carrier you are using but i use straighttalk and had same is how i resolved it


    1. delete any profiles you have saved settings>general>profile  delete if you see profile there if not go to step 2

    2. turn on wifi (my internet was also not working)

    3. open safari

    4. type

    5. download profile

    6. turn off wifi

    7. turn off phone

    8. turn on phone


    my internet and pictures worked after this, any user, any carrier, no issues....hope this is helpful!

  • nnarro Level 1 (0 points)

    This is the way to fix it!! I just figured it out. 1.Settings 2. Cellular 3. Cellular Data Network 4. Reset Settings (scroll to the bottom) 5. Reset

  • missbee27 Level 1 (0 points)

    Go to your message settings. turn off imessage send mms to non iphone turn imessage back on and it will all work fine.

  • WoncoYacor Level 1 (0 points)

    Oh my gosh! Finally something worked! I haven't been able to send MMS or group messages to anyone not using an iphone, for the last month! It has been SO frustrating. I had tried just about everything recommended on this thread to no avail and was not looking forward to speaking with 5 different people at my carrier (tmobile) who don't know how to fix an iphone. I followed nnarro's advice and did a Reset in Cellular settings, and my pictures have now gone thru! Yay! Thanks so much!!! P.S. write down your current settings just in case this doesn't help solve your problem and you need to reset the "reset".

  • lelkin11 Level 1 (0 points)

    Re-boot your phone