Skip navigation

USB-tethering issues (OS X 10.6.8, iTunes 10.7, iOS 6)

22286 Views 24 Replies Latest reply: Jan 25, 2014 7:31 PM by Foolyeen RSS
1 2 Previous Next
Jay Tulod Calculating status...
Currently Being Moderated
Sep 28, 2012 8:42 AM

S.O.S. I've been getting sick for weeks now after every step I've taken using the group discussion I wasn't successful literally at all. I even clean install my laptop desperate to regain the connection. I really like the usb-tethering, please please help me on this??

I have MB white running SNOW LEOPARD with iTUNES 10.7  and iOS 6 iPhone 4s yet still not detecting USB on my Network under System Preferences.

MacBook, Mac OS X (10.6.8), White
  • AbOdWs Calculating status...

    I have the same problem but on my iMac, SNOW Leopard, itunes 10.7 and iphone 4s with IOS 6 anyone?

  • Michael Lemass Level 1 Level 1 (50 points)
    Currently Being Moderated
    Sep 30, 2012 12:10 PM (in response to AbOdWs)

    Im on os 10.6.8 on 2 machines

     

    I made the mistake of updating to itunes 10.7 on my mac pro.  This was before I updated to ios6 on an iphone 4

     

    Clearly apple didnt test itunes 10.7 before releasing it to the public and yet again we are the unpaid software beta testers!

     

    My desktop did not recognise my iphone when plugged into the usb charger/data cable as it did perfectly fine with itunes 10.6.3

     

    I had to connect via bluetooth since I dont have wireless on the mac pro.  This works but I prefer to tether with the usb cable.

     

    I think its a lot slower via bluetooth than with the usb cable

     

    I know that the phone isnt affected because I left the laptop with itunes 10.6.3 and it sees the phone when plugged into the usb and the internet tethering works fine

     

    This is the case before and after updating to ios6.  updating to ios6 didnt fix the usb tethering problem on my mac pro.  And it tethers fine via usb on my laptop running os 10.6.8 with itunes 10.6.3

     

    Im going to try the kext replacement from the laptop to the mac pro now and see if I can restore the computers ability to see the iphone when plugged in via usb for internet tethering ...

     

    This has really wasted my time and its annoying that apple havent admitted the problem exists or brought out a fix!

  • Parimutto Calculating status...

    I have the same problem on mac os x 10.6.8 updating my itunes to 10.7 connecting the iphone 4s on iOS 5.1.1.

    I have tried to replace the kext replacement of appleUSBEthernet file since it helpled before but didnt work this time. I tried to rollback on an earlier version of itunes but the content could not be read. I have gone through the apple trobleshooting but no avail. was about to upgrade iOS to 6 on the iphone untill i stumbled over this discussion. a remedy to the situation would be great.

  • Kenneth Shiu Level 1 Level 1 (0 points)

    Same problem here. USB tetering loss after upgrading to itunes 10.7. IOS 6 with iphone 5. Anybody offers solutions ?

  • da ferret Level 1 Level 1 (0 points)

    I also have this problem.  I also had an issue where the phone wasn't synching with my macbook calendar and address book.  I fixed this.

     

    SO ANNOYING, I wanted to send mails whilst on the run today and couldn't.  Come on please someone figure out the fix!

  • Hibernian56 Level 1 Level 1 (15 points)

    Another case of bad quality control on the part of Apple...

     

    Luckily I have several Macs, and tend to update only one at a time, an wait to see what they have messed up this time, they manage make quite a few headaches with EVERY update, despite what the appologists would have you believe.

     

    Anyway, having compared two machines, (one updated the other not) the update of iTunes to 10.7 seems to have updated AppleUSBEthernetHost.kext to version 2.3.6 and in the process messed it up (of course, its not their fault).

     

    You need to replace this kext with a good version or an earlier working version, repairing permissions did not work.

     

    To do this, download KextUtility and install it, then drag the old working kext onto the KextUtility icon, it willreplace the broken version and fix any other permission issues in your S/L/E folder.

     

    http://mac.softpedia.com/get/System-Utilities/Kext-Utility.shtml

     

    and the working kexts (if you can't find it on your time machine backup)...

     

    Version 2.2.0 http://db.tt/Fahk9VBe

    Version 2.3.6 http://db.tt/U674UcOV

     

    Nice one Apple, thanks for wasting a few hours of my life, AGAIN.

  • da ferret Level 1 Level 1 (0 points)

    Hi Hibernian56,

     

    The macsoftpedia link you gave above goes through to an exe file, which to my knowledge mac's don't like too much!

     

    Is there another link for a mac version.

     

    tnx


    Dave

  • Hibernian56 Level 1 Level 1 (15 points)

    They don't even allow you to edit your posts...

     

    Try this.. http://cvad-mac.narod2.ru/Kext_Utility

  • AbOdWs Level 1 Level 1 (0 points)

    You are the best

    finally it is working again

  • Michael Lemass Level 1 Level 1 (50 points)

    what you download is a zip file which decompresses to a  .app file which is an app that you put into your applications folder

  • Michael Lemass Level 1 Level 1 (50 points)

    I have now solved my tethering problem - I didnt need to use terminal.

     

    I downloaded the kext utility, unzipped it and put the .app file into my applications folder, then I dragged the kext file from my laptop (AppleUSBEthernetHost.kext   version 2.3.0)

     

    The utility replaced the one that itunes 10.7 must have installed or modified into a backup folder and installs  the one from my laptop where I was still on itunes 10.6.3 and it has the same permissions as the other files in that folder system/library/extensions

     

    I rebooted and plugged my iphone in via the usb charger/data cable and immediatly the system put up a window stating:

    A new interface has been detected

    the "iphone USB" network interface has not been set up.  To set up this interface use network preferences"

     

    I then clicked the blue button NETWORK PREFERENCES

     

    This showed the iphone in NOT CONNECTED status so I clicked on ASSIST me and just keep going, you will notice the red dot beside the iphone changing to orange (no IP address) then it changes to green and all is well!!

     

    Thanks a million to Hibernian56 and whoever made kext-utility!!

     

    No thanks to apple for not testing their software properly and wasting my time with hours of reading online!!!

     

    Im on 10.6.8 on both machines

     

    The problem with the kext file that was updated by itunes 10.7 was that the machine no longer detected the iphone thru the usb cable.  Thanks to the other users on here its now fixed!  ;-)

  • nibblyhop Calculating status...

    This worked for me too! Thank you!

    They should publish this solution on their own USB/iPhone troubleshooting site..

  • furiet Calculating status...

    Hi Hibernian56

    Thanks a lot, it took some time, but it worked.

    Just one observation :

    "and the working kexts (if you can't find it on your time machine backup)...

     

    Version 2.2.0 http://db.tt/Fahk9VBe

    Version 2.3.6 http://db.tt/U674UcOV

    "

    Il had  Version 2.3.6 with SNOW LEOPARD 10.6.8, iTUNES 10.7  and iOS 6 iPhone 4, and it didn't work, so I downloaded the Version 2.2.0.

    I had forgotten to restart tne machine, in order to load the system extensions in memory.

    Hi Michael Lemass

    "This showed the iphone in NOT CONNECTED status so I clicked on ASSIST me and just keep going, you will notice the red dot beside the iphone changing to orange (no IP address) then it changes to green and all is well!!"
    Same for me, the dot remained orange until I choose via the Apple menu to connect via USB iPhone, although there was no IP address.

  • charibancho Level 1 Level 1 (0 points)

    Beautiful! Thank you all! Was in exactly the same spot as furiet and now have it all working.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.