Previous 1 2 Next 24 Replies Latest reply: Jan 15, 2013 8:09 AM by hussain1990
betweenrides Level 1 (0 points)

I just bought the iPhone 5, trying to synch with iTunes to get settings, contacts, photos etc. installed. Got a message that iTunes version 10.7 or later is required. Went to and downloaded the update, got a message that it requires MAC OSX version 10.6.8 or later. My MAC (Intel based) is currently running 10.5.8. When I select Software Update, it tells me that all software is up to date. I'm not sure what to do next. After some searching, I found:


Mac OS X 10.6.8 Update Combo v1.1


Is this ok to install on my machine?

iMac, Mac OS X (10.5.8)
Previous 1 2 Next