Previous 1 2 3 4 Next 45 Replies Latest reply: Nov 6, 2013 2:39 PM by LMSTABLER Go to original post
  • Grant Brunson Level 1 Level 1

    Ah! Hulu Plus is working. 

  • Dan Belluz Level 2 Level 2

    Adam60's solution worked perfectly (using the option key). I just used it this morning on an AppleTV 3 with OS 10.8. Thanks for the info

  • cristump Level 1 Level 1

    I did the downgrade a few weeks ago and all has been fine since then. As of a few days ago, however, my ATV3 is telling me there is a new update available. It doesn't tell me the version so I don't know if it's the update I downgraded from or a newer one that fixes this and other issues. Anyone else observe this behavior? Anyone do the upgrade? Thanks.

  • adam60 Level 1 Level 1

    My ATV3 recently decided that it was time to update to the new version by itself. I don't know how that happens but it did. Luckily I downgraded again because it's still the same 5.1 update. Do not update to the new version. Make sure you google ATV update to see what the latest update number is before you do.

  • LadyThong Level 1 Level 1

    Yikes! Can someone please let me. I'm trying to use Hulu on AppleTV but get the connection error. I've read the thread & I'm not able to plug the Internet in directly (cable is routed from upstairs & no HDMI up there) then go back to WiFi.

  • PJL500 Level 1 Level 1

    (I was unable to use the option to downgrade as itunes would not even recognize the device.) So if that's encountered here's how I fixed it:

     

    The Oct 2012 update bricked my Apple TV-2, although the update went the same as previous updates and the unit worked for a few hours.

     

    Then, next time I restarted it got stuck on "Whats New?" screen (the Continue button would not respond.) After about 7 minutes wait it went to the Home Screen but without response from the remote (I changed in a new battery too.) Then it went to the screensaver and stayed stuck on that. It refused to soft-reboot. I could not restore it either as iTunes (via Micro-USB cable) on my Macbook would not recognize the ATV2. (I tried all kinds of permutations and two Micro-USB cables.)

     

    So I tried putting the ATV2 in DFU (Device Firmware Update) mode using iTunes in Windows 7 (Pro) on Parallels (7). This worked.

     

    Here is How to Put the Apple TV into DFU Mode: (I had to try variations on this to get iTunes to see the ATV2 in Devices.)

     

    Note: You will need a Micro-USB cable to connect your AppleTV with iTunes-for-Windows running.

     

    Step 1: Connect the ATV2 via Micro-USB to computer.

     

    Step 2: Hold menu+down for 6 seconds to reboot. (As that did not work for me I had to disconnect/reconnect power instead.)

     

    Step 3: Then immediately hold Menu+Play (on the ATV2 remote) to go into DFU mode. (Rapid flashing followed by less rapid flashing.)

     

    It (eventually after restarting iTunes, Windows etc) showed up in iTunes/Devices just like an iPhone etc.

     

    Click Restore.

     

    I then had to babysit the update as there are a number of messages to be OK-ed, and, at one time, iTunes for Mac began starting up.)

     

    Back to normal (for now.)

     

    This process was tenuous and required patience - I almost gave up trying to get iTunes to see the device.

     

    [There's probably a hardware issue on some devices (different vendors?). Apple should exchange these defective units for refurbished ones. After all it's their software update that broke the units.]

  • hmapro Level 1 Level 1

    The downgrade to 5.0.2 worked for me, yay! I have Hulu Plus back on Ethernet!

  • Kenneth Penkowski Level 1 Level 1

    After upgrading to 5.1.1, access to Hulu plus and Netflix is working over Ethernet.

  • Nando2012 Level 1 Level 1

    Here is a more detailed instruction on how to downgrade the software. See https://discussions.apple.com/thread/4372428?start=15&tstart=0

  • Nando2012 Level 1 Level 1

    Downgrading the software solved my problems with ATV and hulu.

  • gtrogue Level 1 Level 1

    The latest update fixes the Hulu over Ethernet problem. I would suggest upgrading over downgrading.

  • cristump Level 1 Level 1

    Confirmed. The latest 5.1.1 update works fine with all features over ethernet. The downgrade option is obsolete. 

  • Grant Brunson Level 1 Level 1

    Corrrect.  The 5.1.1 upgrade has fixed the Hulu Plus/ethernet issues. 

  • Nando2012 Level 1 Level 1

    Thanks, ill try updating against/ the 5.1.1

  • scaredpoet Level 1 Level 1

    Sadly. this doesn't fix the problem for everyone.  I just upgraded (over WiFi) to the latest 5.1.1 and Hulu is still not working over ethernet, but fine over WiFi.