Previous 1 2 Next 18 Replies Latest reply: Feb 27, 2013 7:16 AM by cabavyras
borderjoe Level 1 Level 1

Since installing IOS6 on my Ipad3, autofill won't work in Safari.  It used to fill my name and address.  Please help!

 

I've enabled Autofill, switched off Private Browsing, turned off Block Pop Ups...it was fine till I began with IOS6.


iPad, iOS 6
  • JimHdk Level 7 Level 7

    Works fine for me.

     

    Note that whatever website you are using must be coded properly for auto-fill to work.

     

    What site are you talking about?

  • sberman Level 7 Level 7

    Check Settings > Safari > AutoFill and make sure it's on.

  • borderjoe Level 1 Level 1

    Hi,

    Thanks for replying.  i do a lot of competitions via HOT UK DEALS-you go through to loads of sites and there was no problem until IOS6.  I'm afraid i don't understand enough to know about a site being coded properly.

  • borderjoe Level 1 Level 1

    Hi,

    I appreciate the info but yes-i've got autofill enabled-have switched it on and off many times, also done same with iPad.  also have 'use Contact Info at 'ON' and Names and Passwords on too-it was all ok until IOS6.  please, any other ideas?  Looking on the web, I don't appear to be the only one but it's really frustrating!

  • Nicalaine Level 1 Level 1

    Mine quit too.  I havealso tried everything. 

  • borderjoe Level 1 Level 1

    Sorry to hear you've got same problem-can anyone out there help us-I've persevered trying things but just cannot solve it!  Help us Apple, please!

  • Turkenator Level 1 Level 1
    expertise.iphone
    iPhone

    I have exactly the same problem since upgrading to IOS 6 and EE, autofill is activated but NO LONGER WORKS! Apple please fix this bug!!!!

     

    Does anyone from Apple ever read these pages?

     

    Frustrated.com

  • borderjoe Level 1 Level 1

    Hi all,

     

    Still struggling with autofill problem-has anyone found a fix yet?  Are Apple likely to sort it soon?

  • sancho679 Level 1 Level 1

    Hi all,

     

    it seems that the root cause for this issue is identified:

     

    Unfortunately it's not a bug, but a bufix which is responsible for this changed behaviour of autocomplete function in Safari browser.

     

    The bugfix was introduced in iOS 6 and corrects that password input elements on HTML forms with the autocomplete attribute set to "off" were being autocompleted although they should not.

     

    You can check if this is also the root cause in your case by searching in the source code of the webpage with the HTML form if the autocomplete tag is present and set to "off":

    <input type="Password" name="password" ... autocomplete="off" ... >

     

    References:

    [1] http://support.apple.com/kb/HT5503 (search for string "CVE-2012-0680")

    [2] http://www.cvedetails.com/cve/CVE-2012-0680/

  • Tommo83 Level 1 Level 1

    Hey guys, I had a similar problem, and managed to get it working.  Autofill has been an on going issue for me across every ios device I have used.
    In the past simply turning off auto fill then restarting the device would then allow auto fill to work, but not this time around.

    After doing a hard reset (home and Power button), I then turned off private browsing (while autofill is all on).  It asked to close all safari pages.  I selected "close all".  Then I opened safari open the website I want punched in the password etc, and hey presto it asked to remember the login details.  I selected yes and it been working since, with private browsing on or off.

     

    Hope this helps someone.

  • Nicalaine Level 1 Level 1

    That didn't work either.  Annoying!

  • borderjoe Level 1 Level 1

    Still can't get Autofill working ....tried Tommo83's fix but no luck.  But if it's a fix introduced by Apple for security as Sancho 679 said, we can't alter it, can we?

  • maggieriordan Level 1 Level 1

    I am SO ANNOYED!!!!  This is exactly what has happened to my ipad too.  I enter hundreds of competitions and now have to physically type in each one manually.  I hope APPLE is on the case as I have reverted back to my desktop computer to enter competitions.  The ipad is gathering dust meanwhile.

  • JaseC Level 1 Level 1

    I am having the same issue here too. My colleague has an IPAD3 on IOS6 and it works fine.

     

    Mine is an IPAD2, since the upgrade mine doesnt work despite all the suggestions above.

     

    Surely it must be a bug given that two devices on the same IOS version are behaving differently.

Previous 1 2 Next