Previous 1 2 Next 23 Replies Latest reply: Jun 4, 2014 8:46 AM by 497Secrets
Donot Haveone Level 1 (15 points)

My backup computer (2006 MBP) told me it needed 2 months to index the 500GB internal drive after upgrade to Lion (10.7.5) from Snow Leopard (10.6.8).  I dragged the entire internal hard drive into the 'privacy'/do not index space for spotlight, and it's still telling me it needs 2 days to index my computer.  There should quite literally be nothing left for it to index, but it still wants 3 days.

 

I've heard of slow indexing after upgrade, but this is ridiculous.

 

Any suggestions for how to (1) kill spotlight, at least transiently, so it will stop and let me use the beastie reasonably efficiently when I need it for a bit (like right now)? and (2) what could make the indexing so incredibly slow?


MacBook Pro, Mac OS X (10.7.5)
  • John Galt Level 8 (45,943 points)

    This is a common complaint. It seems Apple introduced this problem with a recent update, and we just have to wait for them to fix it.

     

    See this thread: time machine slow in 10.7.5

     

    There are techniques posted to temporarily disable and subsequently re-enable Spotlight. The system depends on Spotlight for a number of tasks, so be forewarned regarding the effects of your actions.

  • Donot Haveone Level 1 (15 points)

    29 pages and no true solution.

     

    Spotlight is seriously broken. 

     

    But thanks for the link--on page 29

     

    https://discussions.apple.com/thread/4324046?start=420&tstart=0

     

    there is a command to disable Spotlight temporarily, so I can get some work done, then I guess let it go back to it's insane task. 

     

    Wish I'd put this one to Lion before 10.7.5, because my backup drive was wiped once I had Lion on here, before I set up the new TM, and I can't go back to Snow Leopard now without a lot of time I don't care to spend on the backup machine. 

  • John Galt Level 8 (45,943 points)

    Once Spotlight finishes, which it will, eventually - you will find Time Machine takes ridiculously long to finish. That was the original symptom of this bug, which I think stems from something Spotlight is doing.

     

    My solution, somewhere in those 29 pages, was to revert to OS X 10.7.4 using Time Machine. Life is back to normal. I realize this is not an option if you just updated to Lion.

     

    I have a question for you - how did you upgrade to Lion? App Store? Did it install 10.7.5 right away, or an earlier version of Lion that you subsequently updated?

  • Donot Haveone Level 1 (15 points)

    I updated directly from the App store to 10.7.5.

     

    I had to download from the App store and had no option to fine-tune the version I downloaded.  I'd bought an earlier version for my other Mac, but the download was automatically the latest version for this computer. 

     

    What a mess.

     

    I only did this because I couldn't access the ML encrypted TM drive for the other mac with this one until I'd updated this to 10.7 or greater.  Otherwise it was fine with Snow Leopard.

  • CenCoast Level 1 (0 points)

    After 24 hours, only got 47 of 450 GB copied in Time Machine.  Worthless now.

    Wake up Apple?

  • jeknight Level 1 (0 points)

    I had a similar problem (Spotlight seemed to take forever to index),  so I applied a quick fix similar to one suggested in another forum post and it worked:

     

    1) Turn off Time Machine backups.

     

    2) Open Spotlight Preferences; select the Privacy tag and drag the icon of your hard drive into the box. This tells spotlight NOT to index your hard drive. (temporary setting)

     

    3) If Spotlight already "indexing", do a normal shut down of the Mac and restart.

     

    4) When the computer is back up, use Disk Utility ( in Applications> Utilites) to fix permissions. Not sure this is absolutely necessary, but in case the issue is related to file permissions, it couldn't hurt.

     

    5) Re-open Spotlight preferences, go to Privacy tab, click your hard drive and click '-' (minus) to remove from privacy and restart Spotlight indexing.

     

    6) After the Spotlight index is finshed (mine took well under an hour), then turn Time Machine backups back on. It only took a little while on my Mac for that too.

  • dawsonm Level 1 (0 points)

    27.png  That worked for me. Thanks for the help.

  • grm2507 Level 1 (0 points)

    Worked for me too.  Went from about 7GB in 3 days (and not completing) to backing up about 42GB in about an hour!

     

    I still have some performance problems copying a largish volume of files (manually) to my backup device but at least I have a full TM backup now.

  • Karl Kaufmann Level 1 (80 points)

    This worked extermely well for me--

    Just had my MBP swiped, and reinstalled off Time Machine on the replacement MBP. Once this indexing bug was taken care per the directions above, the first TM backup did take about seven hours, but all was OK afterwards.

  • rjhouston Level 1 (0 points)

    After unsuccessfully trying dozens of recommended processes as recommended by these forums, this one worked for me too.

    Thank you so much.

  • williamdesign24 Level 1 (0 points)

    Nothing like some good Mac Optimization advice. Thanks! I wish that Apple had Spotlight Preferences set up so that you could specify to index like once a week or month or something like that.

  • saf affect Level 1 (0 points)

    Thank you for these directions! Since a Genius at the Apple store wiped and reloaded OS 10.6.8 on my 6 year old Macbook due to kernal panics, the Time Machine back up was taking almost an hour each time, where it only took minutes before the wiping and reloading of the OS. I couldn't figure out the issue and how to fix it - until I read this. This process worked for me too. Thanks!!!

  • Chef Carlos Level 1 (0 points)

    Muchas Gracias Jeknight from Chicago.  Let's hope this does the trick

  • gearyy1 Level 1 (0 points)

    Great work, fixed!

    Cheers

Previous 1 2 Next