Previous 1 2 3 Next 32 Replies Latest reply: Oct 7, 2013 1:15 PM by B1nzy
BigWorm76 Level 1 (10 points)

I like many others had a problem with my homesharing/Airplay from my PC to Apple TV not working. 


I could share from my iphone, ipad, and itouch's with no problem but I could not Airplay from my PC/itunes or see my main PC's sharing from the AppleTV.


Problem Summary

worked before the last few updates

I can do airplay from iphone and ipads

AppleTV can get to cloud movies and music

Still unable to connect to Windows7 computer running itunes.




AppleTV2 sleep mode off,

ApplyTV2 on wifi,(AppleTV worked while connected via Ethernet)

AppleTV2 and Windows7 desktop - sign out and in to home sharing,

Windows Firewall is off

*****Disable IGMP Proxy Setting from your router (Verizon Fios, etc) *****

I finally found my fix to this and it was to disable the IGMP Proxy setting in my providers router.  I have Verizon FIO and even upgraded my router and still had the problem.  I called Apple support and they said the cause is the network is dropping jumbo packets.  Once I disabled the IGMP setting in my router and then rebooted my AppleTV it worked.


Problem Summary

Re: iTunes 10.6.3 home sharing not working properly

Oct 7, 2012 6:48 PM (in response to Jsimber)


Glad to hear that is working for a lot of people.  How I understand it is when Apple added 1080P is about the time this issue started occuring.  Basically more bandwidth is being requested by apple tv (1080P) and the IGMP was blocking the larger traffic request.  Even though this is not Apple's fault or anyone elses (Providers) for that matter I am sure they cleverly disabled the home share connection all together as a protective measure for their service quality.  If your 1080P movies started getting choppy, then they would take a bigger hit.  When you disable IGMP, you turn off the filter allowing the larger traffic through.




Good look and hope it works for you.

AppleTV 2, iOS 6, AppleTV, Airplay, HomeSharing
Previous 1 2 3 Next