Previous 1 2 Next 13 Replies Latest reply: Dec 29, 2013 1:10 PM by mattiepoodle
reitermoritz Level 1 Level 1

When I change any settings in the Mail preferences for my iCloud account, Mail is refusing to store the settings with the following error message:

 

Invalid Incoming Mail Server

The “Incoming Mail Server” field cannot be empty.

 

But the Incoming Mail Server field is not empty, it contains "p05-imap.mail.me.com" which is also grey and not editable. It's only with the iCloud account. I have other mail accounts in Mail (Gmail, the mail account at my university) and with these there's no problem.

 

Any hints on what is causing this problem and/or what I might be doing wrong would be highly appreciated.


MacBook, Mac OS X (10.7.5)
Reply by Dale Weisshaar on Oct 11, 2012 10:04 PM Helpful

Try a post in the 10.7 Mail forum. You get more help there.

DALE

Reply by Csound1 on Oct 13, 2012 8:49 AM Helpful

Also try this:

 

Rightclick on the Inbox, select Get Account Info, select Mailbox Behaviours, can you change it from there?

All replies

  • Dale Weisshaar Level 6 Level 6

    Try a post in the 10.7 Mail forum. You get more help there.

    DALE

  • reitermoritz Level 1 Level 1

    Dale, isn't that where we already are? When I click your link I get to an overview of posts and amongst them I see this exact thread. Or did I misunderstand you?

  • Dale Weisshaar Level 6 Level 6

    My mistake

  • Csound1 Level 8 Level 8
    expertise.desktops
    Desktops

    In System Preferences>iCloud, uncheck Mail, then in Mail, Contacts and Calendars (also in System Preferences) verify that Mail is unchecked there too (if not uncheck it). Reboot and turn them both back on.

  • reitermoritz Level 1 Level 1

    Csound1, I did exactly what you said, but the problem persists.

  • Csound1 Level 8 Level 8
    expertise.desktops
    Desktops

    Check your settings against Apple's recomendations

  • reitermoritz Level 1 Level 1

    Csound1, thanks for your effort. I checked that page about iCloud Mail server setup you suggested but I don't see how exactly it relates to the problem I described. I don't have any trouble receiving or sending mail with my iCloud account.

  • Csound1 Level 8 Level 8
    expertise.desktops
    Desktops

    reitermoritz wrote:

     

    Csound1, thanks for your effort. I checked that page about iCloud Mail server setup you suggested but I don't see how exactly it relates to the problem I described. I don't have any trouble receiving or sending mail with my iCloud account.

    If the account works what are you trying to change? and why?

  • reitermoritz Level 1 Level 1

    Csound1 wrote:

     

    If the account works what are you trying to change? and why?

    I want to change things in the "Mailbox behaviour" tab, especially I don't want my notes to show up in my inbox.

  • Csound1 Level 8 Level 8
    expertise.desktops
    Desktops

    Remove the iCloud account completely and remake it.

  • Csound1 Level 8 Level 8
    expertise.desktops
    Desktops

    Also try this:

     

    Rightclick on the Inbox, select Get Account Info, select Mailbox Behaviours, can you change it from there?

  • reitermoritz Level 1 Level 1

    I quit Mail, then completely removed the iCloud account from "Mail, Contacts & Calendars" in System Preferences. Then I readded the iCloud account and started Mail again.

     

    That kind of worsened the situation in the way that now when I change a setting in the way described above, Mail crashes (becomes unresponsive so I have to force-quit it) instead of just refusing to save the changes with the error message also described above.

     

    But: I am able to change the settings in the way you mentioned in your last comment (right-click on Inbox, then Get Account Info), which is great!

     

    The situation is still not perfect. I'd already like to change the "Full Name" at the "Account Information" which is not possible at the place that I get to via "Get Account Info".

     

    Thanks a lot for your patience and help, Csound1.

  • Csound1 Level 8 Level 8
    expertise.desktops
    Desktops

    You're welcome, sorry we couldn't get everything though

  • balogfalvi Level 1 Level 1

     

     

    In System Preferences>iCloud, uncheck Mail, then in Mail, Contacts and Calendars (also in System Preferences) verify that Mail is unchecked there too (if not uncheck it). Reboot and turn them both back on.

     

    - - - -

     

    Really ?

     

    I have to say this is the first time I see a Windows-like solution here. Hope we are not sinking the ship and joining the rest of the mortals.

     

    My printer customer support, literally, wanted to solve it's **** drivers by telling me to follow these steps: Uninstall everything, shut down the machine, wait 5 minutes, turn it back on, reinstall everything and see if it works now.

     

    All those problems come from just being sloppy where it matters. The code. Not the deadlines, not the bottomlines, not the milestones, not the sandstones; the code.

     

    Hope Apple won't get sloppy there. Would have to hate to admit It's Golden days are in the past. Because there's nothing left.

     

    */rant*

Previous 1 2 Next