Previous 1 2 3 4 Next 88 Replies Latest reply: May 1, 2016 11:42 PM by Michael Hall5 Go to original post
  • CRMDVM Level 4 Level 4

    Thanks - I am going to note your Apple TV intervention - I hope it sticks - and over the years nothing surprises me - I have come to the conclusion that everything about computers is weird.........

  • Matt Comi Level 1 Level 1

    I had this exact issue and had almost given up. I managed to fix it this evening, hopefully it works for you.


    You can verify that we have the same issue by doing this:


    1. Disable your Airport Express's wireless using AirPort Utility 5.6:


    Screen Shot 2012-11-02 at 1.13.36 AM.png

    2. Connect it with Ethernet and verify that the connection is stable.


    If this is the case, then the issue must specifically be with the WiFi and not something else going wrong inside the device. If you're still experiencing dropoffs in this configuration then sorry, I guess this won't help you.


    The fix:


    Update your router to use WPA2-PSK [AES]. This is the only configuration that worked for me. Second, set your AirPort Express to Join your network using WPA2 Personal security. Again, this is the only configuration that worked. The WPA/WPA2 Personal setting did not work.


    Screen Shot 2012-11-02 at 1.17.12 AM.png

    Restart your router. It should work. My problem was identical to yours. I could see the AE in the AirPlay settings in iTunes for a few minutes after I booted it. Sometimes I could play to it, sometimes not. Once it stopped working, I would need to disconnect and reconnect the AE from power. The light would remain solid green.


    But yeah, it works now. Good luck!

  • eicio Level 1 Level 1

    The router/base station my AEX connects to is an Airport Extreme Base Station.  There is no WPA2-PSK setting.  What is the equivalent setting for the Airport Extreme?  Is it one of the Enterprise settings?

  • Bob Timmons Level 10 Level 10

    WPA2-PSK-AES = WPA2 Personal

  • eicio Level 1 Level 1

    Thanks, Bob.  That's the conclusion I came to doing some digging through Apple's documents on configuring Airport Extreme network.

  • Joachim Blunck1 Level 1 Level 1

    First, if you're in this thread because your AirPort Express dropped with a yellow light, my post is not for you.


    If you're in this thread because you've had a random drop of AEX connected devices during AirPlay playback from iTunes, read on.


    My network:


         Airport Extreme 5G with ethernet connected Airport Extress (old), and wireless AEX (old)

         going to

         AirPort Extreme 5G to extend the network to AEX (old) wired, AppleTV (new) wired, and AppleTV (old) wireless.


    iTune playbck would drop ramdomly to all AEX devices after a few minutes of play.  All AEXs green.


    I gave static IPs to all the AEXs and the Extreme that extended the network.  It didn't corrent the problem.

    I set IPV6 to Link Local, it didn't correct the problem.

    I pinged all the AEXs, it didn't correct the problem.


    I got a prompt from my AppleTV (new) to set my credit card.  I did.  Everything has worked since.


    All good now for several days.  Go figure.

  • finnhammer Level 1 Level 1


    My setup is a PC connected to my router with cat5 cable. The AEX is used as music receiver over by the amplifier, across the living room. I also sometimes use my iphone as source, and the iphone never had any issues connecting and staying in contact with the AES.   But every so often the AES became unavailable to Itunes across the network from the PC.



    Matt Coni wrote:

    -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- -----

    The fix:


    Update your router to use WPA2-PSK [AES]. This is the only configuration that worked for me. Second, set your AirPort Express to Join your network using WPA2 Personal security. Again, this is the only configuration that worked. The WPA/WPA2 Personal setting did not work.

    -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- -----


    I second the above: I configured my router and AEX as Matt suggests, and immediately the the airplay option popped up on Itunes. It has remained available to my PC on the network for over 8 hours now, which is forever compared to previous performance.


    Kudos to Google which brought me here on the top hit due to this search string:  airplay drop off network

  • eicio Level 1 Level 1

    I have an all Apple setup so my new AEX is wirelessly connected to an AirPort Extreme.  My older AEX's never drop off the network, only the new model.  All are set to "join" the network and are used for AirPlay speakers.


    I changed the setting on the new AEX to "extend" the network.  That seems to have solved my problem.  I'm 3 days in and no drop off yet!

  • ZEILLZ Level 1 Level 1

    When I first got my AirPort Express I was having nothing but dropouts, trying to find a solution through Apple and forums, I found nothing that worked for me.


    So if nothing Apple says or reading forums doesn't seem to work, try something as simple as doing what I did. I went into my networking settings for my wireless router and changed the channel on the router.


    Mine was set to 'auto' and I changed it to '8'. I have had nothing but seamless and perfect streaming of my music for about 9 hours straight. It's ridiculous how such a simple change to setting can do.


    I changed it at noon and wanted to test it to see if it worked, I'm still listening to music without any interruptions or dropouts as I type this response.


    I hope my solutions works to any and all who try it, best of luck to you.

  • Floogle Level 1 Level 1

    I had been going crazy trying to get my new AE to stay connected to the network.  Nothing worked.  Never had a problem with my ATV2.  However after 10 minutes the AE would drop off.  I initially thought it was something to do with music stopping and the system going into a sleep mode and couldn't be woken by iOS devices, but the light kept green.


    Just read you post, ( couldn't see AE on my airplay list), changed my wireless channel to 8 from the factory preset auto, and hey presto, it was there.  THANK YOU. LEGENDARY SOLUTION.  APPLE NEED TO POST THIS FRONT AND CENTRE OF THEIR PRODUCT INFO...

  • Chris Wigness Level 1 Level 1

    Hi all.  Fingers crossed, I have not had the problem for 24 hours.


    My AE, which is an older model, was dropping from the network repeatedly.  My main router is a TimeMachine and every day, sometimes more than once per day, I would get an error message saying that my TimeMachine is set up for a WDS network but no other device was detected.  The light on the AE would stay green but the light on the TimeMachine would blink amber.  If I unplugged the AE, waited a few seconds and plugged it back in, the TimeMachine error would go away - temporarily.


    I should mention that my knowledge on this stuff is very limited, so I subscribe to the K.I.S.S. theory big time.


    Yesterday I decided to start from scratch on the AE.  I gave it a hard reset and then went into the airport utility and went to manual setup.  I used ZEILLZ's suggestion and made sure both devices were on a static channel - I also chose channel 8.  Within the manual setup, I chose "participate in a WDS network" with WPA/WPA2 Personal as the security.  I had to type in the password, of course, and under WDS, I had to put in the Airport ID of the "Main," i.e., the Time Machine.  So far, it seems okay.


    As I said, fingers crossed!

  • TwinTiger Level 1 Level 1

    Thanks Zeillz,


    I have been very frustrated recently with Airplay through my Airport Express which is a wireless linked as an extension to my Time Machine in another part of my house.


    I have had drop-outs playing wirelessly from my MacBook and have been watching both my Time Machine and Airport Express "disconnect" from my established network via the Airport Utility!  Both units are blaring green so I was wondering what was going on!  A few reboots of both but no joy.  They are already running the WPA2 Personal security setup.


    I am now trying your fix of manually changing the primary wireless unit (in my case a Time Machine) to the following:

    Under 'Wireless Options'  I have changed the 2.4Ghz Channel to 8, and the 5Ghz Channel to 157.


    With the reboot, I am currently enjoying uninterrupted music again - well so far and for longer than I have in recent weeks!


    I come back and let you know how I have faired in a few days time.


    Thanks for the work-around

  • TwinTiger Level 1 Level 1


    Some positive success.


    Channel 8 was only a marginal improvement

    So I switched to Channel 3 - worse

    So I switched to Channel 5 - no improvement

    So I switched to Channel 10 - OK!


    It still has the odd occasional blip, but that is now just a minor annoyance as opposed to a major frustration.

    So the message here is find the channel that suits your local circumstances?



    Now for an observation ...


    I have about 6-8 iDevices (for the family) which I have set to sync wirelessly over WiFi when iTunes is open.  I have noticed a few instances that the dropout of Airplay seemed to coincide with the 'discovery' of one of those iDevices as it appears on iTunes (greyed) and goes through the Apple handshake.  This suggests to me (the novice) that iTunes might be redirecting some of its Wireless energies to securing the link at the possible expense of the ongoing Airplay responsibilities....?


    I have now disabled the 'Sync over WiFi' option for these iDevices and things seem (so far) to be running much smoother.

  • Floogle Level 1 Level 1

    I did think I had solved my problem by following the advice about switching channels.  But that showed itself not to work after half an hour and it lost the network again.  3 days ago the 7.6.3 firmware came out and updated the airport express. It's been working pretty solidly since then. I have even gone out and come back into the house and my iPhone picked it up almost immediately.

    Hopefully fully resolved.  Funny that the firmware notes say nothing about resolving this issue

  • TwinTiger Level 1 Level 1


    Airport Firmware upgrade seems to be holding up.


    Now I am progressively undoing all the previous workarounds:

    _Set the Airport Wireless Option Channel selection back to 'Automatic'

    _Progressively re-checking 'Syncing my iDevices over the WiFi'


    All with the music playing on the stereo, and the Airport Utility status for my network airports happily 'green'.


    So far, so good ...

Previous 1 2 3 4 Next