Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Director Player Error?

I'm wondering if anyone else is having this problem - just occurred since updating to 10.4.6 (using Software Update from 10.4.5).

I have a G5 quad and can no longer play several games that were working fine before updating - I get the following error message:
Director Player Error
Handler not found in object
#play
Script Error. Continue? (no / yes)

Clicking "No" quits the game - clicking yes leaves the game open, but then it's inoperable - nothing works.

I checked already with the games manufacturers - no help there - just the usual uninstall/reinstall which didn't work. I repaired permissions, verified the disk, etc.

I'm not having any other problems (that I've discovered yet anyway) - just this one, but it's annoying because at the end of my workday I like to wind down with a few rounds of some mindless games and a beer. 😟 😟

Any suggestions?

G5 Mac OS X (10.4.6)

Posted on

Reply

Page content loaded

Apr 14, 2006 6:14 AM in response to TrishaM In response to TrishaM

Welcome to Apple Discussions!
It sounds like they may be running on Macromedia Director, as that's the only program called Director I know about. I would contact the game manufacturer and ask the question if they have tested it yet with 10.4.6 to find out what it is running on and if they have any suggestions.

Apr 14, 2006 6:14 AM

Reply Helpful

Apr 14, 2006 8:44 AM in response to a brody In response to a brody

Thanks - yes it does use Macromedia Director, and that was the first question I asked them (if it was tested on 10.4.6)....they claim no problems with 10.4.6 and that its just me - no one else has reported a problem (yet..?)

I appreciate the response though - I'll keep searching for a solution....

Trisha

Apr 14, 2006 8:44 AM

Reply Helpful

Apr 14, 2006 2:34 PM in response to a brody In response to a brody

Actually Director is used by the game creator - the game player uses Shockwave and/or Flash to run games created by Director, so I don't have Director installed (never have).

I have completely uninstalled and reinstalled Shockwave to see if that would help and alas, it did not.

The odd thing is it worked fine until I upgraded to 10.4.6. I also re-applied the upgrade using the Combo Updater (not SU) with no luck. But apparently I'm the only one having this problem (according to the game manufacturer).....

Apr 14, 2006 2:34 PM

Reply Helpful

Apr 14, 2006 3:29 PM in response to a brody In response to a brody

Yes, I removed all the game preferences - there are no director preferences since, technically, I don't have Director installed - the game is created using Director but uses Shockwave to play. When I uninstalled Shockwave I made sure to find and delete all the preferences there too.

Still a mystery.......

Apr 14, 2006 3:29 PM

Reply Helpful

Apr 14, 2006 3:38 PM in response to TrishaM In response to TrishaM

If you have a clone backup of before you installed 10.4.6, it might be interesting to boot off that to see if the issue persists. It might tell you if some hardware issue exists on the machine which is preventing game play from working right that wasn't there before, or be a way of detecting something wrong with your copy of the program itself. Another experiment would be to get an second hard drive and just do an erase and install on that hard drive, upgrade to 10.4.6 with the combo update and see if the game still had trouble playing after installing just it. Either way you'd be able to detect whether it is a unique hardware issue of your machine.

Apr 14, 2006 3:38 PM

Reply Helpful

Apr 19, 2006 5:27 PM in response to a brody In response to a brody

Okay this took a few days to get done......

I borrowed a extra hard drive and installed OSX 10.4 on it, brought it up to 10.4.5 (using the Combo update, not Software Update Utility), installed the game and it works fine. Then I updated again to 10.4.6 (using Combo update, not SWU) and sure enough the game WON'T play - I get the same error:

Director Player Error
Handler Not Found in object
#play
Script Error. Continue? (yes/no)

The ONLY difference is 10.4.5 to 10.4.6 BUT the game manufacturer says it works for him and others on 10.4.6

I made SURE that my Shockwave was current while on 10.4.5 so I know it isn't Shockwave causing the problem......

Is ANYONE else having Shockwave/Director problems under 10.4.6?

G5 Mac OS X (10.4.6)

Apr 19, 2006 5:27 PM

Reply Helpful

Apr 21, 2006 6:22 AM in response to TrishaM In response to TrishaM

I recently purchased and downloaded a game (Mystery Files: Huntsville) from bigfish.com and receive an error message when I try to open it.

Director Player Error: This program is stopping because too many errors have occurred.

I have tried all that you have tried, with no luck. I've contacted the company and have yet to hear from them. I have not yet upgraded, so am using 10.4.5

I have downloaded current schockwave, flash player, etc. Anything I can think of to do. I have tried to open the game on three other mac computers and receive the same message.

After reading all of the errors associated with Director Player, it sounds like Macromedia/Adobe need to resolve many conflicts.

Please let me know if you come up with a solution.

Apr 21, 2006 6:22 AM

Reply Helpful

Apr 21, 2006 10:37 AM in response to Kathy Weaver In response to Kathy Weaver

Well, odd as it sounds, I'm somewhat relieved to find out it's not just me....:)

Note to a brody: the game is the most current download version - and just to be sure, I downloaded another copy of it and installed in on my "test" hard drive running 10.4.5 and it works perfectly - I also re-downloaded it on my G5 that was upgraded to 10.4.6, checked the package contents against the test version to be sure they were identical, and installed it but it just won't run under 10.4.6.

Since I've also made sure that I have the most current versions of Shockwave and Flash installed, I don't think that there is anything else I can do unless SOMEONE puts out a fix (either the game manufacturer or Apple or Macromedia) - I just don't know where that fix will come from since the game manufacturer claims it works fine for him and others under 10.4.6 and almost no one else seems to have this problem.

note to Kathy - yes, by all means if I manage to get this fixed I will let you know what I did!

Apr 21, 2006 10:37 AM

Reply Helpful

May 13, 2006 10:26 PM in response to TrishaM In response to TrishaM

I just recently purchased a game from Bigfishgames and I keep receiving a Director player error as well. I purchased the newest Mystery Case files game and I cannot get it to run for more than 20 seconds. When it opens there appears to be 2 programs working simultaniously in the doc but when I check the applications switcher only the game and finder were open. I downloaded the newest version of flash but nothing has worked. I am awaiting a reply from the company but I fear I will only get told that it is my computers problem not the game.

There has to be a solution for this problem.

i book G4 Mac OS X (10.3.9)

May 13, 2006 10:26 PM

Reply Helpful

May 17, 2006 4:16 PM in response to db2006 In response to db2006

I'm having the same problem, but I can play the Mystery Files: Huntsville Game, but I can't play the Mystery Files: Prime Suspects game. In the prime suspects game it opens two instances of game, tells me that one of them needs attention, and then I get the Director Player error. And you're right, I didn't have the problem until I did the automatic update.

I have sent two emails to Big Fish Games, but I haven't heard back from them. So, if you hear anything, I'd appreciate you posting it back in this forum.

May 17, 2006 4:16 PM

Reply Helpful
User profile for user: TrishaM

Question: Director Player Error?