1 2 Previous Next 20 Replies Latest reply: Dec 2, 2012 3:31 AM by Ebbitt
Jean Shea Level 1 Level 1 (10 points)

This is weird, but is anybody else having a problem using the apostrophe?


iMac, OS X Mountain Lion (10.8.2)
  • 1. Re: Apostrophe
    Terence Devlin Level 10 Level 10 (123,850 points)

    'No,' he said,  'I'm not, but that's not to say that you mightn't. Can you explain a little more?'

  • 2. Re: Apostrophe
    Jean Shea Level 1 Level 1 (10 points)

    Well, It's been happening in the oddest way, so I think this isn't an OS problem. It only happens in Facebook and for the first time I use it, which is all the time. If I type "It's" I'll get "It' " and then I'm booted out of the comments or post window. Once I type it again, I'm good. It's weird, and frustrating. I don't think it's a problem with Apple. It didn't do that to me when I wrote up a quick note in TextEdit. So I don't expect people here to much worrry about it. But thanks for asking. I'll just have to figure out why that's happening and maybe use another browser or something.

  • 3. Re: Apostrophe
    LaCornista Level 1 Level 1 (5 points)

    Yes! It's very frutrating I only recently identified that the problem is with using the apostrophe in contractions. I've observed the following: 

     

    When I use the contraction " 'll " the cursor moves itself to between the 2 letters "l" when I hit the Spacebar to advance to the next word. The Spacebar behaves like the left-pointing arrow key for just the first time after the contraction.

     

    When I use the " 's " or " 'm "  contraction, no other letters I type show up in the text box. When I hit the Spacebar a second time, my entire screen sctrolls down by 1 window's length. The cursor jumps completely out of the text field I'm typing in. Then when I scroll back up to the original text field and click to start typing again, the Spacebar either does nothing (no space) or works fine if I don't use contractions or acts as a Backspace the next time I use a contraction, a space, and a new word (gives the space but erases the next letter I type).

     

    I'm sure there must be other permutations of contractions and the Spacebar that have some issue, but I hope this is enough evidence to help someone identify and fix this bug. I think it's only happening when I use Facebook. It's been happening for at least a couple weeks. It's not happened while typing this post in the forum.

     

    My OS X is version 10.8.2, and I'm sure Facebook has forced whatever is their latest version onto my interface. The last FB change I noticed was last week when they rearranged the buttons along the top and made the logo link back to the Homepage instead of clicking the Home link.

     

    Thanks for any thoughts on a workaround or fix.

    Linda

     

    PS: True, it doesn't seem like an OS issue. Maybe someone else with the issue will have found a workaround and will post it. Or maybe it'll clear upspontaneously the next time FB makes a change.

  • 4. Re: Apostrophe
    Jean Shea Level 1 Level 1 (10 points)

    Thanks for verifying this problem, LaCornista. I was beginning to think that it was just me. I did send a message to Facebook. I forget how I got the page where you register a bug. Hopefully many others are doing the same thing, so Facebook will react. I've also notice that Facebook's notification drop-down menu at the top will go inactive when I'm in Safari. I have to log out, quit Safari and start up Safari again, and even then sometimes it doesn't work. So I switch to Firefox. The problem there is the latest upgrade of Firefox doesn't offer Rapport protection, which I need to use for my bank. Hrrmph.

     

    These are tiny bugs, as bugs go, but they are annoying.

     

    Good luck.

  • 5. Re: Apostrophe
    LaCornista Level 1 Level 1 (5 points)

    Well, until your post, I hadn't put 2 and 2 together to realize it was only happening in Facebook :-) I also didn't think to try another browser until the issue is resolved! I'll do that as well as look for where to report the bug on Facebook.

     

    Thanks!

    Linda

  • 6. Re: Apostrophe
    LaCornista Level 1 Level 1 (5 points)

    UPDATE: It's happening in more than just Facebook :-( This may well be a safari issue. I was typing in an email field on another website and had the same issue with the cursor jumping back one space after the " 'll " contraction. Are you and I the only lucky ones to have this bug, Jean?

  • 7. Re: Apostrophe
    petermac87 Level 5 Level 5 (4,205 points)

    LaCornista wrote:

     

    UPDATE: It's happening in more than just Facebook :-( This may well be a safari issue. I was typing in an email field on another website and had the same issue with the cursor jumping back one space after the " 'll " contraction. Are you and I the only lucky ones to have this bug, Jean?

    Might well be. Can't replicate the problem in Safari on my MacBook Pros. Strange one. Have you tried validating your fonts for any corruption?

     

    Pete

  • 8. Re: Apostrophe
    LaCornista Level 1 Level 1 (5 points)

    Thanks, Pete. I'm using a MacBook Pro, bought last August. Current on the OS version, I don't remember when this issue started (i.e., did it start with an OS update). I use whatever is the standard font for my Safari. When I get home tonight, I'll validate all my fonts. I just found the instructions online.

     

    I will report later!

    Linda

  • 9. Re: Apostrophe
    LaCornista Level 1 Level 1 (5 points)

    Well, there were 37 fonts with "minor" issues but I didn't see how to get any more info. All except for 1 were duplicates with either the .ttf extension or no extension. I removed them but still have the apostrophe bug :-(

  • 10. Re: Apostrophe
    Jean Shea Level 1 Level 1 (10 points)

    I'm finding the problem is limited to Facebook. It doesn't happen in these forums and I haven't seen it on any other website so far.

     

    FWIW, some nuances that may or may not have anything to do with problem is whether and which options in the Spelling and Grammar features (under the edit menu) I have selected in Safari.

    Apostrophe.png

    Nuance No. 1:

    • If I only have Check Grammar with Spelling checked, the problem goes away after 10 or so characters and there are no problems.
    • If I only have Check Spelling While Typing checked, I don't get tossed out of the window if the apostrophe occurs after 10 or so characters, but the first time I hit the space bar, the space is lost and I have to back up and retype.

     

    Nuance No. 2:

    • If I only have Check Spelling While Typing check and I use an apostrophe within the 10-character window, I get booted and advanced a screen's worth.
    • If I have both items selected or just Check Grammar with Spelling checked, I can type the next letter, and then it's game over.

     

    If you're confused, so am I, and for the most part, nothing bad happens. I just have to go back and deal with a fussy Facebook issue. This problem did not surface until I upgraded to Mt Lion 10.8.2. The only other major event is I was one of those who had to replace my hard drive because it failed. I got a new one and all was good until I upgraded.

  • 11. Re: Apostrophe
    LaCornista Level 1 Level 1 (5 points)

    That seems to mirror what I'm experiencing. I have Check Spelling While Typing and Correct Spelling Automatically (which doesn't correct or identify errors) selected.

     

    Aside from Facebook, I have the same apostrophe issue on the New York Cares website when I use their web interface to send emails. I haven't found the problem on any other sites, but I'll be more careful about taking notice when it happens. Maybe there will be a common thread among the site that can help identify the culprit until the next OS update.

  • 12. Re: Apostrophe
    Jean Shea Level 1 Level 1 (10 points)

    Well, well, I tried out my Twitter page, and it doesn't like the apostrophe. Doesn't matter which setting is selected. I get to the apostrophe and I'm booted. None of the other stuff happens. So I'm inclined to think this is a Safari problem. I didn't notice Twitter so much, but I'm not on it at my mac. I tweet mostly via my iphone or iPad.

  • 13. Re: Apostrophe
    LaCornista Level 1 Level 1 (5 points)

    I thought for a minute that perhaps it was only happening on https sites....then I noticed this was also a secured site. Such a bizarre bug. There's a common thread somewhere!

  • 14. Re: Apostrophe
    digitalintrigue Level 1 Level 1 (25 points)

    I am having the same problem. Depending on the word with the apostrophe, typing the space bar after the word will result in one of these three events:

     

    left arrow (cursor moves back one character but doesn't erase that character)

     

    nothing at all (i.e, no space)

     

    boots the cursor completely out of the text entry window, so subsequent typing goes nowhere.

1 2 Previous Next