Previous 1 2 Next 19 Replies Latest reply: Feb 8, 2016 5:32 PM by hchakim7
sjc229 Level 1 (0 points)

macbook air won't pair with my bluetooth speakers (jambox is one).  but my iphone does it fine so I know it must be the computer.  Any thoughts on how to fix? I've already deleted the bluetooth list in the library folder once and no luck.  It's a brand new macbook air (six weeks old) with the latest OS.  It worked the first few times but now doesn't work at all, possibly coinciding with the last software update


MacBook Air
  • gadget13 Level 1 (10 points)

    I too was having problems with BT pairing on all my devices after Lion update - here's how to fix- shut down your computer, power up and immediatly hold cmd option "r" and "p" (all at the same time) your screen will flash a few times but you want to keep holding the buttons through two cycles of start-up. Release the keys after the second start-up. Then re- pair your BT device and it will work.

     

    I had to do this on my macbook air and mac mini. On the Mac Mini - the system restarted said it was recovering from internet, once it was done all my BT devices worked just fine.

     

    Good luck.

  • ufichina Level 1 (0 points)

    Thanks!  I'd tried several other things to no avail, but this worked great.

  • paglits Level 1 (0 points)

    pdid you say hold the command, option, "r" and "p" all at the same time?

  • gadget13 Level 1 (10 points)

    Yes, but remember to hold it through two cycles.

  • paglits Level 1 (0 points)

    ok thanks...

  • LeaSophie Level 1 (0 points)

    I really want to try this, cause I have the same problem, but doesn't it reset the entire hard drive? :/

  • jpp6708 Level 1 (0 points)

    Hi all, I am having the same proplem with my Mac Air and a Muse mini blue tooth speaker.

    I tried turning my computer off and then restart and held the, command button and the option and the (r) button and the (p) button down all at the same time and I did get flashes and it kept flashing as long as I held down the buttons. There were no restarts just flashes. I let it flash probably twenty five times and decided it wasnt the right road on this. Any one have any more ideas? Jim

  • Venkatraghavan Level 1 (0 points)

    Thanks, worked like a charm when other bluetooth devices were shut off

  • Joaopatroc Level 1 (0 points)

    I tried all this holding button things n no flash came on.. instead came a screen to reinstall the OS X Yosemite again? ***?

     

    Problem not solved at all, n my macbook air still can't pair with my speaker.. supper annoying n frustrating to see my crappy iphone 4s do it n my super machine  not! :-/

  • clive184 Level 1 (0 points)

    Thanks worked like a charm

  • lexamcadams Level 1 (0 points)

    Tried the restart of the NVRAM ... and still failed to connect to Sony SRS-X5 speaker.

  • rightcoast Level 1 (0 points)

    Has anyone found a solution? Brand new Kanto bluetooth speakers....new Macbook Air 2014 edition running latest Yosemite version out of the box. The speakers see all other bluetooth enabled devices...iPhone, Galaxy S3, iPad, Galaxy S3 tablet...just not this Macbook.

     

    UPDATE...it seems a little patience goes a long way. "System...preferences...bluetooth..."...and move a little closer to the speakers lol. Working fine now.

  • PATRICKMELE Level 3 (830 points)

    The standard setting prevents conflict with other Bluetooth devices. If you'd like better audio though, you can change the settings with this terminal command:

    defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" -int 40

     

    This command works in other versions of OS X, but the Bluetooth Audio problems seem worse in Yosemite than previous versions. The number 40 is the sound quality setting. Note: a higher number could cause compatibility problems with other Bluetooth devices, so start at 40 and work your way up.

  • PATRICKMELE Level 3 (830 points)

    "The standard setting prevents conflict with other Bluetooth devices. If you'd like better audio though, you can change the settings with this terminal command:

    com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" -int 40

    Then press enter or return.

    This command works in other versions of OS X, but the Bluetooth Audio problems seem worse in Yosemite than previous versions. The number 40 is the sound quality setting. Note: a higher number could cause compatibility problems with other Bluetooth devices, so start at 40 and work your way up"

     

    this info can be found :http://lifehacker.com/fix-your-bluetooth-audio-in-yosemite-with-this-terminal-16 70380974

Previous 1 2 Next