Previous 1 2 Next 24 Replies Latest reply: Nov 13, 2012 6:48 PM by sharktacos
sharktacos Level 1 Level 1 (0 points)

I am trying to submit the feed for my podcast:

 

http://files.therebelgod.com/podcast/

 

However I keep getting this error message:

 

"We could not complete your iTunes Store request.

The network connection was lost. There was an error in the iTunes store. Please try again later."

 

please advise

  • Roger Wilmut1 Level 9 Level 9 (69,535 points)

    This is probably due to a problem at the iTunes Store server. Your feed is OK - it can be subscribed to manually - so I should just leave it for a few hours and try again.

  • sharktacos Level 1 Level 1 (0 points)

    This has been the case for the last 24+ hours (since yesterday morning).

  • Roger Wilmut1 Level 9 Level 9 (69,535 points)

    As your feed can be subscribed to easily enough there are only two possible explanations: either there is a problem at the Store, which would presumably get resolved eventually: or that your server is reacting normally to requests from browsers but not to requests from the Store. The latter is in fact not imposssible, and there have been some instances of an established podcast not updating for what appears to be this reason, but the circumstances are usually a bit different.

     

    Should it be the latter case you would need to take it up with the people running your server. If it's the Store you can only wait (remember it's a weekend!).

  • sharktacos Level 1 Level 1 (0 points)

    Thanks, that's helpfully informative. I can download podcasts from the store (iTunes succesfuly updated a podcast I subscribe to). Would that rule out the 2nd possibility you mention, or is uploading not comparable to downloading from the store?

  • Roger Wilmut1 Level 9 Level 9 (69,535 points)

    The two aren't comparable. You have to remember that downloading episodes comes from the originator's server, not from the Store. What may be happening is that the Store is having trouble reading your feed from your server. I was able to subscribe. but it was my iTunes application which was accessing your server. If it is the second case (and of course I've no way of telling) then your server is responding to requests from iTunes applications and browsers, but not from the Store itself - which might be related either to the domain itself or the protocol used to make the connection. Only the people running your server can look into that.

  • sharktacos Level 1 Level 1 (0 points)

    Also I'm noticing that it takes a very long time, saying "accessing iTunes store" before giving the error message. Is thar normal? I would not think it would be that hard to read a xml file.

  • sharktacos Level 1 Level 1 (0 points)

    I'm sure that they will claim "it's not on our end" since that's huiman nature. Is there some way to determine this? Some test I can ask them to preform or verify?

  • Roger Wilmut1 Level 9 Level 9 (69,535 points)

    I'm afraid that's outside my experience. I think it's just as likely that there is a problem at the Store end - this sort of thing isn't unknown. I should at least leave it until a reasonable time into Monday in the hope that it might sort itself out.

  • scottjutsu Level 1 Level 1 (0 points)

    I've been having the same problem for days.  Haven't been able to find a fix.  I've validated my feed and successfully added it manually to iTunes.  I've tried submitting it to the iTunes directory from different computers, Mac & Windows, from different internet connections, even from different cities - no joy.  I contacted iTunes support and they gave me a bunch of useless canned answers.

     

    Without any specific instructions from Apple on configuring your server so that the iTunes Store can reach/read your podcast feed, I have to assume that it's something on their end or bad iTunes code.

     

    I'm wondering if there will be a fix in the next (delayed) version of iTunes, due by the end of the month.

  • sozbun Level 1 Level 1 (0 points)

    I'm having the same problem. I know for a fact it's on apples side. I tried a feed from my own server and I also tried a feed from libsyn.com. Getting the same problem. I emailed Apple and they sent me to a post on how to submit a feed. I about came unglued I was so ticked off at their pethetic customer service. I'm launching a pretty important podcast for my brand and my business next week and I couldnt be more disappointed in Apple. Who knows when and if they will get this squared away...

  • chimonster Level 1 Level 1 (0 points)

    I am also having similar problems with submitting my feed and am also fairly certain that it is a problem on the iTunes Store side.

     

    I have attempted to try submitting the feed from sites hosted by yola.com, wordpress.com, and bluehost.com. None of them have worked.

     

    Similar to sozbun, I also have a deadline for launching a podcast for a new brand and am quite concerned with this lapse!

  • Robert Walch Level 4 Level 4 (1,550 points)

    Sozbun - Please contact me off line with your libsyn account info.

     

    Regards,

     

    Rob Walch

    libsyn

     

    rob at libsyn dot com

  • scottjutsu Level 1 Level 1 (0 points)

    Robert, to your knowledge are other libsyn podcasts submitting successfully?

  • Robert Walch Level 4 Level 4 (1,550 points)

    Scottjutsu,

     

    Right now there is a system-wide iTunes update issue.  This seems to be effecting all or at least most shows. 

     

    Apple is aware and working on the issue.

     

    If you are a libsyn customer please contact me at rob at libsyn dot com - and let me know the libsyn slug / account you have.

     

    Rob W

Previous 1 2 Next