1 2 3 4 Previous Next 127 Replies Latest reply: Apr 23, 2014 6:29 AM by nerveonepro Go to original post
  • 15. Re: Icons in menu bar and standard menus are invisible!
    harvey pekar Level 1 Level 1 (0 points)

    good luck.

    i did that three times (reinstall the os i mean) - each time it reocurred after the computer went into hibernation.

    safe reboot solution does offer a work around thankfully.

  • 16. Re: Icons in menu bar and standard menus are invisible!
    Achim Franz Level 1 Level 1 (0 points)

    Hi,

    what got my icons back was a complete restore from backup which does sound odd if it was a bad preference file or application, and a repair of the permissions. One thing I did change was I switched off the full disk encryption which not only prevents you from doing a safe boot, but I also noticed that some applications did not retain their setting. I also would re-install all applications that put icons up in teh menu bar, in my case growl, caffein and controlplane. So far (a few weeks )everything works well.

  • 17. Re: Icons in menu bar and standard menus are invisible!
    Jean-Louis LE PAPE Level 1 Level 1 (0 points)

    I put some notes in French, to allow french people to find this discussion which is really useful !

     

    Probleme lorsque le Macbook pro Retina sort de la mise en veille. Les icones de safari, des preferences et la barre d'outil disparaissent. La solution est de redémarrer en apppuyant sur la touche shift, en mode "safe" puis de redémarrer normalement. Ca a marché pour moi. Merci

  • 18. Re: Icons in menu bar and standard menus are invisible!
    traherom Level 1 Level 1 (0 points)

    I have this problem occuring on virtually every restore from sleep (true sleep, not hibernate, although it occurs then too). Safe boot does fix it for me, but this has become a little rediculous. Apple, fix it!

  • 19. Re: Icons in menu bar and standard menus are invisible!
    Barney-15E Level 8 Level 8 (35,295 points)
    I am using Filevault v2 with full-disk encryption

     

     

    Brandonpoc, you cannot boot into safe mode with FileVault enabled. Try booting into the Recovery HD and repair the disk using Disk Utility.

     

    Safe Mode runs some disk checks which may have solved the issue and Disk

  • 20. Re: Icons in menu bar and standard menus are invisible!
    RSouthern Level 1 Level 1 (0 points)

    I'm currently having the same problem. This is the 2nd time I've hit this since upgrading to 10.8.2 (big mistake!!). It seems to be related to hibernate mode in my experience since most of the time, sleep and unsleep work correctly. I'm almost never use hibernate, except when the battery fully drains, like it did this past holiday. Seems to be a "little unreliable", like the old Windoze XP SP1 days with hibernate on Dells. Sheesh! 10.7.x was fine WRT this issue.

     

    I'm using filevault since that's our company requirement (encrypted company data) so the offered workaround here of going to safe mode then back is a real pain in the back-side. However not having half the icons and getting occasional screens of multi-color static is even worse, so I'm now taking 5 hours to decrypt, then boot to safe mode, then another 5 hours to reinstate filevault. Thanks for a bug Apple that will waste a full business day

     

    BTW, I should point out that I zapped PRAM and have tried to remove as much 3rd party software as I can stand to fix this before coming here, nothing worked. Last time this happened I had to reinstall the 10.8 update which took many hours, which is why I'm trying the FileVault workaround this time.

     

    I *think* this is a corrupt file problem rather than a compatibility issue, especially since everything was working fine before the 1st time and after the 1st reinstall. If safe mode doesn't work I'll reinstall again and start looking for a way to disable the hibernation logic.

     

    Apple, will you be fixing this issue soon?! This really is frustrating and wasting a lot of our time.

     

    -Richard

  • 21. Re: Icons in menu bar and standard menus are invisible!
    Yaggo Level 1 Level 1 (0 points)

    Having had the same problem two times, did a clean OS X re-installation between. In both cases the problem occurred after updating the latest 10.8.2 (including the graphic update) and resuming the machine from overnight sleep (i.e. hibernation or write-ram-into-disk sleep mode).

     

    At first time I had Filevault enabled so I was unable to boot into safe-mode. At second time (after the re-install) the FileVault was not enabled and booting into safe-mode and then back to normal mode solved the problem. I disabled hibernation as a temporary work-around (sudo pmset hibernatemode 0).

     

    Reported the bug at https://bugreport.apple.com

  • 22. Re: Icons in menu bar and standard menus are invisible!
    Yaggo Level 1 Level 1 (0 points)

    Got the issue again, disabling hibernation didn't help. This how to fix permanently fix it:

     

    1) Reboot your machine into recovery mode by keeping cmd+r pressed before Apple logo appears.

    2) Re-install OS X using recovery mode (don't worry, your data will not be deleted). May take couple of hours because OS X is fetched over internet.

    3) Once the system is again up and running, do *not* install the graphic update (until the bug is resolved).

     

    I can confirm that re-installing OS X (Mountain Lion) leaves your data untouched on the disk (e.g. home directory, /usr/local, etc), but of course you should always have backups.

  • 23. Re: Icons in menu bar and standard menus are invisible!
    traherom Level 1 Level 1 (0 points)

    For those of you still on 10.8.2, I'm currently trying an experiment of having Power Nap fully off (even when plugged in) and haven't experienced lost icons or graphical snow in around four days. Previous it happened at least once a day, so I'm feeling oppomistic.

     

    I'd love to hear if this alleviates the issue for others or if I'm just getting lucky.

  • 24. Re: Icons in menu bar and standard menus are invisible!
    snazy Level 1 Level 1 (0 points)

    The bug in Mac OS X 10.8.2 occurs irrespective of whether power nap is enabled (or not).

    Additionally I have disabled hibernation by setting the timeout for hibernation in "system settings"/"energy" to never for both power supply and battery modes.

     

    Hello? Anybody at "1 Infinite Loop" reading this thread?? Anyone in Cupertino interested in really bad user experience with current Apple products??

  • 25. Re: Icons in menu bar and standard menus are invisible!
    Barney-15E Level 8 Level 8 (35,295 points)

    Hello? Anybody at "1 Infinite Loop" reading this thread??

    Nope.

  • 26. Re: Icons in menu bar and standard menus are invisible!
    mstg Level 1 Level 1 (0 points)

    I have the same issue here:

    https://discussions.apple.com/message/20417681#20417681

     

    But still not resolved, as it occurres again and again and I cannot boot into safe mode.

    On safe mode booting I see the apple logo and the loading bar and wheel.

    The wheel turns round but the bar hungs at about 30-40% ...

     

    Any ideas would be appreciated.

  • 27. Re: Icons in menu bar and standard menus are invisible!
    Past_Tense Level 1 Level 1 (0 points)

    Booting in Safe Mode, then rebooting into normal mode fixed the issue for me.

  • 28. Re: Icons in menu bar and standard menus are invisible!
    gfingerl Level 1 Level 1 (0 points)

    Booting in Safe Mode did help only temporarily.

     

    So, I also reinstalled the OS, restored my data and did NOT install the graphic update (which was also recommended by Yaggo).

    I had the first occurence of this bug when the graphic update was installed.

  • 29. Re: Icons in menu bar and standard menus are invisible!
    Past_Tense Level 1 Level 1 (0 points)

    Agreed - the Safe Mode fix did not last for me either.

1 2 3 4 Previous Next