Previous 1 2 Next 25 Replies Latest reply: Dec 3, 2012 12:26 AM by hansgnilsson
hansgnilsson Level 1 Level 1 (0 points)

I cannot connect with appstore, get a message that i need an internet connection, though internet is OK

iMac, OS X Mountain Lion (10.8.1)
  • Linc Davis Level 10 Level 10 (177,680 points)

    Has it ever worked?

  • hansgnilsson Level 1 Level 1 (0 points)

    Yes it just stoppad working at some point

  • Linc Davis Level 10 Level 10 (177,680 points)

    Select  System Preferences Network. If the preference pane is locked, click the lock icon in the lower left corner and enter your password to unlock it. Then click the Advanced button and select the Proxies tab. If any proxy options are selected, deselect them. You don’t need to change the bypass or FTP settings. Click OK and then Apply. Test.

  • hansgnilsson Level 1 Level 1 (0 points)

    Sorry, problem is still there.

  • Linc Davis Level 10 Level 10 (177,680 points)

    Is your Internet connection wired or wireless? Can you access the Internet in other applications, such as web browsers?

  • hansgnilsson Level 1 Level 1 (0 points)

    Wireless connection, I can access internet in other applications as well as in other units, where I can also access appstore

  • Linc Davis Level 10 Level 10 (177,680 points)

    Launch the Console application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Console in the icon grid.


    Make sure the title of the Console window is All Messages. If it isn't, select All Messages from the SYSTEM LOG QUERIES menu on the left.


    Click the Clear Display icon in the toolbar. Try the action that you're having trouble with again. Post any messages that appear in the Console window – the text, please, not a screenshot.

    When posting a log extract, be selective. In most cases, a few dozen lines are more than enough.

    Please do not indiscriminately dump thousands of lines from the log into a message.

    Important: Some private information, such as your name, may appear in the log. Edit it out by search-and-replace in a text editor before posting.

  • hansgnilsson Level 1 Level 1 (0 points)

    Message when AppStore was launched:


    2012-11-29 09:41:44,000 kernel[0]: process 395 set trusted

    2012-11-29 09:41:54,000 kernel[0]: revoking trust for process 395

  • Linc Davis Level 10 Level 10 (177,680 points)

    Is it possible for you to connect to your router with an Ethernet cable?

  • hansgnilsson Level 1 Level 1 (0 points)

    Yes, I tried, but no connection to AppStore

  • Linc Davis Level 10 Level 10 (177,680 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether your problem is caused by third-party system modifications that load automatically at startup or login.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:
    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click  Log in.
    *Note: If FileVault is enabled under OS X 10.7 or later, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • HACKINT0SH Level 5 Level 5 (5,755 points)

    I'm curious, were you at least able to connect to the iTunes store?

  • hansgnilsson Level 1 Level 1 (0 points)

    iTunes store is no problrm.

  • hansgnilsson Level 1 Level 1 (0 points)

    Tried safe mode, no connection to appstore still. Other connections working, iTunes store included.

Previous 1 2 Next