Previous 1 6 7 8 9 10 Next 144 Replies Latest reply: Dec 13, 2014 10:34 PM by nishanthrao Go to original post Branched to a new discussion.
  • 473Bellwood Level 1 (0 points)

    No, I spoke too soon... play counts were updated for that song and some others for a little while, but they have now gone back to zero... this is so frustrating.

  • SoCalBob Level 1 (0 points)

    Obviously Apple doesn't care since these problems have been going on for awhile now. I guess they don't think it's important.

  • Colt70 Level 1 (0 points)

    I had that problem for a while, the only way a song add to the count of plays was hiting it directly from the list to play it. If next song was played automatically after, it wasn't add it to the plays. Same thing when I chose to repeat the song automatically, second, third and so on plays weren't add to plays either.

    Not anymore, the problem seems to be solved. I use OSX snow leopard 10.6.8

    But, I still have the problem when I sync my Ipod!!

  • 473Bellwood Level 1 (0 points)

    My problem isn't exactly like that... I've had play counts update both when I've chosen them, and when they've played automatically, it's just that it hasn't always done so.


    A few days ago I couldn't access the iTunes store for most of the day... I thought, "Hmm, maybe they're fixing someting in iTunes, and my problem will be solved.  (I was grasping at straws.)  Then for a couple days afterward, as far as I could tell, my play counts were updating (I didn't keep an exhaustive list of songs that I played, but it was clear that at least some play counts were going up).


    So I thought that I was in the clear until it happened again today... **** it!


    It then occurred to me that the way I shut down could possibly make a difference.  Sometimes I just hit "shut down" and then bludgeon my way through ("Do you want us to force shutdown?" Windows will sometimes ask me, if itunes and/or Firefox are open when I hit shutdown)... perhaps doing it that way can cause a problem.


    And it occurred to me that the "This system is shutting down. Please save all work in progress and log off. Any unsaved changes will be lost." message might not only refer to unsaved Word documents and so on, but maybe could refer to updated iTunes play counts that yes are visible on the screen, but might not be truly saved to the system unless I hit "File - exit" on iTunes before I shut down.


    This is all pure speculation, but a test I just did supports the idea. 


    I played the two songs that hadn't updated a few minutes before, formally exited from itunes (and Firefox), shut down, and when I re-startedf and went back to itunes the playcount was updated.


    Then I chose a third song, played it, and let shuffle take me to a fourth song, and after another proper shutdown (exiting itunes, exiting Firefox, and then shutting down) the play counts for both were updated.


    So that's how I'm always going to shut down from now on... maybe (maybe) this will solve the problem.

  • phopu Level 1 (0 points)

    I have the same problem with short tracks (anything less than 10 seconds), but I resolve it the opposite way. I normally have crossfade off. I had to turn it on (I set it to the minimum 1 second) to get my playcounts updating again.

  • Leonardo Parra Level 1 (0 points)

    Same here, turned crossfade on, set it to 1 second, and it works with some of my short tracks... still no 100% perfect but close enough, please Apple, fix this annoying problem!

  • phopu Level 1 (0 points)

    While listening to a playlist, I ran into another track where the "1 Second Crossfade" trick didn't work. I fiddled around some more and realized it only worked under specific situations.


    Specifically, what I did was go to songs view, make sure all my songs were visible, sorted by time, and finally with the 1 second crossfade enabled I played the song and it updated.


    Yes, this problem is very annoying.

  • ssanders79 Level 1 (0 points)

    This did the trick for me as well.  Created an unplayed smart playlist and sorted by time.  Cleared out all the tracks under 30 seconds.  I also changed my crossfade to 1 second.

  • AtomicVariable Level 1 (0 points)

    Can you please elaborate on play count issues with short tracks? I have finally seen this on some audio only tracks I have listened to a lot - no play count updates. Specifically a 5 second track. It blows right through it then on to the next full length type music track - which updates play count fine without any issues at the end of the track.


    I have crossfade turned off in settings.


    Thanks for the assist to all who pass through this thread.

  • phopu Level 1 (0 points)

    Certainly, basically play counts have not been updating for short tracks (less than 10 seconds) for some of us who have crossfade turned off. To rectify this, this is what some of us have had to resort to:


    1) Turn on Crossfade (set it to the minimum 1 second if you don't want it to interfere too much).

    2) Sort your songs by time.

    3) Play your short tracks. Count should update now.

  • SoCalBob Level 1 (0 points)

    Worked for most songs but not all. Works for most songs even with Crossfade turned off. Problem almost solved.

  • AtomicVariable Level 1 (0 points)

    does it just assume that the song is part of the one before or after it becasue of it's length and adding a minor crossfase makes it able to differentiate it as it's own track?


    One would think that iTunes or iOS should know that it is indeed a separate track regardless of length or break between ddfferent music files.


    So Crossfade is the solution and it is not a universale fix and some songs may still suffer this issue... hmm...


    Any drawbacks to using crossfade? It just fades in the next song as the current one is ending right?

  • phopu Level 1 (0 points)

    I don't use crossfade very much at all and I have it turned off presently. The only reason I turned it on in the first place was to clear some smart playlists I had where these tracks were not removed because their counts weren't updated. I really am not sure what's the cause of the problem.


    This solution is very much a hit or miss proposition as I and SoCalBob already said. I found at least one instance where it didn't work (which is why I mentioned sorting first). I wouldn't be surprised if there were more. I guess the lesson to take away from this is that if you have this problem, try playing with crossfade on. Try playing with crossfade off. Try sorting your playlist in different ways or playing from another listing altogether. If you can, upload the track to an iPod, play from there, and then sync. One method is bound to work, until Apple officially finds a fix for this, that's the best you can hope for.


    In anycase, won't matter very much longer for me hopefully since I am currently trying to migrate my entire library outside of the Apple ecosphere when time permits. Six months of problems like this since iTunes 11 released has really turned me off. If these issues are also a major enough headache for you, I encourage you all to do the same.

  • AtomicVariable Level 1 (0 points)

    What software do you foresee using for management and what devices will you be / are you syncing to? Will you still be reliant on iTunes for apps to iOS devices?

  • phopu Level 1 (0 points)

    That's a great question! But maybe a bit beyond the scope of our current discussion?


    As a courtesy to the TC and other readers, you can instead drop me a message on my own thread:

Previous 1 6 7 8 9 10 Next