Previous 1 2 Next 19 Replies Latest reply: May 17, 2013 8:22 PM by btputnam
danwainwright Level 1 Level 1 (0 points)

i have updated my itunes and now i cant find the select speakers button so i can play through my apple tv. i was actually using it not 3 mins before i updated.

anyone else had trouble?


MacBook Pro, OS X Mountain Lion (10.8.2), itunes 11
  • Dasher Level 1 Level 1 (120 points)

    next to the volume slider

     

     

    Screen Shot 2012-11-30 at 8.12.44 AM.png

     

    also see here;

    http://support.apple.com/kb/HT4437

     

    Dasher

     

    Message was edited by: Dasher

  • danwainwright Level 1 Level 1 (0 points)

    It has now, it took a computer restart and appletv restart to make it work. i dunno what was wrong with it.

    All sorted now.

  • rickerbh Level 1 Level 1 (0 points)

    To get the control to appeal without restarting, I opened the miniplayer, toggled AirPlay on and off by hovering mouse over the miniplayer window, then turning multiple devices on/off, and then it appeared in the main window.

  • PetWolverine Level 1 Level 1 (0 points)

    This trick didn't work for me at first; I had to actually have music playing while toggling the setting, and then it worked.

  • niall.young Level 1 Level 1 (0 points)

    So all of my IOS5 devices can AirPlay fine to my Airport Express and AppleTV, but iTunes11 from the MacBook (ML) won't - despite numerous reboots of both the MacBook and Airport Express, reset to default settings on Airport Express etc.

     

    I haven't updated my AppleTV yet, now I don't want to in case I lose AirPlay on that as we use it every day!

     

    So yeah, something is very broken with iTunes11 AirPlay in certain situations.  I'm running Mountain Lion, all updates etc.  Worked fine immediately before the iTunes11 upgrade.

     

    I guess we wait for an update...

  • samuel.mehr Level 1 Level 1 (0 points)

    I'm having the same problem. My iMac plays songs via AirPlay and an Airport Express fine with the latest version of iTunes... but my Macbook Air does not (same version of itunes, same Airport Express).  Have tried multiple reboots of all devices.  Anybody have a fix?

     

    On both computers, the Airport Express appears in iTunes, but on the laptop it won't allow me to select the device.  I click on it and nothing happens.  When I try to play on multiple speakers, it refuses to be selected!  This worked fine on the last version of iTunes and now it's all messed up...

  • Taco Taco Level 1 Level 1 (0 points)

    I updated iTunes on my windows 7 enterprise 64 bit machine and now I cannot AirPlay to ATV or homeshare library.  I can still ping atv by name and ip from this pc.  Ports on router are open for bonjour.  I see no options to AirPlay in iTunes and none of my devices can see my iTunes library via home sharing when logged in with the same apple I'd.

     

     

    ATV is seen and can be controlled by all iOS devices (2ipads, 2 touchs, and 2 iphones) running the remote app.

     

    None of the iOS devices including atv can see my iTunes library on pc

     

    Everything worked (AirPlay and home sharing) before the iTunes 11 and 11.01 update!

     

    I have done the following:

     

     

    Reset ATv and power cycled pc, router, and atv.

     

    Re configured home sharing on all devices

     

    Deauthorized all computers and reauthoized win 7 iTunes host and reconfigured homesharing

     

    No av is on the pc and firewall is off.  I even tried putting the pc ip in the dmz on router....nothing makes this work!!!

  • TarksWork Level 1 Level 1 (0 points)

    Has anyone received further info on this?

     

    I had my itunes library running home sharing on a pc, connected behind a firewall to an aiport via ethernet. The airport wifi network was being accessed via an ipad using the "remote" application and it worked fine. The airport was then connected to speakers via a Yamaha reciever. Suddenly, with no updates to any software and no changes to my network, the connection between the pc where the itunes library is located and the airport seems to be not working. The odd thing is the ipad sees the airport and it is making changes to itunes while itunes is running on the pc where the library is located. So it almost seems as though the ipad sees the airport which sees the library but the flow doesnt work in  the other direction in order to get the music out of my Yamaha.

     

    I have of course checked the receiver with other sources using the same input and cables and it works. I reinstalled itunes on the pc. I rebooted the aiport and verified it is connected to a network. it just doesnt make sense.

     

    Also the icon that enabled me to control my sound output from itunes on the pc has dissappeared. I've gone to numerous chat boards and looked up various ways to get this to "reappear" and none of them has worked.

  • Zabdi Level 1 Level 1 (0 points)

    worked for me too!!

  • TarksWork Level 1 Level 1 (0 points)

    Yeah, i'm not using ATV just airport and an ipad to control an itunes library sitting on a pc. I've restarted everything, reinstalled everything, rebooted my router, and no luck. Now it seems, actually, to have gotten worse. iTunes freezes up on the pc when i click a song on the ipad to play. I've got to believe this is a software issue and i suspect it may be related to IP address / dhcp but restarting my routers should have fixed that unless something is holding onto an IP. i cant think of anything else it could logically be other than an IP issue or a software issue.

  • TarksWork Level 1 Level 1 (0 points)

    Ok closing out the loop on this in case anyone else has this problem in the future. In my particular case the problem was being caused by software firewall on the pc which was blocking access to the airport from the pc. In my case i removed Symantec completely, reverted to windows firewall and added Avast antivirus and everything is fine now. Took hours to solve this problem and ultimately some time on the phone with Apple Care. hope thsi helps.

  • zennpv Level 1 Level 1 (0 points)

    Ran into missing AirPlay Icon on Itunes 11.01 after I updated my Apple TV. Took me a while to figure this out... but it looks like the Apple TV update turned the AirPlay function to "OFF" within Apple TV settings. Once turned back to "ON", icon reappered on Itunes and working as usual.

  • Moondog Rocks Level 1 Level 1 (0 points)

    Thank you Zen.  After four hours of frustration you solved it for me.  Thank you.

  • rachelpi Level 1 Level 1 (0 points)

    THANK YOU!! Such a simple fix - little did I know my AppleTV had its ears off.  Thanks again.  I tweeted a link to this page so hopefully the similarly afflicted can find it.

Previous 1 2 Next