Previous 1 2 3 4 Next 49 Replies Latest reply: Feb 18, 2015 11:47 PM by atom217
cameronb2 Level 1 Level 1 (0 points)

Since upgrading to iTunes 11 I haven't been able to get the column browser back to how I had it previously.  I want to have a genre column and an artist column, but the column browser options are greyed out for me.

 

Any tips?


Toshiba Tecra A10, Windows 7
  • mjcm_nl Level 2 Level 2 (300 points)

    Is this the case with the colum Browser while working with your Playlists ?

  • cameronb2 Level 1 Level 1 (0 points)

    It's a problem for the Library and for Playlists.  The option is greyed out for both views.

  • mjcm_nl Level 2 Level 2 (300 points)

    With the playlist, the only solution I found for now was :

     

    Export Playlist to a file on Disk

    Remove Playlist from within the Library

    Import Playlist via Alt + F - Library - Import Playlist

  • Marco Polo 73QJ Level 1 Level 1 (15 points)

    Whilst trying to work out exactly what Apple had decided I "didn't need" for my "iTunes experience"(!), I stumbled on this issue. For me, I had the same issue, but by clicking "show side bar", the column browser became live again in Library (but not from playlist). So I clicked on column browser in library, and now it is on for both library and playlist (unlike the much more user friendly iTunes 10.7 - hint!)

  • cameronb2 Level 1 Level 1 (0 points)

    I have my sidebar set to show, but I still don't know how to access the column browser as you describe.  What exactly do you mean when you say 'clicking the column browser'.  Sorry to sound pedantic, but I still have greyed out options, so I'm not sure exactly where you are clicking.

     

    So when you (or others) select the View menu, are you able to then select 'Column Browser' and then select 'Show Column Browser'?

     

    I can select the Column Browser menu option, but all the sub menus are greyed out.

     

    The 'Full Screen' (Ctrl-F) option is also greyed out, not that I care personally.

  • Marco Polo 73QJ Level 1 Level 1 (15 points)

    Thats OK - sorry if I wasn't to clear

    If you have the menu bar showing, and you are in "music" on your library side bar (rather than a playlist), click on view in the menu bar. This then has column browser listed as item 2, with a drop down, with all the items except "show column browser" greyed out.

     

    Clicking on that brought up the column browser in the library window above the listing (as normal). When you then go back to view / column browser, it will now have all the selections in bold, and ticked or not. Hopefully that fixes it - did for me.

     

    (If the column browser does not appear in the windo, go back and do this check as it maybe that the various browser options have not been ticked for some reason)

     

    I thend found that unless I turned the column browser off, it appears in playlist views as well - havent played with that yet to see if its an option or just on or off regardless of the view - too many other bits and pieces that are "not right" in the change fo 11....

  • cameronb2 Level 1 Level 1 (0 points)

    I wasn't able to get the same results as you but I have made some progress.  It still greyed out at the library level, but I did the following to get it active for the playlists

     

    HIDE sidebar - Then the show column browser menu becomes active for playlists only.  I can't access my library from that alternate sidebar that shows up after selecting hide side bar.  Although the All Music playlist might be similar.

     

    The other problem is that the column browser columns are on the top which is pretty silly with today's wide screens and the fact that the data in the columns is not very wide so it doesn't use the space efficiently. Maybe there is an option to shift it somewhere.

     

    So I still can't activate the column browser for my Library, but you've helped me make some progress, so thanks for your help.

  • jtmls Level 1 Level 1 (5 points)

    Had same original problem and the same problem with the suggested solutions.  In addition to showing sidebar, you need to go to the center of the screen just under the Apple symbol at the top and select Songs in order to activate the column browser.

     

    Buena suerte!

  • cameronb2 Level 1 Level 1 (0 points)

    Thanks jtmls!  That was the missing piece explaining why I couldn't get the column browser to work for my Library.  I needed to select 'Songs' at the top.

     

    Now I just need to move it to the left side of the screen and I'm happy (for now)!!

     

    So much for Apple's intuitive products!

  • Logandregs Level 1 Level 1 (0 points)

    jtmls You are an absolute star!

     

    the programme itself is still very far from being as good as i had before but i think this is as close as i'll get.

     

    APPLE Y U DO THIS TO ME!?

  • DABbio Level 1 Level 1 (0 points)

    Let me be among the (not?) first to shout it: WHAT'S GONE WRONG AT APPLE?!

  • cameronb2 Level 1 Level 1 (0 points)

    Thanks for your help everyone, but I decided to downgrad which was actually pretty painless in the end.  Clear instructions on YouTube if you haven't done this before. But to put simply

    - Uninstall 11

    - Reinstate 10.7 library (.itl file) from 'previous itunes libraries' folder

    - Download and install 10.7.  I already had a copy from when I first installed, but plenty of download sites have it

    - And Bob's your Uncle!

     

    http://www.youtube.com/watch?v=be09gGFw-Y4

     

    Call me old fashioned, but it's nice to be back to the old (which feels like new!) and I notice makes better use of the screen real estate.  Odd given that screen resolutions are increasing.

     

    What a way to waste my time Apple!

  • thomaselsted Level 1 Level 1 (0 points)

    It's confusing, but the solution is actualy very, very simple and took me 2 minutes:

     

    If you chose any one of the new tabs Albums, Artists, Genres, or Playlists – then the column browser is not available and therefore greyed out.

     

    If you choose the Song tab, then you can turn on the column browser (View > Column Browser or ⌘B) as well as the sidebar (View > Show Sidebar or  ⌥⌘S), and the layout is almost identical to the previous iTunes.

     

    The reason is that while the new layout seems like a downgrade in functionality, in fact the tabs are additions to Songs – which was actually the way the previous iTunes was structures with the column browser. We were always looking at songs, with the column browser and sidebar to navigate genres, albums and artists.

     

    No reason to downgrade or reinstall or panic!

     

    Best,

    Thomas

  • DABbio Level 1 Level 1 (0 points)

    OK, I'm not ashamed to back down from my initial shock and awe about the new iTunes. I also discovered the simple fix for column browsing that thomaselsted eloquently describes, and I'm willing to give the benefit of the doubt on the rest, as it has often proved to be true that climbing up the learning curve on a new piece of software or hardware can be rewarding.

     

    However, Apple please note:

     

    1. To column browse albums, etc. requires extra steps/clicks, because you have to get out of album view, for instance, go to songs view, turn on columns view, and take it from there. Not good.
    2. When playing radio stations. the mini viewer does not show the current song.
    3. Getting in and out of mini viewer is now also a multi-step process.

     

    Those sorts of things need to be fixed, because adding features should subtract needed user involvement, not add to it!

     

    Reserving my final judgement, which I am sure puts Apple into a stark terror mode.

Previous 1 2 3 4 Next