Previous 1 2 Next 16 Replies Latest reply: Mar 22, 2013 10:38 AM by russ Andris1
Voltaic Level 1 Level 1 (0 points)

I'm hoping some folks can help me here as I'm stumped.

 

I shot around 60 minutes of last evening with my Canon 7D.  File sizes ranged from 500MB to 4GB.  I imported from my 8GB memory card a 3.6 GB file and a 500MB file with no issue.  I then moved on to my 16GB memory card, which was full with around 7 clips, and started importing.  I noticed the import was going slow but I was also importing some audio from SD cards on the same card reader, which I've always done in the past, and figured it was just a USB 2.0 bandwidth thing.

 

I then got an error regarding the Import Failing (see attachment) but the file appeared to have imported without issue.  Upon further inspection during the import however, I noticed any file larger than 1GB was showing as the PAL codec (after it imports it correctly shows H.264 but more on that later).  I checked the 3.6GB file from my first import and it did not share this issue. While on the shoot I had backed up a number of these files to my iPad so I attempted to import them from there and althought he PAL codec was not listed, I did get the Import Failed error.  I also tried a brand new card reader and a different Event/Destination the issue remained.

 

Screen Shot 2012-12-01 at 9.18.09 AM.png

I've restarted, repaired permissions, and the issue remains.  I have never encountered this error and imported a similar amount of footage and clip sizes two weeks ago.  I'm stumped, has anyone else seen this? 


Mac mini, OS X Mountain Lion (10.8.1), RAID 0 2 x 240GB SSD 16GB Mem
  • TheDoctorOfTheApple Level 1 Level 1 (20 points)

    Try importing directly from the camera itself, via USB, with the card in the camera. I have had a good deal of trouble with card readers.

  • digibudII Level 2 Level 2 (415 points)

    another thing to try is to copy the entire folder from the card into the computer and then try importing.

  • TheDoctorOfTheApple Level 1 Level 1 (20 points)

    Yeah. That would be worth a try too.

  • Russ H Level 6 Level 6 (18,210 points)

    Your error image isn't displaying.

     

    I would suspect the 16 GB card. Are you able to open any of the images from that card?

     

    Russ

  • Voltaic Level 1 Level 1 (0 points)

    I'll try going straight from the camera and report back.  I did already try another memory card and also a different memory card reader.

  • mattymattyonga Level 1 Level 1 (0 points)

    I had the exact same trouble, smaller files would import fine from the sd card or from an archive on my computer but the large ones would encounter an error. Importing via usb to the camera works fine though.

     

    Thanks.

  • Voltaic Level 1 Level 1 (0 points)

    I'm still experiencing this issue even with 10.0.7.  I even got a new Compact Flash card.  I guess I could try reading directly from the camera but I'm concerned with my camera running out of battery life and corrupting footage during the transfer.

     

    I submitted a bug report, whether that makes a difference, but would encourage others to do the same.  I know this worked with prior versions of FCPX.  It seems it started around 10.0.6.

     

    Have tried three different card readers, makes no difference.

  • pixnvid Level 1 Level 1 (75 points)

    I have to disagree with importing directly from the camera. It works but it's slow. What I do - and I shoot with 5D II and III, 60D and 7D almost daily - is copy the .mov files using a card reader to a folder on my desktop or external drive and import the h264 files into X from that folder. That way I have an archive of the material. Never had a single problem doing it this way.

    I supect a lot of the problems with the 5D II and 7D come from the .thm files that are generated by the camera. FCPX doesn't like them, won't import them and, in fact, I delete them. Not sure what use they were but they are of no use in FCPX now. The 60D and 5D III don't generate them.

  • Voltaic Level 1 Level 1 (0 points)

    I hear what you're saying but the weird thing is this problem never existed prior to some of the most recent updates.  I guess I'll have to import to the desktop as you've suggested and then move everything into FCPX, just seems counter intuitive to how it should work.

  • mponzi Level 1 Level 1 (0 points)

    I experienced this problem today.  I had 7 clips shot with a 7D.  2 of them were over 1GB the others around 400Mb.  The 2 largest files had this error.

     

    I launched my CF card with a  USB reader.  First I tried to import directly from the card. Second, I tried to create a Camera Archive then import from that.  W/ my AVCHD cameras, I always make a Camera Archive first.

     

    In both cases the larger files gave me the error message.  However, all the clips seem to be in working order, and FCPX created proxy media.

     

    Tomorrow I'll ty copying the .MOV files to hard drive and go from there.  I'll also delete the .THM files and see if that helps.

  • Richard Seldomridge Level 3 Level 3 (655 points)

    I've seen this too (with multiple different DSLRs, different memory cards, card readers, etc...)

     

    Here's how to get around it (until they fix the bug):

     

    - Copy the .mov files to your hard drive via the finder, put them in a new directory that isn't the DCIM one like on the card, if you don't do this then Final Cut thinks they are still on the card when you import them and this won't work.

     

    - Import them into Final Cut but do NOT select the option to copy files into the event folder (if this option is not available it's because Final Cut thinks they are still on the card).

     

    - Then once they are imported, select the event in Final Cut and choose File/Organize Event Files to copy the files in to the event folder, then you can delete the originals.

     

    I haven't had an error using this method, and the import goes much faster anyway.

  • mponzi Level 1 Level 1 (0 points)

    Richard -

     

    Thank you for sharing this.  I will try it tomorrow.

     

    I really appreciate when people, like you, figure these things out and share w/ the rest of us.  On the other hand,  I'm thoroughly unimpressed with the way Apple is handling it's pro apps, specifically Final Cut and Logic.

     

    It's getting awfully hard to spend time finding the workarounds for Apple's continual oversights on features that should "just work."  If  this workaround works,  I'm going to seriously consider switching to Adobe. Steps like these should NOT be necessary.

     

    Again, Richard, thank you!  Apple should realize that efforts like your's should not be necessary.

     

    Marshall Ponzi - Owner of $50,000+ of Apple products!

  • Voltaic Level 1 Level 1 (0 points)

    The other fix I found is importing directly from the camera via USB. The transfers are fast and actually don't result in the error message. Make sure you have a fresh battery though, don't want a transfer corrupted when it shuts off mid way.

  • mponzi Level 1 Level 1 (0 points)

    I did some experiments this morning, and Richard's method worked. Thank you!

     

    However, I didn't follow Richard's steps 2 & 3.  When importing, I let FCP copy the files to the FC Events folder. It still worked.  In step 1, I did not copy the .THM files to the new folder on my HD.

     

    I did a second experiment that did not work:

    1) Copy .mov files (only) from CF card to new folder on HD.---no .THM files

    2) "Create Camera Archive" with FCP - Store new archive in its own folder on my HD

    3) Tried importing from the new Camera Archive -  This crashed just like before.

     

    This tells me FCP is OK with importing individual media files to a FC Event.  It seems to crash when it thinks there's a camera involved.

     

    Later today I'll try to import some AVCHD files and see if it crashes on import.  For AVCHD footage, you need to rely on FCP's "Import from device" capability.  Those files need to be transcoded to be usable at all.

     

    More later.

     

    Marshall

Previous 1 2 Next