Previous 1 2 3 Next 36 Replies Latest reply: Sep 26, 2014 12:44 PM by omenseeker Branched to a new discussion.
GogoGadget69 Level 1 Level 1 (0 points)

For some reason, I cannot import any movies in iTunes 11. I've read other threads where it says imported movies go to the "Home Movies" section but nothing shows up there. When I look in my iTunes music directory on my hard drive, there is a "Home Movies" sub directory and my imported movies have been copied there but they have not been incorporated into the iTunes library and do not show up anywhere. Help!!! I want to watch some movies on my Apple TV. Previous version of iTunes worked perfect, why is it screwing up now?


iMac, Mac OS X (10.5.6)
  • GogoGadget69 Level 1 Level 1 (0 points)

    It must take a while because 15 minutes later, everything showed up in the library. Strange but happy now.

  • Michemouche Level 1 Level 1 (0 points)

    I have exactly the same problem now, what is in your opinion this story related to? ... and why do you think we need now to wait 15mn to ensure it works (What is this home movie folder, don't understand). Usually any movie I owned could be moved / dragged directly into iTune and it would appear immediately. Is it a bug or a feature?

  • GogoGadget69 Level 1 Level 1 (0 points)

    On your hard drive you have an iTunes "Music" folder. Inside that folder is your music as well as the sub folders "Movies" and "TV Shows". iTunes 11 has created a new folder called "Home Movies" where it copies any imported movies to. After messing around with it for a while and not really paying attention to what I was doing, my movies suddenly showed up. So maybe I did something or maybe it just needed to process the files into the library. Sorry I can't be much help beyond that but it is working for me now.

  • FarNorth_64N147W Level 1 Level 1 (0 points)

    It took much longer than 15 minutes, but the same thing happend with my imported videos, they just showed up.

  • jakecasino Level 1 Level 1 (0 points)

    I waited like a whole day and it still isn't showning up

  • Lachmand Level 1 Level 1 (0 points)

    Try this. Start up Itunes. Click on Home Movies Videos in the movies section. If you have a movie her, right button click and select "Get Info". On the options tab, change the media kind to movie and select OK. Your other movies will slowly start to appear!

  • jefferyfromwichita Level 1 Level 1 (5 points)

    I have the exact same problem. Exactly. You described it perfectly.

     

    One bug I found which can cause this is extra "dots" in the file name. I had trouble importing a file named "show.S01.E02.mp4". If I rename the file "showS01E02.mp4" it imports fine.

     

    Computers are weird. I know better than download software called 11.0. When will I learn to wait for 11.01? I guess I like punnishment.

  • SpideyPhiEpsilon Level 1 Level 1 (0 points)

    Hi Lachmand-  Your solution was perfect.  Worked brilliantly for me.  Thanks so much!

  • chriscurnow Level 1 Level 1 (0 points)

    I had this problem too but I think I have found the source of the problem.

     

    After I imported some movies I noticed the iCloud icon (next to the Library selection popup) was showing continous activity. This made me suspect the problem was something to do with iCloud syncing.

     

    I went to iTunes Preferences -> Store and unchecked Sync Playback information across devices and my recently imported movies immediately showed up in the list.

  • GogoGadget69 Level 1 Level 1 (0 points)

    I think I have this figured out now. After you import a movie or video to iTunes, go to the music library and select the "Recently Added" smart playlist. It will show your video there. Right click on it and click "Get Info". Go to the options tab and change media kind to "Movie" or "TV show" depending on what it is. You can also add show information, year, artwork etc from here. Your movie should show up in the proper location now. I think it's stupid that the only place that consistently shows your newly imported videos is in the music "Recently Added" playlist but there you go.

  • HemiDave Level 1 Level 1 (0 points)

    I do not like having them seperate like this.  I wish they kept movies as all movies vs seperating it out like this!  If you change to list view in 11 as well you will all the movies regardless of the category they are assigned to.  I like the overall look and feel of the new iTunes but do not like this option.  IMO "Movies" should show all and if you want to drill out different "categories" that option is still there. 

     

    Anyways, thanks for the tip all...I had one movie imported like seven times until I was able to locate it LOL.  I am surprised that I was never asked if I wanted to replace the existing file.

  • timcpi Level 1 Level 1 (0 points)

    Great idea about the "Recently Added" Smart PlayList, but my version of 11.0.1 iTunes doesn't have such a Smart PlayList.

    I have waited the now-famous "15 Minutes," but nothing has shown up. No error message in iTunes to let you know what is happening is, in my opinion, a clear violation of the Apple GUI.

    It discourages me mightily that Apple's standards are slipping so badly.

  • Steve Taylor1 Level 5 Level 5 (4,660 points)

    Make a recently added playlist by creating a new smart playlist and setting the criteria

     

    Date Added in the last 1 days

  • Steve Taylor1 Level 5 Level 5 (4,660 points)

    I use the interim step of using Subler to tag all my movies correctly. Click Save and then Send to itunes. Because the tags are expicitly set then movies or TV Shows always show up in the right place.

Previous 1 2 3 Next