Previous 1 2 3 Next 33 Replies Latest reply: Jan 2, 2016 11:48 PM by Jim B..... Branched to a new discussion.
daniel efrommn Level 1 (0 points)

how do I turn off optical digital-out port?

MacBook Pro, Mac OS X (10.7.5)
  • Tuffy Nicolas Level 2 (170 points)

    Just want to report that I too, running 10.6.5 on a MacBook Pro, had the mysterious " Audio Out Stuck On Optical Digital-Out Port" problem whereby I was unable to adjust the volume on my built-in speakers and they were permanently "muted" because the operating system was sending the audio signal to a non-existent device that it falsely thought was plugged in to my unused headphone jack hole. I thought at first the problem must necessarily be software-based because the built-in speakers worked fine when playing the start-up chimes. So I uninstalled something called "Soundflower" which does some mysterious shenanigans with commandeering the internal audio signal so that one can make audio recordings of one's computers' sound effects. But uninstalling Soundflower had no effect. So I uninstalled some other audio-related software, also to no avail. Then I zapped the PRAM, to no avail.


    Then I decided to try what some people call "the toothpick trick," i.e. poking around in the headphone jack hole to see if something was stuck in there shortcircuiting it, and initiating the false signal to the OS.


    Bingo! Success!


    Actually, I did a hyper-sophisticated version of the toothpick trick:


    First, I own a home "otoscope," one of those doohickeys that doctors use to look into your ear. One can now buy amateur versions of otoscopes for home use, to looks for kids' ear infections, etc. (They only cost $30 or so.) Anyway, using the smallest attachment designed for babies' ears, I was able to look (with illumination) into the headphone jack hole and yessiree there was a big bunch of dust stuck way deep in there.


    So then I took not a toothpick but instead a slender dental prong-pick thingie made of stainless steel, and very delicately was able to snag the clot of dust deep in the hole at the bottom on the first try. Quite a wad!


    Then I took one of those rubber ear-bulbs, used for cleaning out your ears, and used it as a micro-vacuum-cleaner: Squeeze the rubber bulb til it is as empty as can be, then place the tip of the bulb at the entrance to the headphone jack hole, then suddenly release my grip: it ***** air out of the tiniest spaces! After doing this a few times, I then did the reverse and blew blasts of air into the hole.


    After all this, I looked back into the hole with the otoscope, and it was sparkling clean! Not even the tiniest speck of dust in an area that just three minutes earlier was thick with dust.


    I then turned my computer back on and...problem solved! The audio worked again like normal, and it was no longer detecting an imaginary "Optical Digital-Out Port" device. The internal speakers once again worked as normal, and the volume could be adjusted.


    I guess the problem for me really was dust causing a short-circuit. It might very well be the same for you -- so try cleaning out the headphone jack hole as I did.


    I'm writing this detailed description to help anyone else in the future with a similar problem.

  • Justin1909 Level 1 (0 points)

    I just blew into the jack after reading Tuffy's post; it worked!!

  • youngpeezy Level 1 (0 points)

    Blowing into my headphone jack always works for a while, but is pretty awkward.  I will try this more involved method, though I am wondering if there is a better solution.  Although this is a hardware issue, is there something I could type into terminal that would disable digital optical out regardless of the position of the microswitch?  Or is the behavior of this peripheral restricted to the logic board and can't be fixed without dropping bills at the apple store?

  • Bernd Kaskas Level 1 (10 points)

    I recently used a optical digital out cable for the first time since buying my MacBook Pro in 2009. It seems that the optical device gets mechanically switched on by putting the plug in. When I removed it, the red optical signal was still switched on as evidenced by the red light visible near the socket. Hence the internal speakers remained muted. Then I but a head-speaker cable and the fact that a head speaker was connected was recognised by the computer. Removing the head speaker however made the setting revert to optical digital out. However repeating this a few times, seems to clear the mechanism and allow the computer to recognise when no such optical digital device was connected. I guess there is a small switch which gets stuck with dust building up?


    Thanks for posting your experiences - maybe there is somebody out there who really knows how this socket works? I have not found any explanation in the instruction booklet.

  • Alex Murillo Level 1 (0 points)

    It works!


    Thanks a lot Tuffy Nicolas. I had to read quite a few threads before encountering one as useful as this one. I just did what justin1909 did. Only that after that, I had to get the headphone jack in and out a few times to "unswitch" that switch.


    I was really starting to worry. Thanks for taking the time for posting this.


    Good day!

  • sorbino Level 1 (0 points)

    Blowing in the headphone jack port and plugging/unplugging headphones worked for me too. Thanks!

  • zenomax Level 1 (0 points)

    Inserting & removing the headphone plug fixes it for me.


    I'm curious, though. This problem began the day after I upgraded from 10.6.8 to 10.9.2. I had never experienced it previously. This thread makes it sound like this problem is only a hardware one, mainly having to do with dust inside the headphone jack. So is it just a really weird coincidence that the problem arose for me exactly after I installed the new OS? Or is there possibly something about the Mavericks OS that causes it to be more sensitive to dust in the headphone jack than earlier versions of OS X?

  • Monroe_IV Level 1 (0 points)

    I've been having the same problem for a while, having to plug my headphones in and out a billion times until it finally switched. It seems a lot of people have this problem, but this is the first time I came across the blow method which worked. Easy and simple. It never occured to me that the port might be filled with dust, dirt, etc.. Cleaned the port with a modified paperclip, now working !!!!

  • Ethan E Level 1 (0 points)

    I'm having this problem with a brand new macbook. No dust at all. I work in a performance discipline and it caused problems during rehearsal. Can anyone refer me to the "I want my money back or an immediate house-call repair service" thread?

  • Cindy May Level 1 (0 points)

    Same problem here with my 27'inch Medio 2011 Intel i5 OSX 10.9.2 (13C64) i huffed and i puffed ...and i blowed the hole down...5minut  google search 2 strong breaths ..problem fixed



  • arhimapirate Level 1 (0 points)

    This is the only thing I have found to work but it works EVERY time.


    1) Open Computer

    2) Go to AUDIO MIDI Setup

    3) At the very bottom left corner hit the "+" sign.

    4) "create multi-output device"

    5) In the settings for that device "check" the box "built-in output"

    6) Hold down the "option" key and click the speaker icon at the top in the home bar of your computer and make sure to select "multi-output device".


    Now you should get sound back from your computer speakers. But you still might have the grey icon up top and not be able to control the volume. So:


    7) Hold down the "option" key and click the speaker icon at the top of your computer screen (on the home bar up top)

    8) select "internal speakers"


    Now every time you use headphones and then unplug them you will likely have to repeat #6-8.

  • enkibello Level 1 (0 points)

    OOOHHH MYY GODD!!! Tuffy Nicolas!!! Thank you so much!!!! It did work!!!! You saved my life!!! Thank you so much!!!!!!!!



  • bobmy2 Level 1 (0 points)

    FINALLY!  Nothing worked for this including a toothpick until I understood from posts that dust could be the problem.

    Then I fixed it first try,  once I:

    1. broke off the end of Round toothpick

    2. rubbed the end on the table to get ti smooth and remove burrs

    3. finally got the idea to moisten the end of toothpick

    4. gently pushed moistened toothpick in hole and rotated it


    Toothpick came out dirty looking and the red light was gone. Now the 2007 macbook cycles from internal speaker to headphone every time I plug or unplug the jack. judging from the dust removed by the toothpick, that was the problem. It looks like dust accumulates in this opening over time. Toothpick was only moistened enough to allow it to pick up dust. If you are trying the paper Q-tip stem with no success a little moisture might help do the same thing.

  • dondavanzo Level 1 (0 points)

    Hello everyone


    The resolution I used on my own Macbook 2008 can be found here. Apple will not let me post the resolution here on the their forum.


    Proceed at your own risk


Previous 1 2 3 Next