Previous 1 2 3 4 5 Next 92 Replies Latest reply: Jan 11, 2016 6:36 AM by Loner T Go to original post Branched to a new discussion.
  • Grant Bennet-Alder Level 9 (56,701 points)

    the challenge is providing a BIOS equivalent to the bootable CD/DVD which allows access to hardware.

    The solution OWC and others provides is to dismiss the GUI and get a Terminal window, then enter:


    sudo  <firmware_updater_application>


    running as essentially Root, although a little risky if you screw up,  gives you the needed Hardware access.

  • LAFANGA Level 1 (105 points)

    Jeremy Rojas wrote:


    has anyone tried using the Mac ISO posted here?


    yes i attempted it for many hours but could get no success.


    Could you get the iso image to mount??

  • Loner T Level 6 (17,997 points)

    The ISO contains btdisk.img, isolinux.cfg, isolinux.bin, memdisk.




    btdsk.img          isolinux.bin          isolinux.cfg          memdisk


    isolinux.cfg  contains


    prompt 0

    default BootCD

    #ontimeout hd

    #display BOOTMSG.TXT

    #timeout 100



    # FreeDOS OEM bootdisk, 360KB zip compressed

    label BootCD

        kernel memdisk

        append initrd=BTDSK.IMG



    # overloading is a nice thing. Specify FreeDOS, and if another one is present

    # it gets loaded instead for my own cdrom.

    label hd

            localboot 0x80

    label floppy

            localboot 0x00

    # cancel and try next boot device

    label q

            localboot -1



    file btdsk.img

    btdsk.img: x86 boot sector, FREE-DOS Beta 0.9 Bootloader KERNEL.SYS, code offset 0x3c, OEM-ID "FreeDOS ", sectors/cluster 2, root entries 240, sectors 5760 (volumes <=32 MB) , sectors/FAT 9, serial number 0xc04d1342, label: "           ", FAT (12 bit)


    The problem is that btdisk.img kernel is the FreeDOS kernel which has no CMS-BIOS to support that KERNEL.SYS file hence no firmware update.


    Testing gives and error that Samsung support engineers say is expected. It will either give 'NO EDD-BIOS' or KERNEL.SYS not found.


    The OWC BIOS contains a modified version of DOS which is different.

  • gen_ Level 2 (340 points)

    It's a solution to a different piece of hardware entirely and differs due to the fact that the installer he refers to is bootstrapped toa  *NIX environment and Samsung's is based on a DOS one.

  • Grant Bennet-Alder Level 9 (56,701 points)

    Thanks for the clarification. I had missed the concept that Samsung demanded DOS.

  • Jeremy Rojas Level 1 (10 points)

    Yes I was successful using this method. I burned the ISO to a CD using Disk Utility, rebooted my Mac and went through the steps. Took less than 10 minutes to do everything.

  • David White1 Level 1 (5 points)



    How exactly did you burn the bootable ISO?  I tried several ways yesterday (Toast and Disk Utility) and was not successful.


    The image you download Samsung......DXM04B0Q_Mac.iso has an image file called BTDSK.IMG on it.


    Did you burn the Samsung....iso image or the BTDSK one?  I have tried both.  With the Samsung image it was not visible to boot from at startup.  With the BTDSK one it was available to boot but did not have the software.


    Thanks for any guidance.




  • Jeremy Rojas Level 1 (10 points)

    Hi Dave,


    it was fairly straightforward. Let me start with what I used:


    Samsung 840 (not the Pro) 500GB SSD

    iMac 24" Early 2008 running 10.8.3 (at the time)

    700MB CD-R media


    I downloaded the file called: Samsung_SSD_840_DXT07B0Q_Mac.iso (no need to mount it)


    dragged it into the left-most pane in the disk utility app, made sure it was highlighted and then clicked on burn.


    During reboot, I simply held down the option key and the CD-R showed up as a bootable option. It boots into DOS and I really just followed these instructions verbatim:



    good luck!


  • David White1 Level 1 (5 points)



    Thanks for the detailed instructions.  It is similar to what I tried but I will have another go when I get home tonight and will let you know how I get on.  Let's hope the file I need for the PRO behaves the same way.


    Did you do the update before you put anything on the SSD?  Do you know if it affects the disc content?



  • Grant Bennet-Alder Level 9 (56,701 points)

    Do you know if it affects the disc content?

    You should assume it will erase the SSD contents. Then if it does not, Merry Christmas!


    The reverse assumption is truly horrible. Don't go there.

  • Jeremy Rojas Level 1 (10 points)

    No I just made sure I had a current time machine backup. The drive content isn't touched but as Grant mentioned, plan for the worst!

  • David White1 Level 1 (5 points)

    Well sadly I have not been able to make a bootable CD or get a CD to boot windows.  I used Disk utility to create it (although I could not drag the file to the left hand pane, I had to select it in Burn) and when I rebooted with the option key held down, then the CD was available as an option.  However, when I selected it then the computer just hung.  I thought that it might be that the file I have is not working as you had a different one.  Thus I also tried the Samsung_SSD_840_DXT07B0Q_Mac.iso file to remove a variable but this was not bootable either.


    I'm running a MacPro 2008 (3.1)


    The only good thing is that looking at the SSD the firmware it shows is DXM05B0Q vs the DXM04B0Q updater so it looks as if I have a newer firmware anyway.


    It is very frustrating though and shows that perhaps Samsung is not very supportive of Apple applications!


    Thanks for your suggestions.

  • AntoineFrench Level 1 (0 points)

    David, I'm in the same case. Have you succeeded in making the boot CD working ?

    Would appreciate if you could share your experience.



  • Ilyasilyas Level 1 (0 points)

    can you please conferm that it worked back to normal?

  • Loner T Level 6 (17,997 points)

    I am not sure I understand your question.


    I did not have any luck updating firmware via the Samsung method and ended up using Bootcamp.

Previous 1 2 3 4 5 Next