Previous 1 2 3 Next 35 Replies Latest reply: May 21, 2014 8:47 PM by Zaimejs
pahlberg Level 1 Level 1 (0 points)

 


AppleTV 2
  • Rudegar Level 7 Level 7 (23,035 points)

    more info is likely needed

  • tewfiks Level 1 Level 1 (0 points)

    I just updated the software on out apple tv and now I am unable to log in to netflix. I have tried a hard rest and still unable to sign in.  All of our other devices, iPads, MacBooks, are still working.

     

    Ideas?

  • Catwmn1227 Level 1 Level 1 (0 points)

    Having same problem now, any fix?

  • tewfiks Level 1 Level 1 (0 points)

    Nope, still unable to use the Apple TV to stream Netflix.  Extremely frustrated.  I have given up on it and use the iPads and MacBooks to watch Netflix.

  • Dav1co Level 1 Level 1 (0 points)

    I fix my problem introducing again my Ostore account in the setings and netflix and holu works agaim

  • Dav1co Level 1 Level 1 (0 points)

    Istore. ....  Again. Sorry the spelling,,  it really works

  • kfkolonel Level 1 Level 1 (135 points)

    I have been an Apple fan for years and own just about everything apple. But this is ridiculous. Apple has to fix this. Netflix worked dependably using my WII but I spent $100 because I thought Apple would do it better. Nope.

  • bclgrh Level 1 Level 1 (0 points)

    I have two apple TVs netflix works on one but doesn't work in the other even though they are linked to my same account. Have others ha this issue?

     

    Might cancel the subscription if netflix and apple can't sort this out.

  • tewfiks Level 1 Level 1 (0 points)

    We had the same issue on our Apple TV.  We could not use netflix for about 2 months, then we decided to update the software about two weeks ago and magically the Apple TV could once again stream Netflix without issue. 

     

    So I guess I would recommend that you update the software on both of your APT units and try again.

     

    Extremely frustrating that Apple can not solve this issue in a more timely manner.

  • bclgrh Level 1 Level 1 (0 points)

    Thanks for the suggestion.

    They are both up to date already and tried signing out and back in again.

    One of them plays Netflix but the other one says I need to sign in and when I do it doesn't recognise the account.

    I'm thinking when subscribing to Netflix through apple TV that it doesn't recognise my iTunes account as a sign in for Netflix.

     

    It's an issue that apple need to fix.

    It only started playing up in Jan.

  • kfkolonel Level 1 Level 1 (135 points)

    I have the problem occasionally--about every 4th time I watch Netflix. The "solution" is to unplug your TV and your ATV. After a few seconds plug in the TV. Then plug in the ATV. It will boot up again, and every time I have had to do it, it worked.  FIX THIS Apple. 

  • 1004nancy Level 1 Level 1 (0 points)

    Okay, well I'm a little worried that the last post on here was February.  I haven't been able to get Netflix to work on my Apple TV for about a week now and the fact that no one recently posted same issue either makes me think ppl are just accepting and moving on or I am having delayed issues that everyone else has resolved already.  I have had my ATV for 2 years now and have never had problems with connecting with Netflix for such a long period of time;  usually it only lasts for about 5-10min and I try again successfully.  I have tried everything from checking for update to unplugging TV and ATV(in various orders and length off times) to no avail.  I am not even getting a error code, it just claims "Netflix is currently unavailable.  Try again later."  Since I can access Netflix through EVERY OTHER DEVICE in my home, including Wii, I'm guessing this is an Apple issue.  Please, Please, PLEASE fix this problem!!!

  • Suzanne3530 Level 1 Level 1 (0 points)

    Signing out and back in didn't work and my software was current. This worked, though: settings, general, restart. Voila, Netflix back up and running smoothly.

  • BlackestCloud Level 1 Level 1 (0 points)

    Restart ATV from Settings...General...Restart. After that my Netflix account has worked perfectly. Thanks Suzanne3530

Previous 1 2 3 Next