Previous 1 2 Next 21 Replies Latest reply: Nov 4, 2013 6:26 AM by NatCosta
scorps Level 1 (0 points)

Ever since I purchased my iphone 5 from Vodafone I have not been able to send normal mms messages...imessages worked fine but only to other iphone users. After countless long calls to Vodafone Customer service, several visits to their stores, a replacement iphone 5 and a replacement sim, I could still not send normal mms messages...grrrrr.

Worst of all I was told by Vodafone that this was an 'unusual' problem...despite me telling them that numerous forums were inundated with iphone users having this problem.

So...after 3 hours going through all of the configurations with my techie at work I've finally cracked it!...this fix also worked for my son's iphone 5 and also my neighbour's iphone 5.  None of us were previously able to send mms messages with images.

The problem was not caused by a faulty sim, nor a faulty iphone...nor was it a vodafone network issue. The problem was a corrupted password and file tag which had been pre-set by vodafone.

 

Depending on which software you have on your iphone this is what you need to do:

IOS 6.0.1:

settings -> general -> mobile data -> mobile data network

 

mobile data

apn - wap.vodafone.co.uk

username - ***

password - ***

 

MMS

apn - wap.vodafone.co.uk

username - ***

password - ***

MMSC - http://mms.vodafone.co.uk/servlets/mms

MMS Proxy - 212.183.137.012:8799

MMS max message size - 307200

MMS UA Prof URL

Reset Settings

 

Firstly, tap "Reset Settings"

 

Secondly, delete the 2 sets of 3 asterisks against username under mobile data and replace in both cases with the password 'wap'

Thirdly,  delete the 2 sets of 3 asterisks against username under MMS and replace in both cases with the password 'wap'

Finally, delete the figure of 307200 against MMS max message size (This will reset to 307200 but its important to delete it first)

 

Then with imessages turned off so that your iphone defaults to MMS, send a text message with an image attached (make sure it is not too large). Voila!.....all 3 phones that we have reset in this way can now successfully send MMS messages with images.

 

Don't forget to turn back on imessages after you have finished your test.

 

For 6.0.2 the procedure is the same except that initially you select general then Cellular then cellular data network

 

I'd be very interested to know how many people this fix works for.

  • neil95 Level 3 (610 points)

    Congratulations? Glad you found a fix for your problem. I've personally never had such an issue.

  • abbi1664 Level 1 (0 points)

    I cannot thank you enough -

     

    I have had my iphone5 for approx 8 weeks and since then Vodafone have not been able to help with MMS, despite trying several things to fix it. Hugely frustrating, however in dispair, I tried your solution and tah dah it works perfectly !!

     

    A very happy new year to you and thank you so much for resolving my problem - anyone else having this problem, this is well worth trying !

  • Agnes38 Level 1 (0 points)

    I am with O2, would this also work for me?

  • steveandyhen Level 1 (0 points)

    Fantastic, it worked and now i can send mms picture messages. Thank you so much      P.S.   im with Vodaphone

  • M_xk8 Level 1 (0 points)

    Hi, Thanks very much, I have phoned Vodafone a number of times and they don't have a clue, this was the only solution that cured my fault.

     

    Vodafone need to release a new set of settings and accept that they have a fault........

     

    Thanks again

  • Beefy35 Level 1 (0 points)

    Thanks this sorted my phone out which is more that i can say for Vodafone support

  • Leaskc Level 1 (0 points)

    Fantastic, thank you scorps. Been unable to send MMS for weeks but all sorted now.

     

    Agree with Beefy35 ref vodafone support

  • polymathematic Level 1 (0 points)

    Thank you so very much.... I tried sending an MMS, a couple of days ago, with my iPhone 5 (on Vodafone): and it wouldn't send.... Followed your instructions, and everything now works perfectly...! Yeah!

  • richardburtondesign Level 1 (0 points)

    Thank you SO much!

    People in vodafone didn't have a clue. This is the solution, now I can finally rack up a mms bill haha

     

    Massive kudos to you OP!!!

     

    problem solved on iphone 5, iOs 6.1.2, vodafone

  • Scrumpygirl Level 1 (0 points)

    Thank you   I did the new update ios 6.1.3 and my phone stopped sending mms have been searching the web for hours I found your solution and now it works!! I am on Vodafone

  • Matthew Towland Level 2 (180 points)

    Worked for me.  Was very frustrating - thank you.

  • anthony birch Level 1 (0 points)

    a bit old now i know but i had the same problem and after speaking to vodafone they told me to change the mms apn to internet rather than wap.vodafone.co.uk and i was able to send mms straight away after turning off and switching back on again.

  • aliezh Level 1 (0 points)

    Thank you sooo much for this!!!

  • Paul Horrell Level 1 (10 points)

    Brilliant. I've had the exact same issue since I got the iphone 5 (my first iphone) in December. This solved it. I didn't even have to hit "reset settings", I just changed the password to wap.

Previous 1 2 Next