Previous 1 2 3 4 Next 127 Replies Latest reply: Jan 28, 2013 5:16 AM by AlexRmF Go to original post Branched to a new discussion.
  • rnordsg Level 1 Level 1

    Thanks, and I thought I was just the only one....

  • Oyitchy Level 1 Level 1

    was not when it first came out

  • WassimKad Level 1 Level 1

    Update iOS

  • Oyitchy Level 1 Level 1

     

     

    Update iOS

     

     

     

    If only it was that simple kid

  • p.gaensly Level 1 Level 1

    Still no reply from them.

    Here's the email :
    iphone-support@whatsapp.com

     

    We should all write to them so that we can pressure some sort of response. Maybe with enough complaints they will let ua use our old versions in peace!

     

    I startwd ysing whatsapp when you still had to buy it!

  • FelipeV Level 5 Level 5
    expertise.iphone
    iPhone

    Your beef is with Watsapp and not Apple. Thats the gist of the situation, which some here don't seem to understand....or want to accept.

  • lotr2010 Level 1 Level 1

    Hi there. Yup, same happened to me too earlier today! I had paid for the app too. I dont understand why these people have discontinued whatsapp for the IOS 4.2.1. Its quite ridiculous to be honest. Tried to install the version 2.8.4, 2.8.6 but all in vain. My phone is a brick now. Whatsapp, you'll haven't done your customers any good!

  • lotr2010 Level 1 Level 1

    No reply from their twitter handle too! Quite Ridculous!

  • Lexiepex Level 6 Level 6
    expertise.macosx
    Mac OS X

    There was an article on going back to an older version of an App.

    http://reviews.cnet.com/8301-19512_7-10345683-233.html

    read this, you might be able to reinstall the older version that works on 4.2.1

  • p.gaensly Level 1 Level 1

    tried installing the old app.... but the problem is Whatsapp says: this version is too old, download the updated version at app store.

     

    So they are not letting us use the old version! Whatsapp is the wrong one.

     

    We need to contact them and pressure for a solution. THis is ridiculous.

  • evedz Level 1 Level 1

    I have sent an email to whatsapp support.

    My mother's 3G suddenly requested the verification for whatsapp.

    Shame on developers for killing well-working program.

    Feel myself in hte prison now!

  • lotr2010 Level 1 Level 1

    This happened to me too yesterday. I sent a few mails to the Whatsapp customer support demanding a reply. I got one earlier this morning. Here it is -

     

    Hi,

    Thanks for your message.

    In order to connect to WhatsApp, or activate your number, you will need the latest version of WhatsApp - v2.8.7 - available from the App Store on your iPhone. Please note that iPod and iPad are not supported devices.

    The latest version of WhatsApp for iPhone requires iOS 4.3 or later. Regretfully, Apple does not allow new app updates to be compatible with both iOS 6 and older versions of iOS, effectively ending support for iPhone 3G and the original iPhone. Because of Apple's policy change to new App Store submissions, there is nothing we can do at this time for users with older versions of iOS.

    If you have an iPhone 3GS or newer device, please update to iOS 4.3 or later.
    If you have any other questions or concerns, please feel free to contact us. We would be happy to help!

     

    WhatsApp Support Team

  • lotr2010 Level 1 Level 1

    So its clear now that its not the app team which is to be blamed, but its Apple's new app store policies which are behind this one!

    Apple, you'll haven't done your customers any good!! 

  • lotr2010 Level 1 Level 1

    This happened to me too yesterday. I sent a few mails to the Whatsapp customer support demanding a reply. I got one earlier this morning. Here it is -

     

    Hi,

    Thanks for your message.

    In order to connect to WhatsApp, or activate your number, you will need the latest version of WhatsApp - v2.8.7 - available from the App Store on your iPhone. Please note that iPod and iPad are not supported devices.

    The latest version of WhatsApp for iPhone requires iOS 4.3 or later. Regretfully, Apple does not allow new app updates to be compatible with both iOS 6 and older versions of iOS, effectively ending support for iPhone 3G and the original iPhone. Because of Apple's policy change to new App Store submissions, there is nothing we can do at this time for users with older versions of iOS.

    If you have an iPhone 3GS or newer device, please update to iOS 4.3 or later.
    If you have any other questions or concerns, please feel free to contact us. We would be happy to help!

     

    WhatsApp Support Team

  • Oyitchy Level 1 Level 1

    KDLai wrote:

     

    Newer phone can do more and last till later of time, that's the truth.

     

    However, in the history, paid software would not expire itself when nothing is changed.  It's just like Office 97 can always works with Windows 98.  When consumers want more functions, they can choose later versions and newer hardware.  Consumers can have choices, and that's what called realistic.

     

    Whatsapp is proven to work w/ old version of iOS, and now just take it away.  I don't think Whatsapp can justify that, especially for whom bought it and helped it grow in last few years.

    Well said. Why should the origanal peaple who paid for it suffer . Before they did this they should of made two different versions completly and just left old version alone and just made a new one (this update), like KDLai says, we have a choice, which keeps peaple happy.

Previous 1 2 3 4 Next