Previous 1 2 Next 26 Replies Latest reply: Jan 23, 2013 10:46 PM by FreakyCamel
inthetrees Level 1 (0 points)

I am trying to print wireless with the same computer and same printer by taking the USB end of the printer cord and plugging it into the airport extreem router. It works fine for wireless internet.

  • PAHU Level 6 (15,920 points)

    If you previously had this printer connected to the Mac via USB cable and then disconnected the USB cable and connected it to the Airport router, then you will have to add the printer again. Because the printer currently in Print & Scan on the Mac is for the USB connection and will not print to the networked printer.


    So, open Print & Scan and select to add by clicking the plus button. With the Default view selected, the printer should appear in this view. If it does, select it. The Print Using menu should automatically select the appropriate printer driver and you can click Add to complete the print queue creation.


    Now you should be ready to print.

  • inthetrees Level 1 (0 points)

    After checking all cords that they are properly connected it does not find my printer when I click on the "+".

  • PAHU Level 6 (15,920 points)

    The Airport Extreme uses the Bonjour protocol to advertise the printer connected to its USB port. If you cannot see this printer then you could have an issue with the Bonjour protocol. To check this, you can use Safair, but you need to enable the Bonjour bookmark via Preferences > Bookmarks, as shown below.

    Bonjour Setting.png

    With this enabled you will now have a Bonjour entry and when selected, if the printer can be seen by the Mac it will be listed.

    Bonjour Bookmark.png

    So can you see your printer using this method?

  • inthetrees Level 1 (0 points)

    Nope. It just has in light grey lettering, No Websites available.

  • PAHU Level 6 (15,920 points)

    If you open Airport Utility and click on the Extreme base station, does it show the printer connected via USB?


    Also, have you tried turning off the power to the printer for a few minutes and then back on again?

  • inthetrees Level 1 (0 points)

    It's interesting to me that when I open Airport Utility I get an empty gray box with one of those continuing circles indicating that it is working on something and a message saying that: "No configured Airport base stations have been found. Airport Utility will continue searching." And it has been searching for 15 minutes with no change. But I know for a fact that I am getting my internet through the airport extreem router.


    Also, yes, I disconnected the power to the printer then turned it back on about 5 minutes later. Still nothing.


    I appreciate very much that you are continuing to help me on this.

  • PAHU Level 6 (15,920 points)

    Maybe this issue with the utility being unable to connect to the Extreme is tied in with the printer not appearing in the Add printer window or Safari > Bonjour. Even though your Internet is still working, I would be turning off the Airport Extreme for a couple of minutes and then turning back on. But, I would only do this if you have another option to gain Internet access. Because if there is something wrong with the Extreme, then turning it off and then back on could stop your Internet access.

  • inthetrees Level 1 (0 points)

    Unplugged the Extreme for a few minutes then plugged it back in and the internet works fine but still no printer. Maybe this is the end of the road, huh?

  • PAHU Level 6 (15,920 points)

    Can you connect to the Extreme with Airport Utility?

  • inthetrees Level 1 (0 points)

    Uhhhhh. How?

  • PAHU Level 6 (15,920 points)

    Like you tried before. Open Airport Utility and see if it connects to the Airport Extreme.


    Previously you said "I open Airport Utility I get an empty gray box with one of those continuing circles indicating that it is working on something and a message saying that: "No configured Airport base stations have been found."


    So I was wondering if this is still the case or has this been fixed since you turned the powered off the Extreme and turned it back on.

  • inthetrees Level 1 (0 points)

    Nothing has changed. I have disconnected the printer, airport extreme, my computer, all of them more than once and nothing changes.


    I have also recently tried to password protect my wifi and for the same reason I cannot. The same response of "No configured Airport base stations have been found" in Airport Utility.


    At the same time it says that I am connected to the internet.


    So this is what is confusing to me:

    I have a modem that has all the right lights blinking or solid on.

    I have an Airport Extreme that has its green light solid on.

    I have active wireless internet.

    But in Airport Utility they don't find any Airport base stations. Is the Extreme not a base station?

  • PAHU Level 6 (15,920 points)

    The Airport Extreme is a base station so it is unusual that the utility cannot find it. I do believe that this is related to the Mac's inability to see the printer when it is connected to the Extreme.


    Could you open Activity Monitor (Applications > Utilities) and in the top-right corner of the application, if it says "My Processes", change it to "All Processes". Then look through the list of processes for mDNSResponder. If you don't see it then you could try to manually start it by opening Terminal and typing the following command:


    sudo launchctl load /System/Library/LaunchDaemons/


    Then switch back to Activity Monitor and see if the process is running now. If not, the service is having trouble launching and this is stopping the Mac from seeing the printer (and impacting Airport Utility).


    You could then check the Console application (also in your Utilities folder) and see if there is any mention of Bonjour (Multicast DNS) crashing.

  • inthetrees Level 1 (0 points)

    I do see it. Do I double click on it? I'm getting a little wary.

Previous 1 2 Next