Previous 1 2 3 Next 31 Replies Latest reply: Nov 29, 2014 5:34 PM by artdrectr
Kayon87 Level 1 Level 1 (0 points)

     I have several devices that are conected to the internet at any given time. Including an iPhone 5, iPad 2, iMac 21" and several other computers. All my devices are connected to the internet through an Airport extreme. My internet download speeds are consistantly around 20-25 mbps, however when I try to load a web page on my iMac its like its 10 years ago and I am using dial up. And while waiting for my iMac to load the page if I try to load the same page on either my iPad or iPhone it will load instantly. Again all of my devices are connected to the same Airport extreme.

 

     At first I thought that it was Mediacom's crappy service but then I noticed that my other devices are working perfectly.

 

     Please help, this is extremely annoying considering I use this computer for work and I need constant and fast internet for my job.


iMac, OS X Mountain Lion (10.8.2)
  • Linc Davis Level 10 Level 10 (165,145 points)

    What model iMac?

    Wired or wireless connection?

    Has it always been slow? If not, did you change anything around the time it became slow?

  • Kayon87 Level 1 Level 1 (0 points)

    I have a 2011 iMac 21.5". 3.06 GHz Intel Core 2 Duo

     

    I mainly use wireless but it is still super slow when I switched to wired.

     

    It has not always been slow. This just started a couple months ago. About the time I was having a lot of trouble with my Mediacom service. Which is my I initially thought it was Mediacom. But I have fast speed on my other devices when connected to the same Airport Extreme.

  • MichelPM Level 6 Level 6 (9,885 points)

    How full is your hard drive?

    How much RAM memory is installed?

    How many apps at once do you run concurrently on your iMac?

    Do you run any anti-virus software or hard drive "cleaning" software like MacKeeper?

  • Linc Davis Level 10 Level 10 (165,145 points)

    Please click the link below, which leads to Apple's home page. Does it load slowly or at normal speed?

     

    http://17.149.160.49

  • Kayon87 Level 1 Level 1 (0 points)

    500 GB HD is maybe half full. 4 GB of RAM

     

    It will be slow if I have just Safari open or if I have everything open.

     

    I use VirusBarrier X6 and last week I reformated my computer thinking that I just had a Virus. It did not help. I did a 7 pass format.

  • Kayon87 Level 1 Level 1 (0 points)

    It loaded at normal speed. I cleared the cache and it loaded again at normal speed. however when I tried to switch between pages quickly it boged down and ran slow. Yahoo would not load. I only had one page open at a time.

  • davidsignal Level 3 Level 3 (525 points)

    If LInc's link is working, then you have some kind of DNS issue.  Try changing your DNS server to 8.8.8.8

  • MichelPM Level 6 Level 6 (9,885 points)

    Can you temporarily turn off Virus Barrier to see if this is slowing your system?

    Also in your iMac's Applications folder, locate the Utilities folder, open it and look for and launch Activity Monitor.

    Look at the Processes Tab and see if there is anything that is using a high percentage of your iMac's resources.

     

    Also, it may just be you need to install more RAM memory.

    if your iMac has a 3.06 Ghz CPU, then it is NOT a 2011 model, but a 2010 model iMac.

    OS X especially versions 10.7 Lion and 10.8 Mountain Lion use a lot of CPU, GPU, RAM and hard drive resources.

    The base 4 GBs that came with your iMac is not an ideal amount of RAM, but just enough to give sufficient operation of your iMac out of box.

    OS X, by itself needs between 2-4 GBs of RAM to operate smoothly and efficiently on its own.

    Start running extra applications on top of this and there will be more and more slow down of your iMac.

    Your iMac can take up to 32 GBs of RAM.

    I recomend installing, at least, another 4 GBs of RAM. If you can afford to install more, great then do that!

    But you could just start with only an additonal 4 GBs of RAM.

    You should see a speed improvement by just doubling the amount of RAM memory.

    Here are the RAM specs for your 2010 iMac.

    32 GB (Actual) 16 GB (Apple)
    Memory Slots4 - 204-pin PC3-10600 (1333 MHz) DDR3 SO-DIMM

     

    You can purchase reliable Mac RAM online from Mac RAM vendors Crucial memory or OWC ( also known as macsales)

     

    Good Luck!

  • Kayon87 Level 1 Level 1 (0 points)

    Wouldn't a DNS problem effect all my devices connected to that router?

  • Kayon87 Level 1 Level 1 (0 points)

    Actually I remember when this started happening.

     

    I had been having a lot of problems with my Internet provider, Mediacom. They had just been out to replace my modem with a new DOCSIS 3 modem/router. It's a Netgear. I

    This fixed my speed issues that I was having at the time. However I wanted to use my AirPort Extreme for my router. So the only way I could connect my airport to the Netgear was to put the Airport into bridge mode. This worked. But then this issue came up.

     

    Today I disconnected my AirPort Extreme and am only using the Netgear. But I am still having the issue.

  • davidsignal Level 3 Level 3 (525 points)

    If you can access the apple website using the IP address and it loads fine, but when you type in the actual domain name www.apple.com it causes a slow load, then it is definately related to DNS.   8.8.8.8 is google's public DNS and should work if, for some reason, your mac is not getting DNS requests correctly from the mediacom router.

  • Linc Davis Level 10 Level 10 (165,145 points)

    Wouldn't a DNS problem effect all my devices connected to that router?

     

    Not if the DNS settings are different. Are they?

  • KarenSelena Level 4 Level 4 (1,960 points)

    Could be internet plug ins....

     

    Try this - launch safari.  Reset safari, by clicking on the word safari beside the apple, then "reset safari".  Uncheck "Remove saved names and passwords" and "Reset Top Sites", but keep everything else checked, and reset it then quit safari.

     

    - click finder in the dock, so the word finder appears beside the apple.  Also note in the top menu, is the word "Go", click the go menu and then hold down your option key on your keyboard.  This will make a "library" appear under your home in the Go drop down.   Select the library, then go to your the safari folder.  Inside here, drag "webpageicons" to trash.

     

    - go back one screen and select the "preferences" folder - drag "com.apple.safari.plist" to trash

    - go back one screen and select the "internet plug ins" folder - this folder should be empty.  If it is not......drag what you see out to the desktop....not the trash, just in case you find you need one of them. 

    - launch safari and test it now

Previous 1 2 3 Next